Vulnerabilities

2 via 2 paths

Dependencies

269

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
  • 1
Status
  • 2
  • 0
  • 0

high severity
new

Information Exposure

  • Vulnerable module: simple-get
  • Introduced through: gl@4.9.2

Detailed paths

  • Introduced through: molstar@2.3.9 gl@4.9.2 prebuild-install@5.3.6 simple-get@3.1.0
    Remediation: Upgrade to molstar@3.0.0.

Overview

Affected versions of this package are vulnerable to Information Exposure. When getting Location response header after fetching a remote url with Cookie, it will follow that url and fetch it with the provided cookie which will be then leaked to the attacker .

Remediation

Upgrade simple-get to version 4.0.1 or higher.

References

medium severity

User Interface (UI) Misrepresentation of Critical Information

  • Vulnerable module: swagger-ui-dist
  • Introduced through: swagger-ui-dist@3.52.5

Detailed paths

  • Introduced through: molstar@2.3.9 swagger-ui-dist@3.52.5
    Remediation: Upgrade to molstar@2.4.0.

Overview

swagger-ui-dist is a module that exposes Swagger-UI's entire dist folder as a dependency-free npm module. Use swagger-ui instead, if you'd like to have npm install dependencies for you.

Affected versions of this package are vulnerable to User Interface (UI) Misrepresentation of Critical Information via the ?url parameter, which was intended to allow displaying remote OpenAPI definitions. This functionality may pose a risk for users who host their own SwaggerUI instances. In particular, including remote OpenAPI definitions opens a vector for phishing attacks by abusing the trusted names/domains of self-hosted instances.

Remediation

Upgrade swagger-ui-dist to version 4.1.3 or higher.

References