lumigo-cli@0.44.1

Vulnerabilities

2 via 4 paths

Dependencies

296

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
  • 1
Status
  • 2
  • 0
  • 0

high severity

Command Injection

  • Vulnerable module: lodash.template
  • Introduced through: @oclif/plugin-help@2.2.3 and @oclif/command@1.8.0

Detailed paths

  • Introduced through: lumigo-cli@0.44.1 @oclif/plugin-help@2.2.3 lodash.template@4.5.0
  • Introduced through: lumigo-cli@0.44.1 @oclif/command@1.8.0 @oclif/plugin-help@3.2.2 lodash.template@4.5.0
  • Introduced through: lumigo-cli@0.44.1 @oclif/plugin-help@2.2.3 @oclif/command@1.8.0 @oclif/plugin-help@3.2.2 lodash.template@4.5.0

Overview

lodash.template is a The Lodash method _.template exported as a Node.js module.

Affected versions of this package are vulnerable to Command Injection via template.

PoC

var _ = require('lodash');

_.template('', { variable: '){console.log(process.env)}; with(obj' })()

Remediation

There is no fixed version for lodash.template.

References

medium severity

Server-Side Request Forgery (SSRF)

  • Vulnerable module: axios
  • Introduced through: axios@0.19.2

Detailed paths

  • Introduced through: lumigo-cli@0.44.1 axios@0.19.2
    Remediation: Upgrade to axios@0.21.1.

Overview

axios is a promise based HTTP client for the browser and node.js.

Affected versions of this package are vulnerable to Server-Side Request Forgery (SSRF). An attacker is able to bypass a proxy by providing a URL that responds with a redirect to a restricted host or IP address.

Remediation

Upgrade axios to version 0.21.1 or higher.

References