loopback-connector-oracle@2.4.1

Vulnerabilities

3 via 3 paths

Dependencies

168

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 2
  • 1
Status
  • 3
  • 0
  • 0

high severity

Arbitrary File Overwrite

  • Vulnerable module: tar
  • Introduced through: loopback-oracle-installer@1.4.6

Detailed paths

  • Introduced through: loopback-connector-oracle@2.4.1 loopback-oracle-installer@1.4.6 tar@1.0.3
    Remediation: Upgrade to loopback-connector-oracle@3.0.0.

Overview

tar is a full-featured Tar for Node.js.

Affected versions of this package are vulnerable to Arbitrary File Overwrite. Extracting tarballs containing a hard-link to a file that already exists in the system, and a file that matches the hard-link may overwrite system's files with the contents of the extracted file.

Remediation

Upgrade tar to version 2.2.2, 4.4.2 or higher.

References

high severity

Symlink File Overwrite

  • Vulnerable module: tar
  • Introduced through: loopback-oracle-installer@1.4.6

Detailed paths

  • Introduced through: loopback-connector-oracle@2.4.1 loopback-oracle-installer@1.4.6 tar@1.0.3
    Remediation: Upgrade to loopback-connector-oracle@3.0.0.

Overview

tar is a full-featured Tar for Node.js.

Affected versions of this package are vulnerable to Symlink File Overwrite. It does not properly normalize symbolic links pointing to targets outside the extraction root. As a result, packages may hold symbolic links to parent and sibling directories and overwrite those files when the package is extracted.

Remediation

Upgrade tar to version 2.0.0 or higher.

References

medium severity

Denial of Service (DoS)

  • Vulnerable module: mem
  • Introduced through: loopback-connector@2.7.1

Detailed paths

  • Introduced through: loopback-connector-oracle@2.4.1 loopback-connector@2.7.1 strong-globalize@2.10.0 os-locale@2.1.0 mem@1.1.0
    Remediation: Upgrade to loopback-connector-oracle@3.1.0.

Overview

mem is an optimization used to speed up consecutive function calls by caching the result of calls with identical input.

Affected versions of this package are vulnerable to Denial of Service (DoS). Old results were deleted from the cache and could cause a memory leak.

details

Denial of Service (DoS) describes a family of attacks, all aimed at making a system inaccessible to its intended and legitimate users.

Unlike other vulnerabilities, DoS attacks usually do not aim at breaching security. Rather, they are focused on making websites and services unavailable to genuine users resulting in downtime.

One popular Denial of Service vulnerability is DDoS (a Distributed Denial of Service), an attack that attempts to clog network pipes to the system by generating a large volume of traffic from many machines.

When it comes to open source libraries, DoS vulnerabilities allow attackers to trigger such a crash or crippling of the service by using a flaw either in the application code or from the use of open source libraries.

Two common types of DoS vulnerabilities:

  • High CPU/Memory Consumption- An attacker sending crafted requests that could cause the system to take a disproportionate amount of time to process. For example, commons-fileupload:commons-fileupload.

  • Crash - An attacker sending crafted requests that could cause the system to crash. For Example, npm ws package

Remediation

Upgrade mem to version 4.0.0 or higher.

References