js-given@0.1.3-alpha.2

Vulnerabilities 2 via 2 paths
Dependencies 110
Source npm
Package js-given

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
  • 1
Status
  • 2
  • 0
  • 0
high severity

Arbitrary File Write via Archive Extraction (Zip Slip)

  • Vulnerable module: decompress-zip
  • Introduced through: decompress-zip@0.3.0

Detailed paths

  • Introduced through: js-given@0.1.3-alpha.2 decompress-zip@0.3.0
    Remediation: Upgrade to js-given@0.1.6.

Overview

decompress-zip extracts the contents of the ZIP archive file.

Affected versions of this package are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip). The package will extract files outside of the scope of the specified target directory because there is no validation that file extraction stays within the defined target path.

Details

It is exploited using a specially crafted zip archive, that holds path traversal filenames. When exploited, a filename in a malicious archive is concatenated to the target extraction directory, which results in the final path ending up outside of the target folder. For instance, a zip may hold a file with a "../../file.exe" location and thus break out of the target folder. If an executable or a configuration file is overwritten with a file containing malicious code, the problem can turn into an arbitrary code execution issue quite easily.

The following is an example of a zip archive with one benign file and one malicious file. Extracting the malicous file will result in traversing out of the target folder, ending up in /root/.ssh/ overwriting the authorized_keys file:


+2018-04-15 22:04:29 ..... 19 19 good.txt

+2018-04-15 22:04:42 ..... 20 20 ../../../../../../root/.ssh/authorized_keys

Remediation

Upgrade decompress-zip to version 0.2.2, 0.3.2 or higher.

References

medium severity

Denial of Service (DoS)

  • Vulnerable module: mem
  • Introduced through: yargs@8.0.2

Detailed paths

  • Introduced through: js-given@0.1.3-alpha.2 yargs@8.0.2 os-locale@2.1.0 mem@1.1.0
    Remediation: Upgrade to yargs@12.0.2.

Overview

mem is an optimization used to speed up consecutive function calls by caching the result of calls with identical input.

Affected versions of this package are vulnerable to Denial of Service (DoS). Old results were deleted from the cache and could cause a memory leak.

details

Denial of Service (DoS) describes a family of attacks, all aimed at making a system inaccessible to its intended and legitimate users.

Unlike other vulnerabilities, DoS attacks usually do not aim at breaching security. Rather, they are focused on making websites and services unavailable to genuine users resulting in downtime.

One popular Denial of Service vulnerability is DDoS (a Distributed Denial of Service), an attack that attempts to clog network pipes to the system by generating a large volume of traffic from many machines.

When it comes to open source libraries, DoS vulnerabilities allow attackers to trigger such a crash or crippling of the service by using a flaw either in the application code or from the use of open source libraries.

Two common types of DoS vulnerabilities:

  • High CPU/Memory Consumption- An attacker sending crafted requests that could cause the system to take a disproportionate amount of time to process. For example, commons-fileupload:commons-fileupload.

  • Crash - An attacker sending crafted requests that could cause the system to crash. For Example, npm ws package

Remediation

Upgrade mem to version 4.0.0 or higher.

References