google-auth-library@2.0.2

Vulnerabilities

1 via 2 paths

Dependencies

31

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
Status
  • 1
  • 0
  • 0

medium severity

Server-Side Request Forgery (SSRF)

  • Vulnerable module: axios
  • Introduced through: axios@0.18.1 and gcp-metadata@0.7.0

Detailed paths

  • Introduced through: google-auth-library@2.0.2 axios@0.18.1
    Remediation: Upgrade to google-auth-library@3.0.0.
  • Introduced through: google-auth-library@2.0.2 gcp-metadata@0.7.0 axios@0.18.1
    Remediation: Upgrade to google-auth-library@3.0.0.

Overview

axios is a promise based HTTP client for the browser and node.js.

Affected versions of this package are vulnerable to Server-Side Request Forgery (SSRF). An attacker is able to bypass a proxy by providing a URL that responds with a redirect to a restricted host or IP address.

Remediation

Upgrade axios to version 0.21.1 or higher.

References