desprite@1.1.0

Vulnerabilities

1 via 1 paths

Dependencies

13

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
Status
  • 1
  • 0
  • 0

medium severity

Remote Shell Command Injection

  • Vulnerable module: gm
  • Introduced through: gm@1.17.0

Detailed paths

  • Introduced through: desprite@1.1.0 gm@1.17.0
    Remediation: Upgrade to gm@1.21.0.

Overview

The gm package is the GraphicsMagick and ImageMagick wrapper for Node.js. The compare() function allows comparing of two images, taking as an input argument the path to both images. The function, in versions prior to 1.21.1, fails to sanitize the input correctly, making it vulnerable to a command injection attack.

Remediation

Upgrade gm to version 1.21.1 or greater.

If a direct dependency update is not possible, use snyk wizard to patch this vulnerability.

References