data-migration-cli@2.9.1

Vulnerabilities

1 via 4 paths

Dependencies

317

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
Status
  • 1
  • 0
  • 0

high severity

Command Injection

  • Vulnerable module: lodash.template
  • Introduced through: @oclif/plugin-help@2.2.3, @oclif/command@1.8.0 and others

Detailed paths

  • Introduced through: data-migration-cli@2.9.1 @oclif/plugin-help@2.2.3 lodash.template@4.5.0
  • Introduced through: data-migration-cli@2.9.1 @oclif/command@1.8.0 @oclif/plugin-help@3.2.2 lodash.template@4.5.0
  • Introduced through: data-migration-cli@2.9.1 @oclif/plugin-help@2.2.3 @oclif/command@1.8.0 @oclif/plugin-help@3.2.2 lodash.template@4.5.0
  • Introduced through: data-migration-cli@2.9.1 cli-ux@5.5.1 @oclif/command@1.8.0 @oclif/plugin-help@3.2.2 lodash.template@4.5.0

Overview

lodash.template is a The Lodash method _.template exported as a Node.js module.

Affected versions of this package are vulnerable to Command Injection via template.

PoC

var _ = require('lodash');

_.template('', { variable: '){console.log(process.env)}; with(obj' })()

Remediation

There is no fixed version for lodash.template.

References