bunjil@1.0.9

Vulnerabilities

2 via 3 paths

Dependencies

299

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
  • 1
Status
  • 2
  • 0
  • 0

high severity

Information Exposure

  • Vulnerable module: apollo-server-core
  • Introduced through: apollo-server-koa@1.4.0

Detailed paths

  • Introduced through: bunjil@1.0.9 apollo-server-koa@1.4.0 apollo-server-core@1.4.0
    Remediation: Upgrade to apollo-server-koa@2.1.0.

Overview

apollo-server-core is a core module of the Apollo community GraphQL Server.

Affected versions of this package are vulnerable to Information Exposure. It does not properly enforce validation rules when creating subscription servers, which includes a NoInstrospection rule for the Websocket. This leaks the GraphQL schema types, their relations and human-readable names.

Remediation

Upgrade apollo-server-core to version 2.4.12 or higher.

References

medium severity

Denial of Service

  • Vulnerable module: node-fetch
  • Introduced through: prisma-binding@1.5.19

Detailed paths

  • Introduced through: bunjil@1.0.9 prisma-binding@1.5.19 cross-fetch@2.0.0 node-fetch@2.0.0
  • Introduced through: bunjil@1.0.9 prisma-binding@1.5.19 http-link-dataloader@0.1.6 cross-fetch@2.2.2 node-fetch@2.1.2

Overview

node-fetch is an A light-weight module that brings window.fetch to node.js

Affected versions of this package are vulnerable to Denial of Service. Node Fetch did not honor the size option after following a redirect, which means that when a content size was over the limit, a FetchError would never get thrown and the process would end without failure.

Remediation

Upgrade node-fetch to version 2.6.1, 3.0.0-beta.9 or higher.

References