bbop-graph-noctua@0.0.13

Vulnerabilities

1 via 6 paths

Dependencies

4

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
Status
  • 1
  • 0
  • 0

medium severity

Arbitrary Code Injection

  • Vulnerable module: underscore
  • Introduced through: underscore@1.8.3, bbop-core@0.0.4 and others

Detailed paths

  • Introduced through: bbop-graph-noctua@0.0.13 underscore@1.8.3
    Remediation: Upgrade to underscore@1.12.1.
  • Introduced through: bbop-graph-noctua@0.0.13 bbop-core@0.0.4 underscore@1.8.3
  • Introduced through: bbop-graph-noctua@0.0.13 bbop-graph@0.0.13 underscore@1.8.3
  • Introduced through: bbop-graph-noctua@0.0.13 class-expression@0.0.7 underscore@1.8.3
  • Introduced through: bbop-graph-noctua@0.0.13 bbop-graph@0.0.13 bbop-core@0.0.4 underscore@1.8.3
  • Introduced through: bbop-graph-noctua@0.0.13 class-expression@0.0.7 bbop-core@0.0.4 underscore@1.8.3

Overview

underscore is a JavaScript's functional programming helper library.

Affected versions of this package are vulnerable to Arbitrary Code Injection via the template function, particularly when the variable option is taken from _.templateSettings as it is not sanitized.

PoC

const _ = require('underscore');
_.templateSettings.variable = "a = this.process.mainModule.require('child_process').execSync('touch HELLO')";
const t = _.template("")();

Remediation

Upgrade underscore to version 1.13.0-2, 1.12.1 or higher.

References