Vulnerabilities

2 via 2 paths

Dependencies

9

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 2
Status
  • 2
  • 0
  • 0

high severity
new

Denial of Service (DoS)

  • Vulnerable module: apollo-server-core
  • Introduced through: apollo-server-core@1.4.0

Detailed paths

  • Introduced through: apollo-server-express@1.3.6 apollo-server-core@1.4.0
    Remediation: Upgrade to apollo-server-express@3.0.0.

Overview

apollo-server-core is a core module of the Apollo community GraphQL Server.

Affected versions of this package are vulnerable to Denial of Service (DoS) by accepting an unbounded amount of memory in the cache.

NOTE: The size of a cache can be limited with the cache: "bounded" option as of version 3.9.0.

Details

Denial of Service (DoS) describes a family of attacks, all aimed at making a system inaccessible to its intended and legitimate users.

Unlike other vulnerabilities, DoS attacks usually do not aim at breaching security. Rather, they are focused on making websites and services unavailable to genuine users resulting in downtime.

One popular Denial of Service vulnerability is DDoS (a Distributed Denial of Service), an attack that attempts to clog network pipes to the system by generating a large volume of traffic from many machines.

When it comes to open source libraries, DoS vulnerabilities allow attackers to trigger such a crash or crippling of the service by using a flaw either in the application code or from the use of open source libraries.

Two common types of DoS vulnerabilities:

  • High CPU/Memory Consumption- An attacker sending crafted requests that could cause the system to take a disproportionate amount of time to process. For example, commons-fileupload:commons-fileupload.

  • Crash - An attacker sending crafted requests that could cause the system to crash. For Example, npm ws package

Remediation

Upgrade apollo-server-core to version 3.9.0 or higher.

References

high severity

Information Exposure

  • Vulnerable module: apollo-server-core
  • Introduced through: apollo-server-core@1.4.0

Detailed paths

  • Introduced through: apollo-server-express@1.3.6 apollo-server-core@1.4.0
    Remediation: Upgrade to apollo-server-express@2.1.0.

Overview

apollo-server-core is a core module of the Apollo community GraphQL Server.

Affected versions of this package are vulnerable to Information Exposure. It does not properly enforce validation rules when creating subscription servers, which includes a NoInstrospection rule for the Websocket. This leaks the GraphQL schema types, their relations and human-readable names.

Remediation

Upgrade apollo-server-core to version 2.14.2 or higher.

References