ans-javascript-sdk@4.4.5

Vulnerabilities

1 via 1 paths

Dependencies

115

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
Status
  • 1
  • 0
  • 0

high severity

Insecure Randomness

  • Vulnerable module: crypto-js
  • Introduced through: crypto-js@3.3.0

Detailed paths

  • Introduced through: ans-javascript-sdk@4.4.5 crypto-js@3.3.0
    Remediation: Upgrade to crypto-js@4.0.0.

Overview

crypto-js is a library of crypto standards.

Affected versions of this package are vulnerable to Insecure Randomness. The secureRandom() method is supposed to return a cryptographically strong pseudo-random data string, but it is biased to certain digits. An attacker could be able to guess the created digits.

Remediation

Upgrade crypto-js to version 4.0.0, 3.2.1 or higher.

References