@shopgate/pwa-core@6.14.0-beta.99

Vulnerabilities

2 via 2 paths

Dependencies

14

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
  • 1
Status
  • 2
  • 0
  • 0

high severity

Insecure Randomness

  • Vulnerable module: crypto-js
  • Introduced through: crypto-js@3.1.9-1

Detailed paths

  • Introduced through: @shopgate/pwa-core@6.14.0-beta.99 crypto-js@3.1.9-1
    Remediation: Upgrade to crypto-js@3.2.1.

Overview

crypto-js is a library of crypto standards.

Affected versions of this package are vulnerable to Insecure Randomness. The secureRandom() method is supposed to return a cryptographically strong pseudo-random data string, but it is biased to certain digits. An attacker could be able to guess the created digits.

Remediation

Upgrade crypto-js to version 4.0.0, 3.2.1 or higher.

References

medium severity

Denial of Service

  • Vulnerable module: node-fetch
  • Introduced through: isomorphic-fetch@2.2.1

Detailed paths

  • Introduced through: @shopgate/pwa-core@6.14.0-beta.99 isomorphic-fetch@2.2.1 node-fetch@1.7.3
    Remediation: Upgrade to isomorphic-fetch@3.0.0.

Overview

node-fetch is an A light-weight module that brings window.fetch to node.js

Affected versions of this package are vulnerable to Denial of Service. Node Fetch did not honor the size option after following a redirect, which means that when a content size was over the limit, a FetchError would never get thrown and the process would end without failure.

Remediation

Upgrade node-fetch to version 2.6.1, 3.0.0-beta.9 or higher.

References