Vulnerabilities

1 via 1 paths

Dependencies

136

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
Status
  • 1
  • 0
  • 0

medium severity
new

Information Exposure

  • Vulnerable module: node-fetch
  • Introduced through: puppeteer@10.4.0

Detailed paths

  • Introduced through: @scullyio/scully-plugin-extra@2.0.0-BETA.72406 puppeteer@10.4.0 node-fetch@2.6.1
    Remediation: Upgrade to puppeteer@13.1.2.

Overview

node-fetch is a light-weight module that brings window.fetch to node.js

Affected versions of this package are vulnerable to Information Exposure when fetching a remote url with Cookie, if it get a Location response header, it will follow that url and try to fetch that url with provided cookie. This can lead to forwarding secure headers to 3th party.

Remediation

Upgrade node-fetch to version 2.6.7, 3.1.1 or higher.

References