@pando/repository@0.3.0-alpha.5

Vulnerabilities

1 via 5 paths

Dependencies

268

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
Status
  • 1
  • 0
  • 0

medium severity

Denial of Service

  • Vulnerable module: node-fetch
  • Introduced through: @aragon/os@4.4.0

Detailed paths

  • Introduced through: @pando/repository@0.3.0-alpha.5 @aragon/os@4.4.0 @aragon/truffle-config-v4@1.0.1 @truffle/hdwallet-provider@1.2.6 @trufflesuite/web3-provider-engine@15.0.13-1 @trufflesuite/eth-json-rpc-middleware@4.4.2-1 fetch-ponyfill@4.1.0 node-fetch@1.7.3
  • Introduced through: @pando/repository@0.3.0-alpha.5 @aragon/os@4.4.0 @aragon/truffle-config-v4@1.0.1 @truffle/hdwallet-provider@1.2.6 @trufflesuite/web3-provider-engine@15.0.13-1 @trufflesuite/eth-json-rpc-filters@4.1.2-1 @trufflesuite/eth-json-rpc-middleware@4.4.2-1 fetch-ponyfill@4.1.0 node-fetch@1.7.3
  • Introduced through: @pando/repository@0.3.0-alpha.5 @aragon/os@4.4.0 @aragon/truffle-config-v4@1.0.1 @truffle/hdwallet-provider@1.2.6 @trufflesuite/web3-provider-engine@15.0.13-1 @trufflesuite/eth-json-rpc-infura@4.0.3-0 @trufflesuite/eth-json-rpc-middleware@4.4.2-1 fetch-ponyfill@4.1.0 node-fetch@1.7.3
  • Introduced through: @pando/repository@0.3.0-alpha.5 @aragon/os@4.4.0 @aragon/truffle-config-v4@1.0.1 @truffle/hdwallet-provider@1.2.6 @trufflesuite/web3-provider-engine@15.0.13-1 cross-fetch@2.2.3 node-fetch@2.1.2
  • Introduced through: @pando/repository@0.3.0-alpha.5 @aragon/os@4.4.0 @aragon/truffle-config-v4@1.0.1 @truffle/hdwallet-provider@1.2.6 @trufflesuite/web3-provider-engine@15.0.13-1 @trufflesuite/eth-json-rpc-infura@4.0.3-0 cross-fetch@2.2.3 node-fetch@2.1.2

Overview

node-fetch is an A light-weight module that brings window.fetch to node.js

Affected versions of this package are vulnerable to Denial of Service. Node Fetch did not honor the size option after following a redirect, which means that when a content size was over the limit, a FetchError would never get thrown and the process would end without failure.

Remediation

Upgrade node-fetch to version 2.6.1, 3.0.0-beta.9 or higher.

References