@logique/fastify-adapter@0.0.3-alpha.4

Vulnerabilities

2 via 2 paths

Dependencies

84

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 2
Status
  • 2
  • 0
  • 0

medium severity

Denial of Service (DoS)

  • Vulnerable module: fastify
  • Introduced through: fastify@1.14.6

Detailed paths

  • Introduced through: @logique/fastify-adapter@0.0.3-alpha.4 fastify@1.14.6
    Remediation: Upgrade to fastify@2.15.1.

Overview

fastify is an overhead web framework, for Node.js.

Affected versions of this package are vulnerable to Denial of Service (DoS). A denial of service vulnerability exists in Fastify v2.14.1 and v3.0.0-rc.4 that allows A malicious user can trigger resource exhaustion (when the allErrors option is used) with specially crafted schemas.

Details

Denial of Service (DoS) describes a family of attacks, all aimed at making a system inaccessible to its intended and legitimate users.

Unlike other vulnerabilities, DoS attacks usually do not aim at breaching security. Rather, they are focused on making websites and services unavailable to genuine users resulting in downtime.

One popular Denial of Service vulnerability is DDoS (a Distributed Denial of Service), an attack that attempts to clog network pipes to the system by generating a large volume of traffic from many machines.

When it comes to open source libraries, DoS vulnerabilities allow attackers to trigger such a crash or crippling of the service by using a flaw either in the application code or from the use of open source libraries.

Two common types of DoS vulnerabilities:

  • High CPU/Memory Consumption- An attacker sending crafted requests that could cause the system to take a disproportionate amount of time to process. For example, commons-fileupload:commons-fileupload.

  • Crash - An attacker sending crafted requests that could cause the system to crash. For Example, npm ws package

Remediation

Upgrade fastify to version 2.15.1 or higher.

References

medium severity

Web Cache Poisoning

  • Vulnerable module: find-my-way
  • Introduced through: fastify@1.14.6

Detailed paths

  • Introduced through: @logique/fastify-adapter@0.0.3-alpha.4 fastify@1.14.6 find-my-way@1.18.1
    Remediation: Upgrade to fastify@2.0.0.

Overview

Affected versions of this package are vulnerable to Web Cache Poisoning. It accepts the Accept-Version header by default, and if versioned routes are not being used, this could lead to a denial of service. Accept-Version can be used as an unkeyed header in a cache poisoning attack.

Remediation

Upgrade find-my-way to version 2.2.5, 3.0.5 or higher.

References