@adastradev/user-management-sdk@1.1.1

Vulnerabilities

3 via 7 paths

Dependencies

100

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 2
  • 1
Status
  • 3
  • 0
  • 0

high severity

Insecure Randomness

  • Vulnerable module: crypto-js
  • Introduced through: amazon-cognito-identity-js@3.3.3, aws-api-gateway-client@git+https://github.com/aregier/aws-api-gateway-client.git#issue/67 and others

Detailed paths

  • Introduced through: @adastradev/user-management-sdk@1.1.1 amazon-cognito-identity-js@3.3.3 crypto-js@3.3.0
    Remediation: Upgrade to @adastradev/user-management-sdk@2.4.5.
  • Introduced through: @adastradev/user-management-sdk@1.1.1 aws-api-gateway-client@git+https://github.com/aregier/aws-api-gateway-client.git#issue/67 crypto-js@3.3.0
  • Introduced through: @adastradev/user-management-sdk@1.1.1 @adastradev/serverless-discovery-sdk@0.0.7 aws-api-gateway-client@0.2.17 crypto-js@3.3.0
    Remediation: Upgrade to @adastradev/serverless-discovery-sdk@2.0.2.

Overview

crypto-js is a library of crypto standards.

Affected versions of this package are vulnerable to Insecure Randomness. The secureRandom() method is supposed to return a cryptographically strong pseudo-random data string, but it is biased to certain digits. An attacker could be able to guess the created digits.

Remediation

Upgrade crypto-js to version 4.0.0, 3.2.1 or higher.

References

high severity

Server-side Request Forgery (SSRF)

  • Vulnerable module: netmask
  • Introduced through: proxy-agent@3.1.1

Detailed paths

  • Introduced through: @adastradev/user-management-sdk@1.1.1 proxy-agent@3.1.1 pac-proxy-agent@3.0.1 pac-resolver@3.0.0 netmask@1.0.6
    Remediation: Upgrade to @adastradev/user-management-sdk@2.4.6.

Overview

netmask is a library to parse IPv4 CIDR blocks.

Affected versions of this package are vulnerable to Server-side Request Forgery (SSRF). It incorrectly evaluates individual IPv4 octets that contain octal strings as left-stripped integers, leading to an inordinate attack surface on hundreds of thousands of projects that rely on netmask to filter or evaluate IPv4 block ranges, both inbound and outbound.

For example, a remote unauthenticated attacker can request local resources using input data 0177.0.0.1 (127.0.0.1), which netmask evaluates as the public IP 177.0.0.1. Contrastingly, a remote authenticated or unauthenticated attacker can input the data 0127.0.0.01 (87.0.0.1) as localhost, yet the input data is a public IP and can potentially cause local and remote file inclusion (LFI/RFI). A remote authenticated or unauthenticated attacker can bypass packages that rely on netmask to filter IP address blocks to reach intranets, VPNs, containers, adjacent VPC instances, or LAN hosts, using input data such as 012.0.0.1 (10.0.0.1), which netmask evaluates as 12.0.0.1 (public).

Remediation

Upgrade netmask to version 2.0.1 or higher.

References

medium severity

Server-Side Request Forgery (SSRF)

  • Vulnerable module: axios
  • Introduced through: @adastradev/serverless-discovery-sdk@0.0.7, axios@0.19.2 and others

Detailed paths

  • Introduced through: @adastradev/user-management-sdk@1.1.1 @adastradev/serverless-discovery-sdk@0.0.7 aws-api-gateway-client@0.2.17 axios@0.18.1
    Remediation: Upgrade to @adastradev/serverless-discovery-sdk@2.0.2.
  • Introduced through: @adastradev/user-management-sdk@1.1.1 axios@0.19.2
    Remediation: Upgrade to @adastradev/user-management-sdk@2.4.3.
  • Introduced through: @adastradev/user-management-sdk@1.1.1 aws-api-gateway-client@git+https://github.com/aregier/aws-api-gateway-client.git#issue/67 axios@0.19.2

Overview

axios is a promise based HTTP client for the browser and node.js.

Affected versions of this package are vulnerable to Server-Side Request Forgery (SSRF). An attacker is able to bypass a proxy by providing a URL that responds with a redirect to a restricted host or IP address.

Remediation

Upgrade axios to version 0.21.1 or higher.

References