vscode-contrib/vscode-versionlens

Shows the latest version for each package using code lens.
Vulnerabilities 4 via 4 paths
Dependencies 432
Source GitHub
Commit d44bfa5d

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
  • 3
Status
  • 4
  • 0
  • 0
medium severity

Time of Check Time of Use (TOCTOU)

  • Vulnerable module: chownr
  • Introduced through: npm@6.5.0

Detailed paths

  • Introduced through: vscode-versionlens@vscode-contrib/vscode-versionlens#d44bfa5d17f419754f29d586a771a371fdda2d2b npm@6.5.0 chownr@1.0.1
    Remediation: Upgrade to npm@6.6.0.

Overview

chownr is a package that takes the same arguments as fs.chown()

Affected versions of this package are vulnerable to Time of Check Time of Use (TOCTOU). Affected versions of this package are vulnerable toTime of Check Time of Use (TOCTOU) attacks.

It does not dereference symbolic links and changes the owner of the link, which can trick it into descending into unintended trees if a non-symlink is replaced by a symlink at a critical moment:

      fs.lstat(pathChild, function(er, stats) {
        if (er)
          return cb(er)
        if (!stats.isSymbolicLink())
          chownr(pathChild, uid, gid, then)

Remediation

Upgrade chownr to version 1.1.0 or higher.

References

low severity
new

Arbitrary File Overwrite

  • Vulnerable module: npm
  • Introduced through: npm@6.5.0

Detailed paths

  • Introduced through: vscode-versionlens@vscode-contrib/vscode-versionlens#d44bfa5d17f419754f29d586a771a371fdda2d2b npm@6.5.0
    Remediation: Upgrade to npm@6.13.4.

Overview

npm is a a package manager for JavaScript.

Affected versions of this package are vulnerable to Arbitrary File Overwrite. It fails to prevent existing globally-installed binaries to be overwritten by other package installations. For example, if a package was installed globally and created a serve binary, any subsequent installs of packages that also create a serve binary would overwrite the first binary. This only affects files in /usr/local/bin.

For npm, this behaviour is still allowed in local installations and also through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.

Remediation

Upgrade npm to version 6.13.4 or higher.

References

low severity
new

Arbitrary File Write

  • Vulnerable module: npm
  • Introduced through: npm@6.5.0

Detailed paths

  • Introduced through: vscode-versionlens@vscode-contrib/vscode-versionlens#d44bfa5d17f419754f29d586a771a371fdda2d2b npm@6.5.0
    Remediation: Upgrade to npm@6.13.3.

Overview

npm is a a package manager for JavaScript.

Affected versions of this package are vulnerable to Arbitrary File Write. It fails to prevent access to folders outside of the intended node_modules folder through the bin field.

For npm, a properly constructed entry in the package.json bin field would allow a package publisher to modify and/or gain access to arbitrary files on a user’s system when the package is installed. This behaviour is possible through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.

Remediation

Upgrade npm to version 6.13.3 or higher.

References

low severity
new

Unauthorized File Access

  • Vulnerable module: npm
  • Introduced through: npm@6.5.0

Detailed paths

  • Introduced through: vscode-versionlens@vscode-contrib/vscode-versionlens#d44bfa5d17f419754f29d586a771a371fdda2d2b npm@6.5.0
    Remediation: Upgrade to npm@6.13.3.

Overview

npm is a a package manager for JavaScript.

Affected versions of this package are vulnerable to Unauthorized File Access. It is possible for packages to create symlinks to files outside of thenode_modules folder through the bin field upon installation.

For npm, a properly constructed entry in the package.json bin field would allow a package publisher to create a symlink pointing to arbitrary files on a user’s system when the package is installed. This behaviour is possible through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.

Remediation

Upgrade npm to version 6.13.3 or higher.

References