Vulnerabilities

3 via 6 paths

Dependencies

355

Source

GitHub

Commit

57f58db4

Find, fix and prevent vulnerabilities in your code.

Severity
  • 2
  • 1
Status
  • 3
  • 0
  • 0

high severity

Denial of Service (DoS)

  • Vulnerable module: apollo-server-core
  • Introduced through: apollo-server@2.26.0

Detailed paths

  • Introduced through: moleculer-api@qmit-pro/moleculer-api#57f58db43cb0d8b0e8f4603119b0b642dcbe7781 apollo-server@2.26.0 apollo-server-core@2.26.0
    Remediation: Upgrade to apollo-server@3.0.0.
  • Introduced through: moleculer-api@qmit-pro/moleculer-api#57f58db43cb0d8b0e8f4603119b0b642dcbe7781 apollo-server@2.26.0 apollo-server-express@2.26.0 apollo-server-core@2.26.0
    Remediation: Upgrade to apollo-server@3.0.0.

Overview

apollo-server-core is a core module of the Apollo community GraphQL Server.

Affected versions of this package are vulnerable to Denial of Service (DoS) by accepting an unbounded amount of memory in the cache.

NOTE: The size of a cache can be limited with the cache: "bounded" option as of version 3.9.0.

Details

Denial of Service (DoS) describes a family of attacks, all aimed at making a system inaccessible to its intended and legitimate users.

Unlike other vulnerabilities, DoS attacks usually do not aim at breaching security. Rather, they are focused on making websites and services unavailable to genuine users resulting in downtime.

One popular Denial of Service vulnerability is DDoS (a Distributed Denial of Service), an attack that attempts to clog network pipes to the system by generating a large volume of traffic from many machines.

When it comes to open source libraries, DoS vulnerabilities allow attackers to trigger such a crash or crippling of the service by using a flaw either in the application code or from the use of open source libraries.

Two common types of DoS vulnerabilities:

  • High CPU/Memory Consumption- An attacker sending crafted requests that could cause the system to take a disproportionate amount of time to process. For example, commons-fileupload:commons-fileupload.

  • Crash - An attacker sending crafted requests that could cause the system to crash. For Example, npm ws package

Remediation

Upgrade apollo-server-core to version 3.9.0 or higher.

References

high severity

Denial of Service (DoS)

  • Vulnerable module: dicer
  • Introduced through: busboy@0.3.1 and apollo-server@2.26.0

Detailed paths

  • Introduced through: moleculer-api@qmit-pro/moleculer-api#57f58db43cb0d8b0e8f4603119b0b642dcbe7781 busboy@0.3.1 dicer@0.3.0
  • Introduced through: moleculer-api@qmit-pro/moleculer-api#57f58db43cb0d8b0e8f4603119b0b642dcbe7781 apollo-server@2.26.0 apollo-server-core@2.26.0 @apollographql/graphql-upload-8-fork@8.1.3 busboy@0.3.1 dicer@0.3.0
  • Introduced through: moleculer-api@qmit-pro/moleculer-api#57f58db43cb0d8b0e8f4603119b0b642dcbe7781 apollo-server@2.26.0 apollo-server-express@2.26.0 apollo-server-core@2.26.0 @apollographql/graphql-upload-8-fork@8.1.3 busboy@0.3.1 dicer@0.3.0

Overview

Affected versions of this package are vulnerable to Denial of Service (DoS). A malicious attacker can send a modified form to server, and crash the nodejs service. An attacker could sent the payload again and again so that the service continuously crashes.

PoC:

    fetch('form-image', {
      method: 'POST',
      headers: {
        ['content-type']: 'multipart/form-data; boundary=----WebKitFormBoundaryoo6vortfDzBsDiro',
        ['content-length']: '145',
        host: '127.0.0.1:8000',
        connection: 'keep-alive',
      },
      body: '------WebKitFormBoundaryoo6vortfDzBsDiro\r\n Content-Disposition: form-data; name="bildbeschreibung"\r\n\r\n\r\n------WebKitFormBoundaryoo6vortfDzBsDiro--'
    });

Remediation

There is no fixed version for dicer.

References

medium severity

Open Redirect

  • Vulnerable module: got
  • Introduced through: openid-client@3.15.10

Detailed paths

  • Introduced through: moleculer-api@qmit-pro/moleculer-api#57f58db43cb0d8b0e8f4603119b0b642dcbe7781 openid-client@3.15.10 got@9.6.0
    Remediation: Upgrade to openid-client@4.0.0.

Overview

Affected versions of this package are vulnerable to Open Redirect due to missing verification of requested URLs. It allowed a victim to be redirected to a UNIX socket.

Remediation

Upgrade got to version 11.8.5, 12.1.0 or higher.

References