mean

MEAN.io: A fullstack JavaScript framework powered by MongoDB, ExpressJS, AngularJS, NodeJS.

Known vulnerabilities3
Vulnerable paths7
Dependencies789

Command Injection

high severity
  • Vulnerable module: shelljs
  • Introduced through: shelljs@0.7.7 and meanio@0.9.4

Detailed paths

  • Introduced through: mean@linnovate/mean#dcc36c421ca80be8cbcad659104c50b778f63141 shelljs@0.7.7
  • Introduced through: mean@linnovate/mean#dcc36c421ca80be8cbcad659104c50b778f63141 meanio@0.9.4 shelljs@0.7.7

Overview

shelljs is a portable Unix shell commands for Node.js. It is possible to invoke commands from shell.exec() from external sources, allowing an attacker to inject arbitrary commands.

Remediation

There is no fix version for shelljs.

References

Prototype Override Protection Bypass

high severity
  • Vulnerable module: qs
  • Introduced through: connect-modrewrite@0.9.0

Detailed paths

  • Introduced through: mean@linnovate/mean#dcc36c421ca80be8cbcad659104c50b778f63141 connect-modrewrite@0.9.0 qs@1.2.2

Overview

qs is a querystring parser that supports nesting and arrays, with a depth limit.

By default qs protects against attacks that attempt to overwrite an object's existing prototype properties, such as toString(), hasOwnProperty(),etc.

From qs documentation:

By default parameters that would overwrite properties on the object prototype are ignored, if you wish to keep the data from those fields either use plainObjects as mentioned above, or set allowPrototypes to true which will allow user input to overwrite those properties. WARNING It is generally a bad idea to enable this option as it can cause problems when attempting to use the properties that have been overwritten. Always be careful with this option.

Overwriting these properties can impact application logic, potentially allowing attackers to work around security controls, modify data, make the application unstable and more.

In versions of the package affected by this vulnerability, it is possible to circumvent this protection and overwrite prototype properties and functions by prefixing the name of the parameter with [ or ]. e.g. qs.parse("]=toString") will return {toString = true}, as a result, calling toString() on the object will throw an exception.

Example:

qs.parse('toString=foo', { allowPrototypes: false })
            // {}
            
            qs.parse("]=toString", { allowPrototypes: false })
            // {toString = true} <== prototype overwritten
            

For more information, you can check out our blog.

Disclosure Timeline

  • February 13th, 2017 - Reported the issue to package owner.
  • February 13th, 2017 - Issue acknowledged by package owner.
  • February 16th, 2017 - Partial fix released in versions 6.0.3, 6.1.1, 6.2.2, 6.3.1.
  • March 6th, 2017 - Final fix released in versions 6.4.0,6.3.2, 6.2.3, 6.1.2 and 6.0.4

Remediation

Upgrade qs to version 6.4.0 or higher. Note: The fix was backported to the following versions 6.3.2, 6.2.3, 6.1.2, 6.0.4.

References

Regular Expression Denial of Service (DoS)

Vulnerability patched for: meanio@0.9.4.

medium severity
  • Vulnerable module: uglify-js
  • Introduced through: meanio@0.9.4

Detailed paths

  • Introduced through: mean@linnovate/mean#dcc36c421ca80be8cbcad659104c50b778f63141 meanio@0.9.4 swig@1.4.2 uglify-js@2.4.24

Overview

The parse() function in the uglify-js package prior to version 2.6.0 is vulnerable to regular expression denial of service (ReDoS) attacks when long inputs of certain patterns are processed.

Details

"The Regular expression Denial of Service (ReDoS) is a Denial of Service attack, that exploits the fact that most Regular Expression implementations may reach extreme situations that cause them to work very slowly (exponentially related to input size). An attacker can then cause a program using a Regular Expression to enter these extreme situations and then hang for a very long time." 1

Remediation

Upgrade to version 2.6.0 or greater. If a direct dependency update is not possible, use snyk wizard to patch this vulnerability.

References

Regular Expression Denial of Service (ReDoS)

low severity
  • Vulnerable module: ms
  • Introduced through: compression@1.6.2, helmet@2.3.0 and others

Detailed paths

  • Introduced through: mean@linnovate/mean#dcc36c421ca80be8cbcad659104c50b778f63141 compression@1.6.2 debug@2.2.0 ms@0.7.1
  • Introduced through: mean@linnovate/mean#dcc36c421ca80be8cbcad659104c50b778f63141 helmet@2.3.0 connect@3.4.1 debug@2.2.0 ms@0.7.1
  • Introduced through: mean@linnovate/mean#dcc36c421ca80be8cbcad659104c50b778f63141 meanio@0.9.4 morgan@1.5.3 debug@2.2.0 ms@0.7.1
  • Introduced through: mean@linnovate/mean#dcc36c421ca80be8cbcad659104c50b778f63141 helmet@2.3.0 connect@3.4.1 finalhandler@0.4.1 debug@2.2.0 ms@0.7.1

Overview

ms is a tiny milisecond conversion utility. Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) due to an incomplete fix for previously reported vulnerability npm:ms:20151024. The fix limited the length of accepted input string to 10,000 characters, and turned to be insufficient making it possible to block the event loop for 0.3 seconds (on a typical laptop) with a specially crafted string passed to ms() function.

Proof of concept

ms = require('ms');
            ms('1'.repeat(9998) + 'Q') // Takes about ~0.3s
            

Note: Snyk's patch for this vulnerability limits input length to 100 characters. This new limit was deemed to be a breaking change by the author. Based on user feedback, we believe the risk of breakage is very low, while the value to your security is much greater, and therefore opted to still capture this change in a patch for earlier versions as well. Whenever patching security issues, we always suggest to run tests on your code to validate that nothing has been broken.

For more information on Regular Expression Denial of Service (ReDoS) attacks, go to our blog.

Disclosure Timeline

  • Feb 9th, 2017 - Reported the issue to package owner.
  • Feb 11th, 2017 - Issue acknowledged by package owner.
  • April 12th, 2017 - Fix PR opened by Snyk Security Team.
  • May 15th, 2017 - Vulnerability published.
  • May 16th, 2017 - Issue fixed and version 2.0.0 released.
  • May 21th, 2017 - Patches released for versions >=0.7.1, <=1.0.0.

Remediation

Upgrade ms to version 2.0.0 or higher.

References