deliveredtechnologies/terraform-maven:tf-build-tools/tf-maven-plugin/pom.xml

Vulnerabilities

3 via 16 paths

Dependencies

86

Source

GitHub

Commit

e5f81cc3

Find, fix and prevent vulnerabilities in your code.

Severity
  • 2
  • 1
Status
  • 3
  • 0
  • 0

high severity

XML External Entity (XXE) Injection

  • Vulnerable module: dom4j:dom4j
  • Introduced through: org.apache.maven.plugins:maven-dependency-plugin@3.1.1

Detailed paths

  • Introduced through: deliveredtechnologies/terraform-maven@deliveredtechnologies/terraform-maven#e5f81cc39b43f898920aeb68f302b331b502a0d9 org.apache.maven.plugins:maven-dependency-plugin@3.1.1 org.apache.maven.doxia:doxia-site-renderer@1.4 org.apache.velocity:velocity-tools@2.0 dom4j:dom4j@1.1
  • Introduced through: deliveredtechnologies/terraform-maven@deliveredtechnologies/terraform-maven#e5f81cc39b43f898920aeb68f302b331b502a0d9 org.apache.maven.plugins:maven-dependency-plugin@3.1.1 org.apache.maven.reporting:maven-reporting-impl@2.3 org.apache.maven.doxia:doxia-site-renderer@1.4 org.apache.velocity:velocity-tools@2.0 dom4j:dom4j@1.1

Overview

dom4j:dom4j is a flexible XML framework for Java. Note: this artifact has been deprecated for org.dom4j:dom4j.

Affected versions of this package are vulnerable to XML External Entity (XXE) Injection due to not validating the QName inputs.

Details

XXE Injection is a type of attack against an application that parses XML input. XML is a markup language that defines a set of rules for encoding documents in a format that is both human-readable and machine-readable. By default, many XML processors allow specification of an external entity, a URI that is dereferenced and evaluated during XML processing. When an XML document is being parsed, the parser can make a request and include the content at the specified URI inside of the XML document.

Attacks can include disclosing local files, which may contain sensitive data such as passwords or private user data, using file: schemes or relative paths in the system identifier.

For example, below is a sample XML document, containing an XML element- username.

<?xml version="1.0" encoding="ISO-8859-1"?>
   <username>John</username>
</xml>

An external XML entity - xxe, is defined using a system identifier and present within a DOCTYPE header. These entities can access local or remote content. For example the below code contains an external XML entity that would fetch the content of /etc/passwd and display it to the user rendered by username.

<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE foo [
   <!ENTITY xxe SYSTEM "file:///etc/passwd" >]>
   <username>&xxe;</username>
</xml>

Other XXE Injection attacks can access local resources that may not stop returning data, possibly impacting application availability and leading to Denial of Service.

Remediation

References

high severity

Command Injection

  • Vulnerable module: org.apache.maven.shared:maven-shared-utils
  • Introduced through: org.apache.maven.plugins:maven-dependency-plugin@3.1.1, org.apache.maven.shared:maven-invoker@3.0.1 and others

Detailed paths

  • Introduced through: deliveredtechnologies/terraform-maven@deliveredtechnologies/terraform-maven#e5f81cc39b43f898920aeb68f302b331b502a0d9 org.apache.maven.plugins:maven-dependency-plugin@3.1.1 org.apache.maven.shared:maven-shared-utils@3.2.0
  • Introduced through: deliveredtechnologies/terraform-maven@deliveredtechnologies/terraform-maven#e5f81cc39b43f898920aeb68f302b331b502a0d9 org.apache.maven.shared:maven-invoker@3.0.1 org.apache.maven.shared:maven-shared-utils@3.2.0
  • Introduced through: deliveredtechnologies/terraform-maven@deliveredtechnologies/terraform-maven#e5f81cc39b43f898920aeb68f302b331b502a0d9 org.apache.maven.plugins:maven-dependency-plugin@3.1.1 org.apache.maven.reporting:maven-reporting-impl@2.3 org.apache.maven.shared:maven-shared-utils@3.2.0
  • Introduced through: deliveredtechnologies/terraform-maven@deliveredtechnologies/terraform-maven#e5f81cc39b43f898920aeb68f302b331b502a0d9 org.apache.maven.plugins:maven-dependency-plugin@3.1.1 org.apache.maven.shared:file-management@3.0.0 org.apache.maven.shared:maven-shared-utils@3.2.0
  • Introduced through: deliveredtechnologies/terraform-maven@deliveredtechnologies/terraform-maven#e5f81cc39b43f898920aeb68f302b331b502a0d9 org.apache.maven.plugins:maven-dependency-plugin@3.1.1 org.apache.maven.shared:maven-common-artifact-filters@3.0.1 org.apache.maven.shared:maven-shared-utils@3.2.0
  • Introduced through: deliveredtechnologies/terraform-maven@deliveredtechnologies/terraform-maven#e5f81cc39b43f898920aeb68f302b331b502a0d9 org.apache.maven.plugins:maven-dependency-plugin@3.1.1 org.apache.maven.shared:file-management@3.0.0 org.apache.maven.shared:maven-shared-io@3.0.0 org.apache.maven.shared:maven-shared-utils@3.2.0
  • Introduced through: deliveredtechnologies/terraform-maven@deliveredtechnologies/terraform-maven#e5f81cc39b43f898920aeb68f302b331b502a0d9 org.apache.maven.plugins:maven-dependency-plugin@3.1.1 org.apache.maven.shared:maven-artifact-transfer@0.9.1 org.apache.maven.shared:maven-common-artifact-filters@3.0.1 org.apache.maven.shared:maven-shared-utils@3.2.0
  • Introduced through: deliveredtechnologies/terraform-maven@deliveredtechnologies/terraform-maven#e5f81cc39b43f898920aeb68f302b331b502a0d9 org.apache.maven.plugins:maven-deploy-plugin@3.0.0-M1 org.apache.maven.shared:maven-artifact-transfer@0.9.1 org.apache.maven.shared:maven-common-artifact-filters@3.0.1 org.apache.maven.shared:maven-shared-utils@3.2.0

Overview

org.apache.maven.shared:maven-shared-utils is a functional replacement for plexus-utils in Maven.

Affected versions of this package are vulnerable to Command Injection. The Commandline class can emit double-quoted strings without proper escaping, allowing shell injection attacks. The BourneShell class should unconditionally single-quote emitted strings (including the name of the command itself being quoted), with {{'"'"'}} used for embedded single quotes, for maximum safety across shells implementing a superset of POSIX quoting rules.

This is a similar issue to SNYK-JAVA-ORGCODEHAUSPLEXUS-31522

Remediation

Upgrade org.apache.maven.shared:maven-shared-utils to version 3.3.3 or higher.

References

low severity

Information Exposure

  • Vulnerable module: commons-codec:commons-codec
  • Introduced through: org.apache.maven.doxia:doxia-core@1.9, org.apache.maven.plugins:maven-dependency-plugin@3.1.1 and others

Detailed paths

  • Introduced through: deliveredtechnologies/terraform-maven@deliveredtechnologies/terraform-maven#e5f81cc39b43f898920aeb68f302b331b502a0d9 org.apache.maven.doxia:doxia-core@1.9 org.apache.httpcomponents:httpclient@4.5.8 commons-codec:commons-codec@1.6
  • Introduced through: deliveredtechnologies/terraform-maven@deliveredtechnologies/terraform-maven#e5f81cc39b43f898920aeb68f302b331b502a0d9 org.apache.maven.plugins:maven-dependency-plugin@3.1.1 org.apache.maven.shared:maven-artifact-transfer@0.9.1 commons-codec:commons-codec@1.6
  • Introduced through: deliveredtechnologies/terraform-maven@deliveredtechnologies/terraform-maven#e5f81cc39b43f898920aeb68f302b331b502a0d9 org.apache.maven.plugins:maven-deploy-plugin@3.0.0-M1 org.apache.maven.shared:maven-artifact-transfer@0.9.1 commons-codec:commons-codec@1.6
  • Introduced through: deliveredtechnologies/terraform-maven@deliveredtechnologies/terraform-maven#e5f81cc39b43f898920aeb68f302b331b502a0d9 org.apache.maven.plugins:maven-dependency-plugin@3.1.1 org.apache.maven.doxia:doxia-site-renderer@1.4 org.apache.maven.doxia:doxia-core@1.9 org.apache.httpcomponents:httpclient@4.5.8 commons-codec:commons-codec@1.6
  • Introduced through: deliveredtechnologies/terraform-maven@deliveredtechnologies/terraform-maven#e5f81cc39b43f898920aeb68f302b331b502a0d9 org.apache.maven.plugins:maven-dependency-plugin@3.1.1 org.apache.maven.reporting:maven-reporting-impl@2.3 org.apache.maven.doxia:doxia-core@1.9 org.apache.httpcomponents:httpclient@4.5.8 commons-codec:commons-codec@1.6
  • Introduced through: deliveredtechnologies/terraform-maven@deliveredtechnologies/terraform-maven#e5f81cc39b43f898920aeb68f302b331b502a0d9 org.apache.maven.plugins:maven-dependency-plugin@3.1.1 org.apache.maven.reporting:maven-reporting-impl@2.3 org.apache.maven.doxia:doxia-site-renderer@1.4 org.apache.maven.doxia:doxia-core@1.9 org.apache.httpcomponents:httpclient@4.5.8 commons-codec:commons-codec@1.6

Overview

commons-codec:commons-codec is a package that contains simple encoder and decoders for various formats such as Base64 and Hexadecimal.

Affected versions of this package are vulnerable to Information Exposure. When there is no byte array value that can be encoded into a string the Base32 implementation does not reject it, and instead decodes it into an arbitrary value which can be re-encoded again using the same implementation. This allows for information exposure exploits such as tunneling additional information via seemingly valid base 32 strings.

Remediation

Upgrade commons-codec:commons-codec to version 1.13 or higher.

References