Docker golang:1.14-alpine3.12

Vulnerabilities

7 via 13 paths

Dependencies

15

Source

Group 6 Copy Created with Sketch. Docker

Target OS

alpine:3.12.3
Test your Docker Hub image against our market leading vulnerability database Sign up for free
Severity
  • 4
  • 2
  • 1
Status
  • 7
  • 0
  • 0

high severity

Out-of-bounds Read

  • Vulnerable module: apk-tools/apk-tools
  • Introduced through: apk-tools/apk-tools@2.10.5-r1
  • Fixed in: 2.10.6-r0

Detailed paths

  • Introduced through: golang:1.14-alpine3.12@* apk-tools/apk-tools@2.10.5-r1

NVD Description

Note: Versions mentioned in the description apply to the upstream apk-tools package. See Remediation section below for Alpine:3.12 relevant versions.

In Alpine Linux apk-tools before 2.12.5, the tarball parser allows a buffer overflow and crash.

Remediation

Upgrade Alpine:3.12 apk-tools to version 2.10.6-r0 or higher.

References

high severity

Improper Handling of Exceptional Conditions

  • Vulnerable module: busybox/busybox
  • Introduced through: busybox/busybox@1.31.1-r19 and busybox/ssl_client@1.31.1-r19
  • Fixed in: 1.31.1-r20

Detailed paths

  • Introduced through: golang:1.14-alpine3.12@* busybox/busybox@1.31.1-r19
  • Introduced through: golang:1.14-alpine3.12@* busybox/ssl_client@1.31.1-r19

NVD Description

Note: Versions mentioned in the description apply to the upstream busybox package. See Remediation section below for Alpine:3.12 relevant versions.

decompress_gunzip.c in BusyBox through 1.32.1 mishandles the error bit on the huft_build result pointer, with a resultant invalid free or segmentation fault, via malformed gzip data.

Remediation

Upgrade Alpine:3.12 busybox to version 1.31.1-r20 or higher.

References

high severity

Improper Certificate Validation

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1i-r0 and openssl/libssl1.1@1.1.1i-r0
  • Fixed in: 1.1.1k-r0

Detailed paths

  • Introduced through: golang:1.14-alpine3.12@* openssl/libcrypto1.1@1.1.1i-r0
  • Introduced through: golang:1.14-alpine3.12@* openssl/libssl1.1@1.1.1i-r0

NVD Description

Note: Versions mentioned in the description apply to the upstream openssl package. See Remediation section below for Alpine:3.12 relevant versions.

The X509_V_FLAG_X509_STRICT flag enables additional security checks of the certificates present in a certificate chain. It is not set by default. Starting from OpenSSL version 1.1.1h a check to disallow certificates in the chain that have explicitly encoded elliptic curve parameters was added as an additional strict check. An error in the implementation of this check meant that the result of a previous check to confirm that certificates in the chain are valid CA certificates was overwritten. This effectively bypasses the check that non-CA certificates must not be able to issue other certificates. If a "purpose" has been configured then there is a subsequent opportunity for checks that the certificate is a valid CA. All of the named "purpose" values implemented in libcrypto perform this check. Therefore, where a purpose is set the certificate chain will still be rejected even when the strict flag has been used. A purpose is set by default in libssl client and server certificate verification routines, but it can be overridden or removed by an application. In order to be affected, an application must explicitly set the X509_V_FLAG_X509_STRICT verification flag and either not set a purpose for the certificate verification or, in the case of TLS client or server applications, override the default purpose. OpenSSL versions 1.1.1h and newer are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1h-1.1.1j).

Remediation

Upgrade Alpine:3.12 openssl to version 1.1.1k-r0 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1i-r0 and openssl/libssl1.1@1.1.1i-r0
  • Fixed in: 1.1.1j-r0

Detailed paths

  • Introduced through: golang:1.14-alpine3.12@* openssl/libcrypto1.1@1.1.1i-r0
  • Introduced through: golang:1.14-alpine3.12@* openssl/libssl1.1@1.1.1i-r0

NVD Description

Note: Versions mentioned in the description apply to the upstream openssl package. See Remediation section below for Alpine:3.12 relevant versions.

Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

Remediation

Upgrade Alpine:3.12 openssl to version 1.1.1j-r0 or higher.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1i-r0 and openssl/libssl1.1@1.1.1i-r0
  • Fixed in: 1.1.1j-r0

Detailed paths

  • Introduced through: golang:1.14-alpine3.12@* openssl/libcrypto1.1@1.1.1i-r0
  • Introduced through: golang:1.14-alpine3.12@* openssl/libssl1.1@1.1.1i-r0

NVD Description

Note: Versions mentioned in the description apply to the upstream openssl package. See Remediation section below for Alpine:3.12 relevant versions.

Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

Remediation

Upgrade Alpine:3.12 openssl to version 1.1.1j-r0 or higher.

References

medium severity

NULL Pointer Dereference

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1i-r0 and openssl/libssl1.1@1.1.1i-r0
  • Fixed in: 1.1.1k-r0

Detailed paths

  • Introduced through: golang:1.14-alpine3.12@* openssl/libcrypto1.1@1.1.1i-r0
  • Introduced through: golang:1.14-alpine3.12@* openssl/libssl1.1@1.1.1i-r0

NVD Description

Note: Versions mentioned in the description apply to the upstream openssl package. See Remediation section below for Alpine:3.12 relevant versions.

An OpenSSL TLS server may crash if sent a maliciously crafted renegotiation ClientHello message from a client. If a TLSv1.2 renegotiation ClientHello omits the signature_algorithms extension (where it was present in the initial ClientHello), but includes a signature_algorithms_cert extension then a NULL pointer dereference will result, leading to a crash and a denial of service attack. A server is only vulnerable if it has TLSv1.2 and renegotiation enabled (which is the default configuration). OpenSSL TLS clients are not impacted by this issue. All OpenSSL 1.1.1 versions are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1-1.1.1j).

Remediation

Upgrade Alpine:3.12 openssl to version 1.1.1k-r0 or higher.

References

low severity

Inadequate Encryption Strength

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1i-r0 and openssl/libssl1.1@1.1.1i-r0
  • Fixed in: 1.1.1j-r0

Detailed paths

  • Introduced through: golang:1.14-alpine3.12@* openssl/libcrypto1.1@1.1.1i-r0
  • Introduced through: golang:1.14-alpine3.12@* openssl/libssl1.1@1.1.1i-r0

NVD Description

Note: Versions mentioned in the description apply to the upstream openssl package. See Remediation section below for Alpine:3.12 relevant versions.

OpenSSL 1.0.2 supports SSLv2. If a client attempts to negotiate SSLv2 with a server that is configured to support both SSLv2 and more recent SSL and TLS versions then a check is made for a version rollback attack when unpadding an RSA signature. Clients that support SSL or TLS versions greater than SSLv2 are supposed to use a special form of padding. A server that supports greater than SSLv2 is supposed to reject connection attempts from a client where this special form of padding is present, because this indicates that a version rollback has occurred (i.e. both client and server support greater than SSLv2, and yet this is the version that is being requested). The implementation of this padding check inverted the logic so that the connection attempt is accepted if the padding is present, and rejected if it is absent. This means that such as server will accept a connection if a version rollback attack has occurred. Further the server will erroneously reject a connection if a normal SSLv2 connection attempt is made. Only OpenSSL 1.0.2 servers from version 1.0.2s to 1.0.2x are affected by this issue. In order to be vulnerable a 1.0.2 server must: 1) have configured SSLv2 support at compile time (this is off by default), 2) have configured SSLv2 support at runtime (this is off by default), 3) have configured SSLv2 ciphersuites (these are not in the default ciphersuite list) OpenSSL 1.1.1 does not have SSLv2 support and therefore is not vulnerable to this issue. The underlying error is in the implementation of the RSA_padding_check_SSLv23() function. This also affects the RSA_SSLV23_PADDING padding mode used by various other functions. Although 1.1.1 does not support SSLv2 the RSA_padding_check_SSLv23() function still exists, as does the RSA_SSLV23_PADDING padding mode. Applications that directly call that function or use that padding mode will encounter this issue. However since there is no support for the SSLv2 protocol in 1.1.1 this is considered a bug and not a security issue in that version. OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.0.2y (Affected 1.0.2s-1.0.2x).

Remediation

Upgrade Alpine:3.12 openssl to version 1.1.1j-r0 or higher.

References