Docker golang:1.13.3-alpine3.10

Vulnerabilities

7 via 14 paths

Dependencies

15

Source

Group 6 Copy Created with Sketch. Docker

Target OS

alpine:3.10.3
Test your Docker Hub image against our market leading vulnerability database Sign up for free
Severity
  • 4
  • 3
Status
  • 7
  • 0
  • 0

high severity
new

Inadequate Encryption Strength

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1d-r0 and openssl/libssl1.1@1.1.1d-r0
  • Fixed in: 1.1.1j-r0

Detailed paths

  • Introduced through: golang:1.13.3-alpine3.10@* openssl/libcrypto1.1@1.1.1d-r0
  • Introduced through: golang:1.13.3-alpine3.10@* openssl/libssl1.1@1.1.1d-r0

Overview

Affected versions of this package are vulnerable to Inadequate Encryption Strength. OpenSSL 1.0.2 supports SSLv2. If a client attempts to negotiate SSLv2 with a server that is configured to support both SSLv2 and more recent SSL and TLS versions then a check is made for a version rollback attack when unpadding an RSA signature. Clients that support SSL or TLS versions greater than SSLv2 are supposed to use a special form of padding. A server that supports greater than SSLv2 is supposed to reject connection attempts from a client where this special form of padding is present, because this indicates that a version rollback has occurred (i.e. both client and server support greater than SSLv2, and yet this is the version that is being requested). The implementation of this padding check inverted the logic so that the connection attempt is accepted if the padding is present, and rejected if it is absent. This means that such as server will accept a connection if a version rollback attack has occurred. Further the server will erroneously reject a connection if a normal SSLv2 connection attempt is made. Only OpenSSL 1.0.2 servers from version 1.0.2s to 1.0.2x are affected by this issue. In order to be vulnerable a 1.0.2 server must: 1) have configured SSLv2 support at compile time (this is off by default), 2) have configured SSLv2 support at runtime (this is off by default), 3) have configured SSLv2 ciphersuites (these are not in the default ciphersuite list) OpenSSL 1.1.1 does not have SSLv2 support and therefore is not vulnerable to this issue. The underlying error is in the implementation of the RSA_padding_check_SSLv23() function. This also affects the RSA_SSLV23_PADDING padding mode used by various other functions. Although 1.1.1 does not support SSLv2 the RSA_padding_check_SSLv23() function still exists, as does the RSA_SSLV23_PADDING padding mode. Applications that directly call that function or use that padding mode will encounter this issue. However since there is no support for the SSLv2 protocol in 1.1.1 this is considered a bug and not a security issue in that version. OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.0.2y (Affected 1.0.2s-1.0.2x).

Remediation

Upgrade openssl to version or higher.

References

high severity
new

Integer Overflow or Wraparound

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1d-r0 and openssl/libssl1.1@1.1.1d-r0
  • Fixed in: 1.1.1j-r0

Detailed paths

  • Introduced through: golang:1.13.3-alpine3.10@* openssl/libcrypto1.1@1.1.1d-r0
  • Introduced through: golang:1.13.3-alpine3.10@* openssl/libssl1.1@1.1.1d-r0

Overview

Affected versions of this package are vulnerable to Integer Overflow or Wraparound. Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

Remediation

Upgrade openssl to version or higher.

References

high severity
new

Integer Overflow or Wraparound

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1d-r0 and openssl/libssl1.1@1.1.1d-r0
  • Fixed in: 1.1.1j-r0

Detailed paths

  • Introduced through: golang:1.13.3-alpine3.10@* openssl/libcrypto1.1@1.1.1d-r0
  • Introduced through: golang:1.13.3-alpine3.10@* openssl/libssl1.1@1.1.1d-r0

Overview

Affected versions of this package are vulnerable to Integer Overflow or Wraparound. Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

Remediation

Upgrade openssl to version or higher.

References

high severity

NULL Pointer Dereference

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1d-r0 and openssl/libssl1.1@1.1.1d-r0
  • Fixed in: 1.1.1g-r0

Detailed paths

  • Introduced through: golang:1.13.3-alpine3.10@* openssl/libcrypto1.1@1.1.1d-r0
  • Introduced through: golang:1.13.3-alpine3.10@* openssl/libssl1.1@1.1.1d-r0

Overview

Affected versions of this package are vulnerable to NULL Pointer Dereference. Server or client applications that call the SSL_check_chain() function during or after a TLS 1.3 handshake may crash due to a NULL pointer dereference as a result of incorrect handling of the "signature_algorithms_cert" TLS extension. The crash occurs if an invalid or unrecognised signature algorithm is received from the peer. This could be exploited by a malicious peer in a Denial of Service attack. OpenSSL version 1.1.1d, 1.1.1e, and 1.1.1f are affected by this issue. This issue did not affect OpenSSL versions prior to 1.1.1d. Fixed in OpenSSL 1.1.1g (Affected 1.1.1d-1.1.1f).

Remediation

Upgrade openssl to version or higher.

References

medium severity

Out-of-bounds Write

  • Vulnerable module: musl/musl
  • Introduced through: musl/musl@1.1.22-r3 and musl/musl-utils@1.1.22-r3
  • Fixed in: 1.1.22-r4

Detailed paths

  • Introduced through: golang:1.13.3-alpine3.10@* musl/musl@1.1.22-r3
  • Introduced through: golang:1.13.3-alpine3.10@* musl/musl-utils@1.1.22-r3

Overview

Affected versions of this package are vulnerable to Out-of-bounds Write. In musl libc through 1.2.1, wcsnrtombs mishandles particular combinations of destination buffer size and source character limit, as demonstrated by an invalid write access (buffer overflow).

Remediation

Upgrade musl to version or higher.

References

medium severity

Information Exposure

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1d-r0 and openssl/libssl1.1@1.1.1d-r0
  • Fixed in: 1.1.1d-r2

Detailed paths

  • Introduced through: golang:1.13.3-alpine3.10@* openssl/libcrypto1.1@1.1.1d-r0
  • Introduced through: golang:1.13.3-alpine3.10@* openssl/libssl1.1@1.1.1d-r0

Overview

Affected versions of this package are vulnerable to Information Exposure. There is an overflow bug in the x64_64 Montgomery squaring procedure used in exponentiation with 512-bit moduli. No EC algorithms are affected. Analysis suggests that attacks against 2-prime RSA1024, 3-prime RSA1536, and DSA1024 as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH512 are considered just feasible. However, for an attack the target would have to re-use the DH512 private key, which is not recommended anyway. Also applications directly using the low level API BN_mod_exp may be affected if they use BN_FLG_CONSTTIME. Fixed in OpenSSL 1.1.1e (Affected 1.1.1-1.1.1d). Fixed in OpenSSL 1.0.2u (Affected 1.0.2-1.0.2t).

Remediation

Upgrade openssl to version or higher.

References

medium severity

NULL Pointer Dereference

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1d-r0 and openssl/libssl1.1@1.1.1d-r0
  • Fixed in: 1.1.1i-r0

Detailed paths

  • Introduced through: golang:1.13.3-alpine3.10@* openssl/libcrypto1.1@1.1.1d-r0
  • Introduced through: golang:1.13.3-alpine3.10@* openssl/libssl1.1@1.1.1d-r0

Overview

Affected versions of this package are vulnerable to NULL Pointer Dereference. The X.509 GeneralName type is a generic type for representing different types of names. One of those name types is known as EDIPartyName. OpenSSL provides a function GENERAL_NAME_cmp which compares different instances of a GENERAL_NAME to see if they are equal or not. This function behaves incorrectly when both GENERAL_NAMEs contain an EDIPARTYNAME. A NULL pointer dereference and a crash may occur leading to a possible denial of service attack. OpenSSL itself uses the GENERAL_NAME_cmp function for two purposes: 1) Comparing CRL distribution point names between an available CRL and a CRL distribution point embedded in an X509 certificate 2) When verifying that a timestamp response token signer matches the timestamp authority name (exposed via the API functions TS_RESP_verify_response and TS_RESP_verify_token) If an attacker can control both items being compared then that attacker could trigger a crash. For example if the attacker can trick a client or server into checking a malicious certificate against a malicious CRL then this may occur. Note that some applications automatically download CRLs based on a URL embedded in a certificate. This checking happens prior to the signatures on the certificate and CRL being verified. OpenSSL's s_server, s_client and verify tools have support for the "-crl_download" option which implements automatic CRL downloading and this attack has been demonstrated to work against those tools. Note that an unrelated bug means that affected versions of OpenSSL cannot parse or construct correct encodings of EDIPARTYNAME. However it is possible to construct a malformed EDIPARTYNAME that OpenSSL's parser will accept and hence trigger this attack. All OpenSSL 1.1.1 and 1.0.2 versions are affected by this issue. Other OpenSSL releases are out of support and have not been checked. Fixed in OpenSSL 1.1.1i (Affected 1.1.1-1.1.1h). Fixed in OpenSSL 1.0.2x (Affected 1.0.2-1.0.2w).

Remediation

Upgrade openssl to version or higher.

References