Docker fluent/fluentd:v1.9-1

Vulnerabilities

4 via 14 paths

Dependencies

27

Source

Group 6 Copy Created with Sketch. Docker

Target OS

alpine:3.9.5
Test your Docker Hub image against our market leading vulnerability database Sign up for free
Severity
  • 1
  • 2
  • 1
Status
  • 4
  • 0
  • 0

high severity

NULL Pointer Dereference

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1d-r2 and openssl/libssl1.1@1.1.1d-r2
  • Fixed in: 1.1.1g-r0

Detailed paths

  • Introduced through: fluent/fluentd:v1.9-1@* openssl/libcrypto1.1@1.1.1d-r2
  • Introduced through: fluent/fluentd:v1.9-1@* openssl/libssl1.1@1.1.1d-r2

Overview

Affected versions of this package are vulnerable to NULL Pointer Dereference. Server or client applications that call the SSL_check_chain() function during or after a TLS 1.3 handshake may crash due to a NULL pointer dereference as a result of incorrect handling of the "signature_algorithms_cert" TLS extension. The crash occurs if an invalid or unrecognised signature algorithm is received from the peer. This could be exploited by a malicious peer in a Denial of Service attack. OpenSSL version 1.1.1d, 1.1.1e, and 1.1.1f are affected by this issue. This issue did not affect OpenSSL versions prior to 1.1.1d. Fixed in OpenSSL 1.1.1g (Affected 1.1.1d-1.1.1f).

Remediation

Upgrade openssl to version or higher.

References

medium severity

Out-of-bounds Write

  • Vulnerable module: musl/musl
  • Introduced through: musl/musl@1.1.20-r5 and musl/musl-utils@1.1.20-r5
  • Fixed in: 1.1.20-r6

Detailed paths

  • Introduced through: fluent/fluentd:v1.9-1@* musl/musl@1.1.20-r5
  • Introduced through: fluent/fluentd:v1.9-1@* musl/musl-utils@1.1.20-r5

Overview

Affected versions of this package are vulnerable to Out-of-bounds Write. In musl libc through 1.2.1, wcsnrtombs mishandles particular combinations of destination buffer size and source character limit, as demonstrated by an invalid write access (buffer overflow).

Remediation

Upgrade musl to version or higher.

References

medium severity

Information Exposure

  • Vulnerable module: ruby/ruby
  • Introduced through: ruby/ruby@2.5.7-r0, ruby/ruby-etc@2.5.7-r0 and others
  • Fixed in: 2.5.8-r0

Detailed paths

  • Introduced through: fluent/fluentd:v1.9-1@* ruby/ruby@2.5.7-r0
  • Introduced through: fluent/fluentd:v1.9-1@* ruby/ruby-etc@2.5.7-r0
  • Introduced through: fluent/fluentd:v1.9-1@* ruby/ruby-irb@2.5.7-r0
  • Introduced through: fluent/fluentd:v1.9-1@* ruby/ruby-libs@2.5.7-r0
  • Introduced through: fluent/fluentd:v1.9-1@* ruby/ruby-webrick@2.5.7-r0

Overview

Affected versions of this package are vulnerable to Information Exposure. An issue was discovered in Ruby 2.5.x through 2.5.7, 2.6.x through 2.6.5, and 2.7.0. If a victim calls BasicSocket#read_nonblock(requested_size, buffer, exception: false), the method resizes the buffer to fit the requested size, but no data is copied. Thus, the buffer string provides the previous value of the heap. This may expose possibly sensitive data from the interpreter.

Remediation

Upgrade ruby to version or higher.

References

low severity

CVE-2020-16255

  • Vulnerable module: ruby/ruby
  • Introduced through: ruby/ruby@2.5.7-r0, ruby/ruby-etc@2.5.7-r0 and others
  • Fixed in: 2.5.8-r0

Detailed paths

  • Introduced through: fluent/fluentd:v1.9-1@* ruby/ruby@2.5.7-r0
  • Introduced through: fluent/fluentd:v1.9-1@* ruby/ruby-etc@2.5.7-r0
  • Introduced through: fluent/fluentd:v1.9-1@* ruby/ruby-irb@2.5.7-r0
  • Introduced through: fluent/fluentd:v1.9-1@* ruby/ruby-libs@2.5.7-r0
  • Introduced through: fluent/fluentd:v1.9-1@* ruby/ruby-webrick@2.5.7-r0

Overview

Affected versions of this package are vulnerable to CVE-2020-16255 ownCloud (Core) before 10.5 allows XSS in login page 'forgot password.'

Remediation

Upgrade ruby to version or higher.

References