Docker fluent/fluentd:v1.7.3-1.0

Vulnerabilities

12 via 42 paths

Dependencies

28

Source

Group 6 Copy Created with Sketch. Docker

Target OS

alpine:3.9.4
Test your Docker Hub image against our market leading vulnerability database Sign up for free
Severity
  • 3
  • 7
  • 2
Status
  • 12
  • 0
  • 0

high severity

NULL Pointer Dereference

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1b-r1 and openssl/libssl1.1@1.1.1b-r1
  • Fixed in: 1.1.1g-r0

Detailed paths

  • Introduced through: fluent/fluentd:v1.7.3-1.0@* openssl/libcrypto1.1@1.1.1b-r1
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* openssl/libssl1.1@1.1.1b-r1

Overview

Affected versions of this package are vulnerable to NULL Pointer Dereference. Server or client applications that call the SSL_check_chain() function during or after a TLS 1.3 handshake may crash due to a NULL pointer dereference as a result of incorrect handling of the "signature_algorithms_cert" TLS extension. The crash occurs if an invalid or unrecognised signature algorithm is received from the peer. This could be exploited by a malicious peer in a Denial of Service attack. OpenSSL version 1.1.1d, 1.1.1e, and 1.1.1f are affected by this issue. This issue did not affect OpenSSL versions prior to 1.1.1d. Fixed in OpenSSL 1.1.1g (Affected 1.1.1d-1.1.1f).

Remediation

Upgrade openssl to version or higher.

References

high severity

Arbitrary Code Injection

  • Vulnerable module: ruby/ruby
  • Introduced through: ruby/ruby@2.5.5-r0, ruby/ruby-etc@2.5.5-r0 and others
  • Fixed in: 2.5.7-r0

Detailed paths

  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-etc@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-irb@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-libs@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-webrick@2.5.5-r0

Overview

Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows code injection if the first argument (aka the "command" argument) to Shell#[] or Shell#test in lib/shell.rb is untrusted data. An attacker can exploit this to call an arbitrary Ruby method.

References

high severity

Improper Authentication

  • Vulnerable module: ruby/ruby
  • Introduced through: ruby/ruby@2.5.5-r0, ruby/ruby-etc@2.5.5-r0 and others
  • Fixed in: 2.5.7-r0

Detailed paths

  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-etc@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-irb@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-libs@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-webrick@2.5.5-r0

Overview

WEBrick::HTTPAuth::DigestAuth in Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 has a regular expression Denial of Service cause by looping/backtracking. A victim must expose a WEBrick server that uses DigestAuth to the Internet or a untrusted network.

References

medium severity

Out-of-bounds Write

  • Vulnerable module: musl/musl
  • Introduced through: musl/musl@1.1.20-r5 and musl/musl-utils@1.1.20-r5
  • Fixed in: 1.1.20-r6

Detailed paths

  • Introduced through: fluent/fluentd:v1.7.3-1.0@* musl/musl@1.1.20-r5
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* musl/musl-utils@1.1.20-r5

Overview

Affected versions of this package are vulnerable to Out-of-bounds Write. In musl libc through 1.2.1, wcsnrtombs mishandles particular combinations of destination buffer size and source character limit, as demonstrated by an invalid write access (buffer overflow).

Remediation

Upgrade musl to version or higher.

References

medium severity

Information Exposure

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1b-r1 and openssl/libssl1.1@1.1.1b-r1
  • Fixed in: 1.1.1d-r2

Detailed paths

  • Introduced through: fluent/fluentd:v1.7.3-1.0@* openssl/libcrypto1.1@1.1.1b-r1
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* openssl/libssl1.1@1.1.1b-r1

Overview

Affected versions of this package are vulnerable to Information Exposure. There is an overflow bug in the x64_64 Montgomery squaring procedure used in exponentiation with 512-bit moduli. No EC algorithms are affected. Analysis suggests that attacks against 2-prime RSA1024, 3-prime RSA1536, and DSA1024 as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH512 are considered just feasible. However, for an attack the target would have to re-use the DH512 private key, which is not recommended anyway. Also applications directly using the low level API BN_mod_exp may be affected if they use BN_FLG_CONSTTIME. Fixed in OpenSSL 1.1.1e (Affected 1.1.1-1.1.1d). Fixed in OpenSSL 1.0.2u (Affected 1.0.2-1.0.2t).

Remediation

Upgrade openssl to version or higher.

References

medium severity

Missing Encryption of Sensitive Data

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1b-r1 and openssl/libssl1.1@1.1.1b-r1
  • Fixed in: 1.1.1d-r0

Detailed paths

  • Introduced through: fluent/fluentd:v1.7.3-1.0@* openssl/libcrypto1.1@1.1.1b-r1
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* openssl/libssl1.1@1.1.1b-r1

Overview

Normally in OpenSSL EC groups always have a co-factor present and this is used in side channel resistant code paths. However, in some cases, it is possible to construct a group using explicit parameters (instead of using a named curve). In those cases it is possible that such a group does not have the cofactor present. This can occur even where all the parameters match a known named curve. If such a curve is used then OpenSSL falls back to non-side channel resistant code paths which may result in full key recovery during an ECDSA signature operation. In order to be vulnerable an attacker would have to have the ability to time the creation of a large number of signatures where explicit parameters with no co-factor present are in use by an application using libcrypto. For the avoidance of doubt libssl is not vulnerable because explicit parameters are never used. Fixed in OpenSSL 1.1.1d (Affected 1.1.1-1.1.1c). Fixed in OpenSSL 1.1.0l (Affected 1.1.0-1.1.0k). Fixed in OpenSSL 1.0.2t (Affected 1.0.2-1.0.2s).

References

medium severity

Use of Insufficiently Random Values

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1b-r1 and openssl/libssl1.1@1.1.1b-r1
  • Fixed in: 1.1.1d-r0

Detailed paths

  • Introduced through: fluent/fluentd:v1.7.3-1.0@* openssl/libcrypto1.1@1.1.1b-r1
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* openssl/libssl1.1@1.1.1b-r1

Overview

OpenSSL 1.1.1 introduced a rewritten random number generator (RNG). This was intended to include protection in the event of a fork() system call in order to ensure that the parent and child processes did not share the same RNG state. However this protection was not being used in the default case. A partial mitigation for this issue is that the output from a high precision timer is mixed into the RNG state so the likelihood of a parent and child process sharing state is significantly reduced. If an application already calls OPENSSL_init_crypto() explicitly using OPENSSL_INIT_ATFORK then this problem does not occur at all. Fixed in OpenSSL 1.1.1d (Affected 1.1.1-1.1.1c).

References

medium severity

Arbitrary Code Injection

  • Vulnerable module: ruby/ruby
  • Introduced through: ruby/ruby@2.5.5-r0, ruby/ruby-etc@2.5.5-r0 and others
  • Fixed in: 2.5.7-r0

Detailed paths

  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-etc@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-irb@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-libs@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-webrick@2.5.5-r0

Overview

Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows HTTP Response Splitting. If a program using WEBrick inserts untrusted input into the response header, an attacker can exploit it to insert a newline character to split a header, and inject malicious content to deceive clients. NOTE: this issue exists because of an incomplete fix for CVE-2017-17742, which addressed the CRLF vector, but did not address an isolated CR or an isolated LF.

References

medium severity

CVE-2019-15845

  • Vulnerable module: ruby/ruby
  • Introduced through: ruby/ruby@2.5.5-r0, ruby/ruby-etc@2.5.5-r0 and others
  • Fixed in: 2.5.7-r0

Detailed paths

  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-etc@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-irb@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-libs@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-webrick@2.5.5-r0

Overview

Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 mishandles path checking within File.fnmatch functions.

References

medium severity

Information Exposure

  • Vulnerable module: ruby/ruby
  • Introduced through: ruby/ruby@2.5.5-r0, ruby/ruby-etc@2.5.5-r0 and others
  • Fixed in: 2.5.8-r0

Detailed paths

  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-etc@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-irb@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-libs@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-webrick@2.5.5-r0

Overview

Affected versions of this package are vulnerable to Information Exposure. An issue was discovered in Ruby 2.5.x through 2.5.7, 2.6.x through 2.6.5, and 2.7.0. If a victim calls BasicSocket#read_nonblock(requested_size, buffer, exception: false), the method resizes the buffer to fit the requested size, but no data is copied. Thus, the buffer string provides the previous value of the heap. This may expose possibly sensitive data from the interpreter.

Remediation

Upgrade ruby to version or higher.

References

low severity

Missing Encryption of Sensitive Data

  • Vulnerable module: openssl/libcrypto1.1
  • Introduced through: openssl/libcrypto1.1@1.1.1b-r1 and openssl/libssl1.1@1.1.1b-r1
  • Fixed in: 1.1.1d-r0

Detailed paths

  • Introduced through: fluent/fluentd:v1.7.3-1.0@* openssl/libcrypto1.1@1.1.1b-r1
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* openssl/libssl1.1@1.1.1b-r1

Overview

In situations where an attacker receives automated notification of the success or failure of a decryption attempt an attacker, after sending a very large number of messages to be decrypted, can recover a CMS/PKCS7 transported encryption key or decrypt any RSA encrypted message that was encrypted with the public RSA key, using a Bleichenbacher padding oracle attack. Applications are not affected if they use a certificate together with the private RSA key to the CMS_decrypt or PKCS7_decrypt functions to select the correct recipient info to decrypt. Fixed in OpenSSL 1.1.1d (Affected 1.1.1-1.1.1c). Fixed in OpenSSL 1.1.0l (Affected 1.1.0-1.1.0k). Fixed in OpenSSL 1.0.2t (Affected 1.0.2-1.0.2s).

References

low severity

CVE-2020-16255

  • Vulnerable module: ruby/ruby
  • Introduced through: ruby/ruby@2.5.5-r0, ruby/ruby-etc@2.5.5-r0 and others
  • Fixed in: 2.5.8-r0

Detailed paths

  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-etc@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-irb@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-libs@2.5.5-r0
  • Introduced through: fluent/fluentd:v1.7.3-1.0@* ruby/ruby-webrick@2.5.5-r0

Overview

Affected versions of this package are vulnerable to CVE-2020-16255 ownCloud (Core) before 10.5 allows XSS in login page 'forgot password.'

Remediation

Upgrade ruby to version or higher.

References