Docker fluent/fluentd:v1.4.0-debian-onbuild-1.0

Vulnerabilities

125 via 326 paths

Dependencies

100

Source

Group 6 Copy Created with Sketch. Docker

Target OS

debian:9
Test your Docker Hub image against our market leading vulnerability database Sign up for free
Severity
  • 46
  • 24
  • 55
Status
  • 125
  • 0
  • 0

high severity

Out-of-bounds Write

  • Vulnerable module: bzip2/libbz2-1.0
  • Introduced through: bzip2/libbz2-1.0@1.0.6-8.1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* bzip2/libbz2-1.0@1.0.6-8.1

Overview

BZ2_decompress in decompress.c in bzip2 through 1.0.6 has an out-of-bounds write when there are many selectors.

References

high severity

Information Exposure

  • Vulnerable module: gcc-6/gcc-6-base
  • Introduced through: gcc-6/gcc-6-base@6.3.0-18+deb9u1, gcc-6/libgcc1@1:6.3.0-18+deb9u1 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* gcc-6/gcc-6-base@6.3.0-18+deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* gcc-6/libgcc1@1:6.3.0-18+deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* gcc-6/libstdc++6@6.3.0-18+deb9u1

Overview

stack_protect_prologue in cfgexpand.c and stack_protect_epilogue in function.c in GNU Compiler Collection (GCC) 4.1 through 8 (under certain circumstances) generate instruction sequences when targeting ARM targets that spill the address of the stack protector guard, which allows an attacker to bypass the protection of -fstack-protector, -fstack-protector-all, -fstack-protector-strong, and -fstack-protector-explicit against stack overflow by controlling what the stack canary is compared against.

References

high severity

Improper Data Handling

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

In the GNU C Library (aka glibc or libc6) before 2.28, parse_reg_exp in posix/regcomp.c misparses alternatives, which allows attackers to cause a denial of service (assertion failure and application exit) or trigger an incorrect result by attempting a regular-expression match.

References

high severity

Missing Release of Resource after Effective Lifetime

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3 and glibc/multiarch-support@2.24-11+deb9u3
  • Fixed in: 2.24-11+deb9u4

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

A memory leak in glibc 2.1.1 (released on May 24, 1999) can be reached and amplified through the LD_HWCAP_MASK environment variable. Please note that many versions of glibc are not vulnerable to this issue if patched for CVE-2017-1000366.

References

high severity

Out-of-Bounds

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3 and glibc/multiarch-support@2.24-11+deb9u3
  • Fixed in: 2.24-11+deb9u4

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

The glob function in glob.c in the GNU C Library (aka glibc or libc6) before 2.27 contains a buffer overflow during unescaping of user names with the ~ operator.

References

high severity

Out-of-Bounds

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3 and glibc/multiarch-support@2.24-11+deb9u3
  • Fixed in: 2.24-11+deb9u4

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

A buffer overflow in glibc 2.5 (released on September 29, 2006) and can be triggered through the LD_LIBRARY_PATH environment variable. Please note that many versions of glibc are not vulnerable to this issue if patched for CVE-2017-1000366.

References

high severity

Out-of-Bounds

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3 and glibc/multiarch-support@2.24-11+deb9u3
  • Fixed in: 2.24-11+deb9u4

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

The GNU C Library (aka glibc or libc6) before 2.27 contains an off-by-one error leading to a heap-based buffer overflow in the glob function in glob.c, related to the processing of home directories using the ~ operator followed by a long string.

References

high severity

Out-of-Bounds

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3 and glibc/multiarch-support@2.24-11+deb9u3
  • Fixed in: 2.24-11+deb9u4

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

An SSE2-optimized memmove implementation for i386 in sysdeps/i386/i686/multiarch/memcpy-sse2-unaligned.S in the GNU C Library (aka glibc or libc6) 2.21 through 2.27 does not correctly perform the overlapping memory check if the source memory range spans the middle of the address space, resulting in corrupt data being produced by the copy operation. This may disclose information to context-dependent attackers, or result in a denial of service, or, possibly, code execution.

References

high severity

Out-of-bounds Read

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

In the GNU C Library (aka glibc or libc6) through 2.29, proceed_next_node in posix/regexec.c has a heap-based buffer over-read via an attempted case-insensitive regular-expression match.

References

high severity

Out-of-bounds Write

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

An integer overflow in the implementation of the posix_memalign in memalign functions in the GNU C Library (aka glibc or libc6) 2.26 and earlier could cause these functions to return a pointer to a heap area that is too small, potentially leading to heap corruption.

References

high severity

Out-of-bounds Write

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3 and glibc/multiarch-support@2.24-11+deb9u3
  • Fixed in: 2.24-11+deb9u4

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

stdlib/canonicalize.c in the GNU C Library (aka glibc or libc6) 2.27 and earlier, when processing very long pathname arguments to the realpath function, could encounter an integer overflow on 32-bit architectures, leading to a stack-based buffer overflow and, potentially, arbitrary code execution.

References

high severity

Out-of-bounds Write

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

In glibc 2.26 and earlier there is confusion in the usage of getcwd() by realpath() which can be used to write before the destination buffer leading to a buffer underflow and potential code execution.

References

high severity

Out-of-bounds Write

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

The malloc implementation in the GNU C Library (aka glibc or libc6), from version 2.24 to 2.26 on powerpc, and only in version 2.26 on i386, did not properly handle malloc calls with arguments close to SIZE_MAX and could return a pointer to a heap region that is smaller than requested, eventually leading to heap corruption.

References

high severity

Out-of-bounds Write

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3 and glibc/multiarch-support@2.24-11+deb9u3
  • Fixed in: 2.24-11+deb9u4

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

An AVX-512-optimized implementation of the mempcpy function in the GNU C Library (aka glibc or libc6) 2.27 and earlier may write data beyond the target buffer, leading to a buffer overflow in __mempcpy_avx512_no_vzeroupper.

References

high severity

Out-of-bounds Write

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

An out-of-bounds write vulnerability was found in glibc before 2.31 when handling signal trampolines on PowerPC. Specifically, the backtrace function did not properly check the array bounds when storing the frame address, resulting in a denial of service or potential code execution. The highest threat from this vulnerability is to system availability.

References

high severity

Reachable Assertion

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

Affected versions of this package are vulnerable to Reachable Assertion. The iconv function in the GNU C Library (aka glibc or libc6) 2.32 and earlier, when processing invalid input sequences in the ISO-2022-JP-3 encoding, fails an assertion in the code path and aborts the program, potentially resulting in a denial of service.

Remediation

There is no fixed version for glibc.

References

high severity

Untrusted Search Path

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3 and glibc/multiarch-support@2.24-11+deb9u3
  • Fixed in: 2.24-11+deb9u4

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

elf/dl-load.c in the GNU C Library (aka glibc or libc6) 2.19 through 2.26 mishandles RPATH and RUNPATH containing $ORIGIN for a privileged (setuid or AT_SECURE) program, which allows local users to gain privileges via a Trojan horse library in the current working directory, related to the fillin_rpath and decompose_rpath functions. This is associated with misinterpretion of an empty RPATH/RUNPATH token as the "./" directory. NOTE: this configuration of RPATH/RUNPATH for a privileged program is apparently very uncommon; most likely, no such program is shipped with any common Linux distribution.

References

high severity

Use After Free

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

A use-after-free vulnerability introduced in glibc upstream version 2.14 was found in the way the tilde expansion was carried out. Directory paths containing an initial tilde followed by a valid username were affected by this issue. A local attacker could exploit this flaw by creating a specially crafted path that, when processed by the glob function, would potentially lead to arbitrary code execution. This was fixed in version 2.32.

References

high severity

Cross-site Request Forgery (CSRF)

  • Vulnerable module: gnupg2/gpgv
  • Introduced through: gnupg2/gpgv@2.1.18-8~deb9u3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* gnupg2/gpgv@2.1.18-8~deb9u3

Overview

GnuPG version 2.1.12 - 2.2.11 contains a Cross ite Request Forgery (CSRF) vulnerability in dirmngr that can result in Attacker controlled CSRF, Information Disclosure, DoS. This attack appear to be exploitable via Victim must perform a WKD request, e.g. enter an email address in the composer window of Thunderbird/Enigmail. This vulnerability appears to have been fixed in after commit 4a4bb874f63741026bd26264c43bb32b1099f060.

References

high severity

CVE-2018-10754

  • Vulnerable module: ncurses/libncurses5
  • Introduced through: ncurses/libncurses5@6.0+20161126-1+deb9u2, ncurses/libncursesw5@6.0+20161126-1+deb9u2 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/libncurses5@6.0+20161126-1+deb9u2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/libncursesw5@6.0+20161126-1+deb9u2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/libtinfo5@6.0+20161126-1+deb9u2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/ncurses-base@6.0+20161126-1+deb9u2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/ncurses-bin@6.0+20161126-1+deb9u2

Overview

In ncurses before 6.1.20180414, there is a NULL Pointer Dereference in the _nc_parse_entry function of tinfo/parse_entry.c. It could lead to a remote denial of service if the terminfo library code is used to process untrusted terminfo data in which a use-name is invalid syntax. The product proceeds to the dereference code path even after a "dubious character `[' in name or alias field" detection.

References

high severity

Cryptographic Issues

  • Vulnerable module: openssl
  • Introduced through: openssl@1.1.0j-1~deb9u1 and openssl/libssl1.1@1.1.0j-1~deb9u1
  • Fixed in: 1.1.0k-1~deb9u1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl@1.1.0j-1~deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl/libssl1.1@1.1.0j-1~deb9u1

Overview

ChaCha20-Poly1305 is an AEAD cipher, and requires a unique nonce input for every encryption operation. RFC 7539 specifies that the nonce value (IV) should be 96 bits (12 bytes). OpenSSL allows a variable nonce length and front pads the nonce with 0 bytes if it is less than 12 bytes. However it also incorrectly allows a nonce to be set of up to 16 bytes. In this case only the last 12 bytes are significant and any additional leading bytes are ignored. It is a requirement of using this cipher that nonce values are unique. Messages encrypted using a reused nonce value are susceptible to serious confidentiality and integrity attacks. If an application changes the default nonce length to be longer than 12 bytes and then makes a change to the leading bytes of the nonce expecting the new value to be a new unique nonce then such an application could inadvertently encrypt messages with a reused nonce. Additionally the ignored bytes in a long nonce are not covered by the integrity guarantee of this cipher. Any application that relies on the integrity of these ignored leading bytes of a long nonce may be further affected. Any OpenSSL internal use of this cipher, including in SSL/TLS, is safe because no such use sets such a long nonce value. However user applications that use this cipher directly and set a non-default nonce length to be longer than 12 bytes may be vulnerable. OpenSSL versions 1.1.1 and 1.1.0 are affected by this issue. Due to the limited scope of affected deployments this has been assessed as low severity and therefore we are not creating new releases at this time. Fixed in OpenSSL 1.1.1c (Affected 1.1.1-1.1.1b). Fixed in OpenSSL 1.1.0k (Affected 1.1.0-1.1.0j).

References

high severity
new

Integer Overflow or Wraparound

  • Vulnerable module: openssl
  • Introduced through: openssl@1.1.0j-1~deb9u1 and openssl/libssl1.1@1.1.0j-1~deb9u1
  • Fixed in: 1.1.0l-1~deb9u3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl@1.1.0j-1~deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl/libssl1.1@1.1.0j-1~deb9u1

Overview

Affected versions of this package are vulnerable to Integer Overflow or Wraparound. Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

Remediation

Upgrade openssl to version or higher.

References

high severity
new

Integer Overflow or Wraparound

  • Vulnerable module: openssl
  • Introduced through: openssl@1.1.0j-1~deb9u1 and openssl/libssl1.1@1.1.0j-1~deb9u1
  • Fixed in: 1.1.0l-1~deb9u3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl@1.1.0j-1~deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl/libssl1.1@1.1.0j-1~deb9u1

Overview

Affected versions of this package are vulnerable to Integer Overflow or Wraparound. The OpenSSL public API function X509_issuer_and_serial_hash() attempts to create a unique hash value based on the issuer and serial number data contained within an X509 certificate. However it fails to correctly handle any errors that may occur while parsing the issuer field (which might occur if the issuer field is maliciously constructed). This may subsequently result in a NULL pointer deref and a crash leading to a potential denial of service attack. The function X509_issuer_and_serial_hash() is never directly called by OpenSSL itself so applications are only vulnerable if they use this function directly and they use it on certificates that may have been obtained from untrusted sources. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

Remediation

Upgrade openssl to version or higher.

References

high severity
new

Integer Overflow or Wraparound

  • Vulnerable module: openssl1.0/libssl1.0.2
  • Introduced through: openssl1.0/libssl1.0.2@1.0.2q-1~deb9u1
  • Fixed in: 1.0.2u-1~deb9u4

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl1.0/libssl1.0.2@1.0.2q-1~deb9u1

Overview

Affected versions of this package are vulnerable to Integer Overflow or Wraparound. The OpenSSL public API function X509_issuer_and_serial_hash() attempts to create a unique hash value based on the issuer and serial number data contained within an X509 certificate. However it fails to correctly handle any errors that may occur while parsing the issuer field (which might occur if the issuer field is maliciously constructed). This may subsequently result in a NULL pointer deref and a crash leading to a potential denial of service attack. The function X509_issuer_and_serial_hash() is never directly called by OpenSSL itself so applications are only vulnerable if they use this function directly and they use it on certificates that may have been obtained from untrusted sources. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

Remediation

Upgrade openssl1.0 to version or higher.

References

high severity
new

Integer Overflow or Wraparound

  • Vulnerable module: openssl1.0/libssl1.0.2
  • Introduced through: openssl1.0/libssl1.0.2@1.0.2q-1~deb9u1
  • Fixed in: 1.0.2u-1~deb9u4

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl1.0/libssl1.0.2@1.0.2q-1~deb9u1

Overview

Affected versions of this package are vulnerable to Integer Overflow or Wraparound. Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

Remediation

Upgrade openssl1.0 to version or higher.

References

high severity

Buffer Overflow

  • Vulnerable module: perl/perl-base
  • Introduced through: perl/perl-base@5.24.1-3+deb9u5
  • Fixed in: 5.24.1-3+deb9u7

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* perl/perl-base@5.24.1-3+deb9u5

Overview

Affected versions of this package are vulnerable to Buffer Overflow regcomp.c in Perl before 5.30.3 allows a buffer overflow via a crafted regular expression because of recursive S_study_chunk calls.

Remediation

Upgrade perl to version or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: perl/perl-base
  • Introduced through: perl/perl-base@5.24.1-3+deb9u5
  • Fixed in: 5.24.1-3+deb9u7

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* perl/perl-base@5.24.1-3+deb9u5

Overview

Affected versions of this package are vulnerable to Integer Overflow or Wraparound. Perl before 5.30.3 has an integer overflow related to mishandling of a "PL_regkind[OP(n)] == NOTHING" situation. A crafted regular expression could lead to malformed bytecode with a possibility of instruction injection.

Remediation

Upgrade perl to version or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: perl/perl-base
  • Introduced through: perl/perl-base@5.24.1-3+deb9u5
  • Fixed in: 5.24.1-3+deb9u7

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* perl/perl-base@5.24.1-3+deb9u5

Overview

Affected versions of this package are vulnerable to Out-of-bounds Write. Perl before 5.30.3 on 32-bit platforms allows a heap-based buffer overflow because nested regular expression quantifiers have an integer overflow.

Remediation

Upgrade perl to version or higher.

References

high severity

Arbitrary Argument Injection

  • Vulnerable module: ruby2.3
  • Introduced through: ruby2.3@2.3.3-1+deb9u4 and ruby2.3/libruby2.3@2.3.3-1+deb9u4
  • Fixed in: 2.3.3-1+deb9u6

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3@2.3.3-1+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3/libruby2.3@2.3.3-1+deb9u4

Overview

An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::UserInteraction#verbose calls say without escaping, escape sequence injection is possible.

References

high severity

Arbitrary Code Injection

  • Vulnerable module: ruby2.3
  • Introduced through: ruby2.3@2.3.3-1+deb9u4 and ruby2.3/libruby2.3@2.3.3-1+deb9u4
  • Fixed in: 2.3.3-1+deb9u6

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3@2.3.3-1+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3/libruby2.3@2.3.3-1+deb9u4

Overview

An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::CommandManager#run calls alert_error without escaping, escape sequence injection is possible. (There are many ways to cause an error.)

References

high severity

Arbitrary Code Injection

  • Vulnerable module: ruby2.3
  • Introduced through: ruby2.3@2.3.3-1+deb9u4 and ruby2.3/libruby2.3@2.3.3-1+deb9u4
  • Fixed in: 2.3.3-1+deb9u6

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3@2.3.3-1+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3/libruby2.3@2.3.3-1+deb9u4

Overview

An issue was discovered in RubyGems 2.6 and later through 3.0.2. The gem owner command outputs the contents of the API response directly to stdout. Therefore, if the response is crafted, escape sequence injection may occur.

References

high severity

Arbitrary Code Injection

  • Vulnerable module: ruby2.3
  • Introduced through: ruby2.3@2.3.3-1+deb9u4 and ruby2.3/libruby2.3@2.3.3-1+deb9u4
  • Fixed in: 2.3.3-1+deb9u6

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3@2.3.3-1+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3/libruby2.3@2.3.3-1+deb9u4

Overview

An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.

References

high severity

Arbitrary Code Injection

  • Vulnerable module: ruby2.3
  • Introduced through: ruby2.3@2.3.3-1+deb9u4 and ruby2.3/libruby2.3@2.3.3-1+deb9u4
  • Fixed in: 2.3.3-1+deb9u6

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3@2.3.3-1+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3/libruby2.3@2.3.3-1+deb9u4

Overview

An issue was discovered in RubyGems 2.6 and later through 3.0.2. Gem::GemcutterUtilities#with_response may output the API response to stdout as it is. Therefore, if the API side modifies the response, escape sequence injection may occur.

References

high severity

Arbitrary Code Injection

  • Vulnerable module: ruby2.3
  • Introduced through: ruby2.3@2.3.3-1+deb9u4 and ruby2.3/libruby2.3@2.3.3-1+deb9u4
  • Fixed in: 2.3.3-1+deb9u7

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3@2.3.3-1+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3/libruby2.3@2.3.3-1+deb9u4

Overview

Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows code injection if the first argument (aka the "command" argument) to Shell#[] or Shell#test in lib/shell.rb is untrusted data. An attacker can exploit this to call an arbitrary Ruby method.

References

high severity

Directory Traversal

  • Vulnerable module: ruby2.3
  • Introduced through: ruby2.3@2.3.3-1+deb9u4 and ruby2.3/libruby2.3@2.3.3-1+deb9u4
  • Fixed in: 2.3.3-1+deb9u6

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3@2.3.3-1+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3/libruby2.3@2.3.3-1+deb9u4

Overview

A Directory Traversal issue was discovered in RubyGems 2.7.6 and later through 3.0.2. Before making new directories or touching files (which now include path-checking code for symlinks), it would delete the target destination. If that destination was hidden behind a symlink, a malicious gem could delete arbitrary files on the user's machine, presuming the attacker could guess at paths. Given how frequently gem is run as sudo, and how predictable paths are on modern systems (/tmp, /usr, etc.), this could likely lead to data loss or an unusable system.

References

high severity

HTTP Request Smuggling

  • Vulnerable module: ruby2.3
  • Introduced through: ruby2.3@2.3.3-1+deb9u4 and ruby2.3/libruby2.3@2.3.3-1+deb9u4
  • Fixed in: 2.3.3-1+deb9u9

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3@2.3.3-1+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3/libruby2.3@2.3.3-1+deb9u4

Overview

Affected versions of this package are vulnerable to HTTP Request Smuggling. An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1. WEBrick, a simple HTTP server bundled with Ruby, had not checked the transfer-encoding header value rigorously. An attacker may potentially exploit this issue to bypass a reverse proxy (which also has a poor header check), which may lead to an HTTP Request Smuggling attack.

Remediation

Upgrade ruby2.3 to version or higher.

References

high severity

Improper Authentication

  • Vulnerable module: ruby2.3
  • Introduced through: ruby2.3@2.3.3-1+deb9u4 and ruby2.3/libruby2.3@2.3.3-1+deb9u4
  • Fixed in: 2.3.3-1+deb9u7

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3@2.3.3-1+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3/libruby2.3@2.3.3-1+deb9u4

Overview

WEBrick::HTTPAuth::DigestAuth in Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 has a regular expression Denial of Service cause by looping/backtracking. A victim must expose a WEBrick server that uses DigestAuth to the Internet or a untrusted network.

References

high severity

Improper Input Validation

  • Vulnerable module: ruby2.3
  • Introduced through: ruby2.3@2.3.3-1+deb9u4 and ruby2.3/libruby2.3@2.3.3-1+deb9u4
  • Fixed in: 2.3.3-1+deb9u8

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3@2.3.3-1+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3/libruby2.3@2.3.3-1+deb9u4

Overview

The JSON gem through 2.2.0 for Ruby, as used in Ruby 2.4 through 2.4.9, 2.5 through 2.5.7, and 2.6 through 2.6.5, has an Unsafe Object Creation Vulnerability. This is quite similar to CVE-2013-0269, but does not rely on poor garbage-collection behavior within Ruby. Specifically, use of JSON parsing methods can lead to creation of a malicious object within the interpreter, with adverse effects that are application-dependent.

References

high severity

Out-of-Bounds

  • Vulnerable module: shadow/login
  • Introduced through: shadow/login@1:4.4-4.1 and shadow/passwd@1:4.4-4.1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* shadow/login@1:4.4-4.1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* shadow/passwd@1:4.4-4.1

Overview

In shadow before 4.5, the newusers tool could be made to manipulate internal data structures in ways unintended by the authors. Malformed input may lead to crashes (with a buffer overflow or other memory corruption) or other unspecified behaviors. This crosses a privilege boundary in, for example, certain web-hosting environments in which a Control Panel allows an unprivileged user account to create subaccounts.

References

high severity

Access Restriction Bypass

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@232-25+deb9u8 and systemd/libudev1@232-25+deb9u8
  • Fixed in: 232-25+deb9u11

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libsystemd0@232-25+deb9u8
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libudev1@232-25+deb9u8

Overview

In systemd before v242-rc4, it was discovered that pam_systemd does not properly sanitize the environment before using the XDG_SEAT variable. It is possible for an attacker, in some particular configurations, to set a XDG_SEAT environment variable which allows for commands to be checked against polkit policies using the "allow_active" element rather than "allow_any".

References

high severity

Deserialization of Untrusted Data

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@232-25+deb9u8 and systemd/libudev1@232-25+deb9u8
  • Fixed in: 232-25+deb9u10

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libsystemd0@232-25+deb9u8
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libudev1@232-25+deb9u8

Overview

A vulnerability in unit_deserialize of systemd allows an attacker to supply arbitrary state across systemd re-execution via NotifyAccess. This can be used to improperly influence systemd execution and possibly lead to root privilege escalation. Affected releases are systemd versions up to and including 239.

References

high severity

Incorrect Privilege Assignment

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@232-25+deb9u8 and systemd/libudev1@232-25+deb9u8

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libsystemd0@232-25+deb9u8
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libudev1@232-25+deb9u8

Overview

It was discovered that a systemd service that uses DynamicUser property can create a SUID/SGID binary that would be allowed to run as the transient service UID/GID even after the service is terminated. A local attacker may use this flaw to access resources that will be owned by a potentially different service in the future, when the UID/GID will be recycled.

References

high severity

Information Exposure

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@232-25+deb9u8 and systemd/libudev1@232-25+deb9u8

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libsystemd0@232-25+deb9u8
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libudev1@232-25+deb9u8

Overview

systemd 242 changes the VT1 mode upon a logout, which allows attackers to read cleartext passwords in certain circumstances, such as watching a shutdown, or using Ctrl-Alt-F1 and Ctrl-Alt-F2. This occurs because the KDGKBMODE (aka current keyboard mode) check is mishandled.

References

high severity

Privilege Chaining

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@232-25+deb9u8 and systemd/libudev1@232-25+deb9u8

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libsystemd0@232-25+deb9u8
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libudev1@232-25+deb9u8

Overview

It was discovered that a systemd service that uses DynamicUser property can get new privileges through the execution of SUID binaries, which would allow to create binaries owned by the service transient group with the setgid bit set. A local attacker may use this flaw to access resources that will be owned by a potentially different service in the future, when the GID will be recycled.

References

high severity

Use After Free

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@232-25+deb9u8 and systemd/libudev1@232-25+deb9u8

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libsystemd0@232-25+deb9u8
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libudev1@232-25+deb9u8

Overview

A heap use-after-free vulnerability was found in systemd before version v245-rc1, where asynchronous Polkit queries are performed while handling dbus messages. A local unprivileged attacker can abuse this flaw to crash systemd services or potentially execute code and elevate their privileges, by sending specially crafted dbus messages.

References

high severity

Access Restriction Bypass

  • Vulnerable module: util-linux
  • Introduced through: util-linux@2.29.2-1+deb9u1, util-linux/bsdutils@1:2.29.2-1+deb9u1 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* util-linux@2.29.2-1+deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* util-linux/bsdutils@1:2.29.2-1+deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* util-linux/libblkid1@2.29.2-1+deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* util-linux/libfdisk1@2.29.2-1+deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* util-linux/libmount1@2.29.2-1+deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* util-linux/libsmartcols1@2.29.2-1+deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* util-linux/libuuid1@2.29.2-1+deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* util-linux/mount@2.29.2-1+deb9u1

Overview

runuser in util-linux allows local users to escape to the parent session via a crafted TIOCSTI ioctl call, which pushes characters to the terminal's input buffer.

References

medium severity

Improper Input Validation

  • Vulnerable module: apt
  • Introduced through: apt@1.4.9 and apt/libapt-pkg5.0@1.4.9
  • Fixed in: 1.4.10

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* apt@1.4.9
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* apt/libapt-pkg5.0@1.4.9

Overview

Missing input validation in the ar/tar implementations of APT before version 2.1.2 could result in denial of service when processing specially crafted deb files.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: apt
  • Introduced through: apt@1.4.9 and apt/libapt-pkg5.0@1.4.9
  • Fixed in: 1.4.11

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* apt@1.4.9
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* apt/libapt-pkg5.0@1.4.9

Overview

Affected versions of this package are vulnerable to Integer Overflow or Wraparound. APT had several integer overflows and underflows while parsing .deb packages, aka GHSL-2020-168 GHSL-2020-169, in files apt-pkg/contrib/extracttar.cc, apt-pkg/deb/debfile.cc, and apt-pkg/contrib/arfile.cc. This issue affects: apt 1.2.32ubuntu0 versions prior to 1.2.32ubuntu0.2; 1.6.12ubuntu0 versions prior to 1.6.12ubuntu0.2; 2.0.2ubuntu0 versions prior to 2.0.2ubuntu0.2; 2.1.10ubuntu0 versions prior to 2.1.10ubuntu0.1;

Remediation

Upgrade apt to version or higher.

References

medium severity

Out-of-bounds Write

  • Vulnerable module: e2fsprogs
  • Introduced through: e2fsprogs@1.43.4-2, e2fsprogs/e2fslibs@1.43.4-2 and others
  • Fixed in: 1.43.4-2+deb9u1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* e2fsprogs@1.43.4-2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* e2fsprogs/e2fslibs@1.43.4-2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* e2fsprogs/libcomerr2@1.43.4-2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* e2fsprogs/libss2@1.43.4-2

Overview

An exploitable code execution vulnerability exists in the quota file functionality of E2fsprogs 1.45.3. A specially crafted ext4 partition can cause an out-of-bounds write on the heap, resulting in code execution. An attacker can corrupt a partition to trigger this vulnerability.

References

medium severity

Out-of-bounds Write

  • Vulnerable module: e2fsprogs
  • Introduced through: e2fsprogs@1.43.4-2, e2fsprogs/e2fslibs@1.43.4-2 and others
  • Fixed in: 1.43.4-2+deb9u2

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* e2fsprogs@1.43.4-2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* e2fsprogs/e2fslibs@1.43.4-2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* e2fsprogs/libcomerr2@1.43.4-2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* e2fsprogs/libss2@1.43.4-2

Overview

A code execution vulnerability exists in the directory rehashing functionality of E2fsprogs e2fsck 1.45.4. A specially crafted ext4 directory can cause an out-of-bounds write on the stack, resulting in code execution. An attacker can corrupt a partition to trigger this vulnerability.

References

medium severity

Allocation of Resources Without Limits or Throttling

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

The DNS stub resolver in the GNU C Library (aka glibc or libc6) before version 2.26, when EDNS support is enabled, will solicit large UDP responses from name servers, potentially simplifying off-path DNS spoofing attacks due to IP fragmentation.

References

medium severity

Improper Input Validation

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

In the GNU C Library (aka glibc or libc6) through 2.28, the getaddrinfo function would successfully parse a string that contained an IPv4 address followed by whitespace and arbitrary characters, which could lead applications to incorrectly assume that it had parsed a valid string, without the possibility of embedded HTTP headers or other potentially dangerous substrings.

References

medium severity

Missing Release of Resource after Effective Lifetime

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3 and glibc/multiarch-support@2.24-11+deb9u3
  • Fixed in: 2.24-11+deb9u4

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

The glob function in glob.c in the GNU C Library (aka glibc or libc6) before 2.27, when invoked with GLOB_TILDE, could skip freeing allocated memory when processing the ~ operator with a long user name, potentially leading to a denial of service (memory leak).

References

medium severity

Out-of-Bounds

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

The GNU C Library (aka glibc or libc6) before 2.32 could overflow an on-stack buffer during range reduction if an input to an 80-bit long double function contains a non-canonical bit pattern, a seen when passing a 0x5d414141414141410000 value to sinl on x86 targets. This is related to sysdeps/ieee754/ldbl-96/e_rem_pio2l.c.

References

medium severity

Out-of-bounds Read

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

Affected versions of this package are vulnerable to Out-of-bounds Read. The iconv feature in the GNU C Library (aka glibc or libc6) through 2.32, when processing invalid multi-byte input sequences in the EUC-KR encoding, may have a buffer over-read.

Remediation

There is no fixed version for glibc.

References

medium severity

Cryptographic Issues

  • Vulnerable module: libgcrypt20
  • Introduced through: libgcrypt20@1.7.6-2+deb9u3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* libgcrypt20@1.7.6-2+deb9u3

Overview

In Libgcrypt 1.8.4, the C implementation of AES is vulnerable to a flush-and-reload side-channel attack because physical addresses are available to other processes. (The C implementation is used on platforms where an assembly-language implementation is unavailable.)

References

medium severity

Race Condition

  • Vulnerable module: libgcrypt20
  • Introduced through: libgcrypt20@1.7.6-2+deb9u3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* libgcrypt20@1.7.6-2+deb9u3

Overview

It was discovered that there was a ECDSA timing attack in the libgcrypt20 cryptographic library. Version affected: 1.8.4-5, 1.7.6-2+deb9u3, and 1.6.3-2+deb8u4. Versions fixed: 1.8.5-2 and 1.6.3-2+deb8u7.

References

medium severity

Missing Encryption of Sensitive Data

  • Vulnerable module: openssl
  • Introduced through: openssl@1.1.0j-1~deb9u1 and openssl/libssl1.1@1.1.0j-1~deb9u1
  • Fixed in: 1.1.0l-1~deb9u1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl@1.1.0j-1~deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl/libssl1.1@1.1.0j-1~deb9u1

Overview

Normally in OpenSSL EC groups always have a co-factor present and this is used in side channel resistant code paths. However, in some cases, it is possible to construct a group using explicit parameters (instead of using a named curve). In those cases it is possible that such a group does not have the cofactor present. This can occur even where all the parameters match a known named curve. If such a curve is used then OpenSSL falls back to non-side channel resistant code paths which may result in full key recovery during an ECDSA signature operation. In order to be vulnerable an attacker would have to have the ability to time the creation of a large number of signatures where explicit parameters with no co-factor present are in use by an application using libcrypto. For the avoidance of doubt libssl is not vulnerable because explicit parameters are never used. Fixed in OpenSSL 1.1.1d (Affected 1.1.1-1.1.1c). Fixed in OpenSSL 1.1.0l (Affected 1.1.0-1.1.0k). Fixed in OpenSSL 1.0.2t (Affected 1.0.2-1.0.2s).

References

medium severity

NULL Pointer Dereference

  • Vulnerable module: openssl
  • Introduced through: openssl@1.1.0j-1~deb9u1 and openssl/libssl1.1@1.1.0j-1~deb9u1
  • Fixed in: 1.1.0l-1~deb9u2

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl@1.1.0j-1~deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl/libssl1.1@1.1.0j-1~deb9u1

Overview

Affected versions of this package are vulnerable to NULL Pointer Dereference. The X.509 GeneralName type is a generic type for representing different types of names. One of those name types is known as EDIPartyName. OpenSSL provides a function GENERAL_NAME_cmp which compares different instances of a GENERAL_NAME to see if they are equal or not. This function behaves incorrectly when both GENERAL_NAMEs contain an EDIPARTYNAME. A NULL pointer dereference and a crash may occur leading to a possible denial of service attack. OpenSSL itself uses the GENERAL_NAME_cmp function for two purposes: 1) Comparing CRL distribution point names between an available CRL and a CRL distribution point embedded in an X509 certificate 2) When verifying that a timestamp response token signer matches the timestamp authority name (exposed via the API functions TS_RESP_verify_response and TS_RESP_verify_token) If an attacker can control both items being compared then that attacker could trigger a crash. For example if the attacker can trick a client or server into checking a malicious certificate against a malicious CRL then this may occur. Note that some applications automatically download CRLs based on a URL embedded in a certificate. This checking happens prior to the signatures on the certificate and CRL being verified. OpenSSL's s_server, s_client and verify tools have support for the "-crl_download" option which implements automatic CRL downloading and this attack has been demonstrated to work against those tools. Note that an unrelated bug means that affected versions of OpenSSL cannot parse or construct correct encodings of EDIPARTYNAME. However it is possible to construct a malformed EDIPARTYNAME that OpenSSL's parser will accept and hence trigger this attack. All OpenSSL 1.1.1 and 1.0.2 versions are affected by this issue. Other OpenSSL releases are out of support and have not been checked. Fixed in OpenSSL 1.1.1i (Affected 1.1.1-1.1.1h). Fixed in OpenSSL 1.0.2x (Affected 1.0.2-1.0.2w).

Remediation

Upgrade openssl to version or higher.

References

medium severity

Information Exposure

  • Vulnerable module: openssl1.0/libssl1.0.2
  • Introduced through: openssl1.0/libssl1.0.2@1.0.2q-1~deb9u1
  • Fixed in: 1.0.2r-1~deb9u1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl1.0/libssl1.0.2@1.0.2q-1~deb9u1

Overview

If an application encounters a fatal protocol error and then calls SSL_shutdown() twice (once to send a close_notify, and once to receive one) then OpenSSL can respond differently to the calling application if a 0 byte record is received with invalid padding compared to if a 0 byte record is received with an invalid MAC. If the application then behaves differently based on that in a way that is detectable to the remote peer, then this amounts to a padding oracle that could be used to decrypt data. In order for this to be exploitable "non-stitched" ciphersuites must be in use. Stitched ciphersuites are optimised implementations of certain commonly used ciphersuites. Also the application must call SSL_shutdown() twice even if a protocol error has occurred (applications should not do this but some do anyway). Fixed in OpenSSL 1.0.2r (Affected 1.0.2-1.0.2q).

References

medium severity

Information Exposure

  • Vulnerable module: openssl1.0/libssl1.0.2
  • Introduced through: openssl1.0/libssl1.0.2@1.0.2q-1~deb9u1
  • Fixed in: 1.0.2u-1~deb9u1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl1.0/libssl1.0.2@1.0.2q-1~deb9u1

Overview

There is an overflow bug in the x64_64 Montgomery squaring procedure used in exponentiation with 512-bit moduli. No EC algorithms are affected. Analysis suggests that attacks against 2-prime RSA1024, 3-prime RSA1536, and DSA1024 as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH512 are considered just feasible. However, for an attack the target would have to re-use the DH512 private key, which is not recommended anyway. Also applications directly using the low level API BN_mod_exp may be affected if they use BN_FLG_CONSTTIME. Fixed in OpenSSL 1.1.1e (Affected 1.1.1-1.1.1d). Fixed in OpenSSL 1.0.2u (Affected 1.0.2-1.0.2t).

References

medium severity

Missing Encryption of Sensitive Data

  • Vulnerable module: openssl1.0/libssl1.0.2
  • Introduced through: openssl1.0/libssl1.0.2@1.0.2q-1~deb9u1
  • Fixed in: 1.0.2t-1~deb9u1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl1.0/libssl1.0.2@1.0.2q-1~deb9u1

Overview

Normally in OpenSSL EC groups always have a co-factor present and this is used in side channel resistant code paths. However, in some cases, it is possible to construct a group using explicit parameters (instead of using a named curve). In those cases it is possible that such a group does not have the cofactor present. This can occur even where all the parameters match a known named curve. If such a curve is used then OpenSSL falls back to non-side channel resistant code paths which may result in full key recovery during an ECDSA signature operation. In order to be vulnerable an attacker would have to have the ability to time the creation of a large number of signatures where explicit parameters with no co-factor present are in use by an application using libcrypto. For the avoidance of doubt libssl is not vulnerable because explicit parameters are never used. Fixed in OpenSSL 1.1.1d (Affected 1.1.1-1.1.1c). Fixed in OpenSSL 1.1.0l (Affected 1.1.0-1.1.0k). Fixed in OpenSSL 1.0.2t (Affected 1.0.2-1.0.2s).

References

medium severity

NULL Pointer Dereference

  • Vulnerable module: openssl1.0/libssl1.0.2
  • Introduced through: openssl1.0/libssl1.0.2@1.0.2q-1~deb9u1
  • Fixed in: 1.0.2u-1~deb9u3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl1.0/libssl1.0.2@1.0.2q-1~deb9u1

Overview

Affected versions of this package are vulnerable to NULL Pointer Dereference. The X.509 GeneralName type is a generic type for representing different types of names. One of those name types is known as EDIPartyName. OpenSSL provides a function GENERAL_NAME_cmp which compares different instances of a GENERAL_NAME to see if they are equal or not. This function behaves incorrectly when both GENERAL_NAMEs contain an EDIPARTYNAME. A NULL pointer dereference and a crash may occur leading to a possible denial of service attack. OpenSSL itself uses the GENERAL_NAME_cmp function for two purposes: 1) Comparing CRL distribution point names between an available CRL and a CRL distribution point embedded in an X509 certificate 2) When verifying that a timestamp response token signer matches the timestamp authority name (exposed via the API functions TS_RESP_verify_response and TS_RESP_verify_token) If an attacker can control both items being compared then that attacker could trigger a crash. For example if the attacker can trick a client or server into checking a malicious certificate against a malicious CRL then this may occur. Note that some applications automatically download CRLs based on a URL embedded in a certificate. This checking happens prior to the signatures on the certificate and CRL being verified. OpenSSL's s_server, s_client and verify tools have support for the "-crl_download" option which implements automatic CRL downloading and this attack has been demonstrated to work against those tools. Note that an unrelated bug means that affected versions of OpenSSL cannot parse or construct correct encodings of EDIPARTYNAME. However it is possible to construct a malformed EDIPARTYNAME that OpenSSL's parser will accept and hence trigger this attack. All OpenSSL 1.1.1 and 1.0.2 versions are affected by this issue. Other OpenSSL releases are out of support and have not been checked. Fixed in OpenSSL 1.1.1i (Affected 1.1.1-1.1.1h). Fixed in OpenSSL 1.0.2x (Affected 1.0.2-1.0.2w).

Remediation

Upgrade openssl1.0 to version or higher.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: pcre3/libpcre3
  • Introduced through: pcre3/libpcre3@2:8.39-3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* pcre3/libpcre3@2:8.39-3

Overview

Affected versions of this package are vulnerable to Integer Overflow or Wraparound libpcre in PCRE before 8.44 allows an integer overflow via a large number after a (?C substring.

Remediation

There is no fixed version for pcre3.

References

medium severity

OS Command Injection

  • Vulnerable module: rake
  • Introduced through: rake@10.5.0-2
  • Fixed in: 10.5.0-2+deb9u1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* rake@10.5.0-2

Overview

There is an OS command injection vulnerability in Ruby Rake < 12.3.3 in Rake::FileList when supplying a filename that begins with the pipe character |.

References

medium severity

Arbitrary Code Injection

  • Vulnerable module: ruby2.3
  • Introduced through: ruby2.3@2.3.3-1+deb9u4 and ruby2.3/libruby2.3@2.3.3-1+deb9u4
  • Fixed in: 2.3.3-1+deb9u7

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3@2.3.3-1+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3/libruby2.3@2.3.3-1+deb9u4

Overview

Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows HTTP Response Splitting. If a program using WEBrick inserts untrusted input into the response header, an attacker can exploit it to insert a newline character to split a header, and inject malicious content to deceive clients. NOTE: this issue exists because of an incomplete fix for CVE-2017-17742, which addressed the CRLF vector, but did not address an isolated CR or an isolated LF.

References

medium severity

CVE-2019-15845

  • Vulnerable module: ruby2.3
  • Introduced through: ruby2.3@2.3.3-1+deb9u4 and ruby2.3/libruby2.3@2.3.3-1+deb9u4
  • Fixed in: 2.3.3-1+deb9u7

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3@2.3.3-1+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ruby2.3/libruby2.3@2.3.3-1+deb9u4

Overview

Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 mishandles path checking within File.fnmatch functions.

References

medium severity

Out-of-Bounds

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@232-25+deb9u8 and systemd/libudev1@232-25+deb9u8
  • Fixed in: 232-25+deb9u9

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libsystemd0@232-25+deb9u8
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libudev1@232-25+deb9u8

Overview

An issue was discovered in sd-bus in systemd 239. bus_process_object() in libsystemd/sd-bus/bus-objects.c allocates a variable-length stack buffer for temporarily storing the object path of incoming D-Bus messages. An unprivileged local user can exploit this by sending a specially crafted message to PID1, causing the stack pointer to jump over the stack guard pages into an unmapped memory region and trigger a denial of service (systemd PID1 crash and kernel panic).

References

medium severity

Race Condition

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@232-25+deb9u8 and systemd/libudev1@232-25+deb9u8
  • Fixed in: 232-25+deb9u10

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libsystemd0@232-25+deb9u8
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libudev1@232-25+deb9u8

Overview

In systemd prior to 234 a race condition exists between .mount and .automount units such that automount requests from kernel may not be serviced by systemd resulting in kernel holding the mountpoint and any processes that try to use said mount will hang. A race condition like this may lead to denial of service, until mount points are unmounted.

References

medium severity

Loop with Unreachable Exit Condition ('Infinite Loop')

  • Vulnerable module: tar
  • Introduced through: tar@1.29b-1.1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* tar@1.29b-1.1

Overview

GNU Tar through 1.30, when --sparse is used, mishandles file shrinkage during read access, which allows local users to cause a denial of service (infinite read loop in sparse_dump_region in sparse.c) by modifying a file that is supposed to be archived by a different user's process (e.g., a system backup running as root).

References

low severity

Improper Verification of Cryptographic Signature

  • Vulnerable module: apt
  • Introduced through: apt@1.4.9 and apt/libapt-pkg5.0@1.4.9

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* apt@1.4.9
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* apt/libapt-pkg5.0@1.4.9

Overview

It was found that apt-key in apt, all versions, do not correctly validate gpg keys with the master keyring, leading to a potential man-in-the-middle attack.

References

low severity

Improper Check for Dropped Privileges

  • Vulnerable module: bash
  • Introduced through: bash@4.4-5

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* bash@4.4-5

Overview

An issue was discovered in disable_priv_mode in shell.c in GNU Bash through 5.0 patch 11. By default, if Bash is run with its effective UID not equal to its real UID, it will drop privileges by setting its effective UID to its real UID. However, it does so incorrectly. On Linux and other systems that support "saved UID" functionality, the saved UID is not dropped. An attacker with command execution in the shell can use "enable -f" for runtime loading of a new builtin, which can be a shared object that calls setuid() and therefore regains privileges. However, binaries running with an effective UID of 0 are unaffected.

References

low severity

Improper Input Validation

  • Vulnerable module: coreutils
  • Introduced through: coreutils@8.26-3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* coreutils@8.26-3

Overview

chroot in GNU coreutils, when used with --userspec, allows local users to escape to the parent session via a crafted TIOCSTI ioctl call, which pushes characters to the terminal's input buffer.

References

low severity

Race Condition

  • Vulnerable module: coreutils
  • Introduced through: coreutils@8.26-3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* coreutils@8.26-3

Overview

In GNU Coreutils through 8.29, chown-core.c in chown and chgrp does not prevent replacement of a plain file with a symlink during use of the POSIX "-R -L" options, which allows local users to modify the ownership of arbitrary files by leveraging a race condition.

References

low severity

Access Restriction Bypass

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

** DISPUTED ** GNU Libc current is affected by: Re-mapping current loaded library with malicious ELF file. The impact is: In worst case attacker may evaluate privileges. The component is: libld. The attack vector is: Attacker sends 2 ELF files to victim and asks to run ldd on it. ldd execute code. NOTE: Upstream comments indicate "this is being treated as a non-security bug and no real threat."

References

low severity

CVE-2010-4051

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

The regcomp implementation in the GNU C Library (aka glibc or libc6) through 2.11.3, and 2.12.x through 2.12.2, allows context-dependent attackers to cause a denial of service (application crash) via a regular expression containing adjacent bounded repetitions that bypass the intended RE_DUP_MAX limitation, as demonstrated by a {10,}{10,}{10,}{10,}{10,} sequence in the proftpd.gnu.c exploit for ProFTPD, related to a "RE_DUP_MAX overflow."

References

low severity

CVE-2020-27618

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

Affected versions of this package are vulnerable to CVE-2020-27618. The iconv function in the GNU C Library (aka glibc or libc6) 2.32 and earlier, when processing invalid multi-byte input sequences in IBM1364, IBM1371, IBM1388, IBM1390, and IBM1399 encodings, fails to advance the input state, which could lead to an infinite loop in applications, resulting in a denial of service, a different vulnerability from CVE-2016-10228.

Remediation

There is no fixed version for glibc.

References

low severity
new

Double Free

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

Affected versions of this package are vulnerable to Double Free. The nameserver caching daemon (nscd) in the GNU C Library (aka glibc or libc6) 2.29 through 2.33, when processing a request for netgroup lookup, may crash due to a double-free, potentially resulting in degraded service or Denial of Service on the local system. This is related to netgroupcache.c.

Remediation

There is no fixed version for glibc.

References

low severity

Improper Data Handling

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

The pop_fail_stack function in the GNU C Library (aka glibc or libc6) allows context-dependent attackers to cause a denial of service (assertion failure and application crash) via vectors related to extended regular expression processing.

References

low severity

Improper Input Validation

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

The iconv program in the GNU C Library (aka glibc or libc6) 2.31 and earlier, when invoked with multiple suffixes in the destination encoding (TRANSLATE or IGNORE) along with the -c option, enters an infinite loop when processing invalid multi-byte input sequences, leading to a denial of service.

References

low severity

Improper Resource Shutdown or Release

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

The string component in the GNU C Library (aka glibc or libc6) through 2.28, when running on the x32 architecture, incorrectly attempts to use a 64-bit register for size_t in assembly codes, which can lead to a segmentation fault or possibly unspecified other impact, as demonstrated by a crash in __memmove_avx_unaligned_erms in sysdeps/x86_64/multiarch/memmove-vec-unaligned-erms.S during a memcpy.

References

low severity

Information Exposure

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

** DISPUTED ** GNU Libc current is affected by: Mitigation bypass. The impact is: Attacker may bypass ASLR using cache of thread stack and heap. The component is: glibc. NOTE: Upstream comments indicate "this is being treated as a non-security bug and no real threat."

References

low severity

Information Exposure

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

On the x86-64 architecture, the GNU C Library (aka glibc) before 2.31 fails to ignore the LD_PREFER_MAP_32BIT_EXEC environment variable during program execution after a security transition, allowing local attackers to restrict the possible mapping addresses for loaded libraries and thus bypass ASLR for a setuid program.

References

low severity

Integer Underflow

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

An exploitable signed comparison vulnerability exists in the ARMv7 memcpy() implementation of GNU glibc 2.30.9000. Calling memcpy() (on ARMv7 targets that utilize the GNU glibc implementation) with a negative value for the 'num' parameter results in a signed comparison vulnerability. If an attacker underflows the 'num' parameter to memcpy(), this vulnerability could lead to undefined behavior such as writing to out-of-bounds memory and potentially remote code execution. Furthermore, this memcpy() implementation allows for program execution to continue in scenarios where a segmentation fault or crash should have occurred. The dangers occur in that subsequent execution and iterations of this code will be executed with this corrupted data.

References

low severity

Out-of-Bounds

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

In the GNU C Library (aka glibc or libc6) through 2.29, the memcmp function for the x32 architecture can incorrectly return zero (indicating that the inputs are equal) because the RDX most significant bit is mishandled.

References

low severity

Out-of-Bounds

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

** DISPUTED ** GNU Libc current is affected by: Mitigation bypass. The impact is: Attacker may bypass stack guard protection. The component is: nptl. The attack vector is: Exploit stack buffer overflow vulnerability and use this bypass vulnerability to bypass stack guard. NOTE: Upstream comments indicate "this is being treated as a non-security bug and no real threat."

References

low severity

Resource Management Errors

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

Stack consumption vulnerability in the regcomp implementation in the GNU C Library (aka glibc or libc6) through 2.11.3, and 2.12.x through 2.12.2, allows context-dependent attackers to cause a denial of service (resource exhaustion) via a regular expression containing adjacent repetition operators, as demonstrated by a {10,}{10,}{10,}{10,} sequence in the proftpd.gnu.c exploit for ProFTPD.

References

low severity

Resource Management Errors

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

The glob implementation in the GNU C Library (aka glibc or libc6) allows remote authenticated users to cause a denial of service (CPU and memory consumption) via crafted glob expressions that do not match any pathnames, as demonstrated by glob expressions in STAT commands to an FTP daemon, a different vulnerability than CVE-2010-2632.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

** DISPUTED ** In the GNU C Library (aka glibc or libc6) through 2.29, check_dst_limits_calc_pos_1 in posix/regexec.c has Uncontrolled Recursion, as demonstrated by '(|)(\1\1)*' in grep, a different issue than CVE-2018-20796. NOTE: the software maintainer disputes that this is a vulnerability because the behavior occurs only with a crafted pattern.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

In the GNU C Library (aka glibc or libc6) through 2.29, check_dst_limits_calc_pos_1 in posix/regexec.c has Uncontrolled Recursion, as demonstrated by '(\227|)(\1\1|t1|\\2537)+' in grep.

References

low severity

Use of Insufficiently Random Values

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.24-11+deb9u3, glibc/libc-dev-bin@2.24-11+deb9u4 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-bin@2.24-11+deb9u3
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc-dev-bin@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/libc6-dev@2.24-11+deb9u4
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* glibc/multiarch-support@2.24-11+deb9u3

Overview

** DISPUTED ** GNU Libc current is affected by: Mitigation bypass. The impact is: Attacker may guess the heap addresses of pthread_created thread. The component is: glibc. NOTE: the vendor's position is "ASLR bypass itself is not a vulnerability."

References

low severity

Key Management Errors

  • Vulnerable module: gnupg2/gpgv
  • Introduced through: gnupg2/gpgv@2.1.18-8~deb9u3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* gnupg2/gpgv@2.1.18-8~deb9u3

Overview

GnuPG 2.2.4 and 2.2.5 does not enforce a configuration in which key certification requires an offline master Certify key, which results in apparently valid certifications that occurred only with access to a signing subkey.

References

low severity

Use of a Broken or Risky Cryptographic Algorithm

  • Vulnerable module: gnupg2/gpgv
  • Introduced through: gnupg2/gpgv@2.1.18-8~deb9u3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* gnupg2/gpgv@2.1.18-8~deb9u3

Overview

A flaw was found in the way certificate signatures could be forged using collisions found in the SHA-1 algorithm. An attacker could use this weakness to create forged certificate signatures. This issue affects GnuPG versions before 2.2.18.

References

low severity

Use of a Broken or Risky Cryptographic Algorithm

  • Vulnerable module: libgcrypt20
  • Introduced through: libgcrypt20@1.7.6-2+deb9u3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* libgcrypt20@1.7.6-2+deb9u3

Overview

cipher/elgamal.c in Libgcrypt through 1.8.2, when used to encrypt messages directly, improperly encodes plaintexts, which allows attackers to obtain sensitive information by reading ciphertext data (i.e., it does not have semantic security in face of a ciphertext-only attack). The Decisional Diffie-Hellman (DDH) assumption does not hold for Libgcrypt's ElGamal implementation.

References

low severity

Buffer Overflow

  • Vulnerable module: lz4/liblz4-1
  • Introduced through: lz4/liblz4-1@0.0~r131-2+b1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* lz4/liblz4-1@0.0~r131-2+b1

Overview

LZ4 before 1.9.2 has a heap-based buffer overflow in LZ4_write32 (related to LZ4_compress_destSize), affecting applications that call LZ4_compress_fast with a large input. (This issue can also lead to data corruption.) NOTE: the vendor states "only a few specific / uncommon usages of the API are at risk."

References

low severity

NULL Pointer Dereference

  • Vulnerable module: ncurses/libncurses5
  • Introduced through: ncurses/libncurses5@6.0+20161126-1+deb9u2, ncurses/libncursesw5@6.0+20161126-1+deb9u2 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/libncurses5@6.0+20161126-1+deb9u2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/libncursesw5@6.0+20161126-1+deb9u2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/libtinfo5@6.0+20161126-1+deb9u2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/ncurses-base@6.0+20161126-1+deb9u2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/ncurses-bin@6.0+20161126-1+deb9u2

Overview

In ncurses 6.1, there is a NULL pointer dereference at function _nc_parse_entry in parse_entry.c that will lead to a denial of service attack. The product proceeds to the dereference code path even after a "dubious character `*' in name or alias field" detection.

References

low severity

Out-of-bounds Read

  • Vulnerable module: ncurses/libncurses5
  • Introduced through: ncurses/libncurses5@6.0+20161126-1+deb9u2, ncurses/libncursesw5@6.0+20161126-1+deb9u2 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/libncurses5@6.0+20161126-1+deb9u2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/libncursesw5@6.0+20161126-1+deb9u2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/libtinfo5@6.0+20161126-1+deb9u2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/ncurses-base@6.0+20161126-1+deb9u2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/ncurses-bin@6.0+20161126-1+deb9u2

Overview

There is a heap-based buffer over-read in the fmt_entry function in tinfo/comp_hash.c in the terminfo library in ncurses before 6.1-20191012.

References

low severity

Out-of-bounds Read

  • Vulnerable module: ncurses/libncurses5
  • Introduced through: ncurses/libncurses5@6.0+20161126-1+deb9u2, ncurses/libncursesw5@6.0+20161126-1+deb9u2 and others

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/libncurses5@6.0+20161126-1+deb9u2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/libncursesw5@6.0+20161126-1+deb9u2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/libtinfo5@6.0+20161126-1+deb9u2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/ncurses-base@6.0+20161126-1+deb9u2
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* ncurses/ncurses-bin@6.0+20161126-1+deb9u2

Overview

There is a heap-based buffer over-read in the _nc_find_entry function in tinfo/comp_hash.c in the terminfo library in ncurses before 6.1-20191012.

References

low severity

Cryptographic Issues

  • Vulnerable module: openssl
  • Introduced through: openssl@1.1.0j-1~deb9u1 and openssl/libssl1.1@1.1.0j-1~deb9u1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl@1.1.0j-1~deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl/libssl1.1@1.1.0j-1~deb9u1

Overview

The NIST SP 800-90A default statement of the Dual Elliptic Curve Deterministic Random Bit Generation (Dual_EC_DRBG) algorithm contains point Q constants with a possible relationship to certain "skeleton key" values, which might allow context-dependent attackers to defeat cryptographic protection mechanisms by leveraging knowledge of those values. NOTE: this is a preliminary CVE for Dual_EC_DRBG; future research may provide additional details about point Q and associated attacks, and could potentially lead to a RECAST or REJECT of this CVE.

References

low severity

Cryptographic Issues

  • Vulnerable module: openssl
  • Introduced through: openssl@1.1.0j-1~deb9u1 and openssl/libssl1.1@1.1.0j-1~deb9u1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl@1.1.0j-1~deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl/libssl1.1@1.1.0j-1~deb9u1

Overview

OpenSSL 0.9.8i on the Gaisler Research LEON3 SoC on the Xilinx Virtex-II Pro FPGA uses a Fixed Width Exponentiation (FWE) algorithm for certain signature calculations, and does not verify the signature before providing it to a caller, which makes it easier for physically proximate attackers to determine the private key via a modified supply voltage for the microprocessor, related to a "fault-based attack."

References

low severity

Information Exposure

  • Vulnerable module: openssl
  • Introduced through: openssl@1.1.0j-1~deb9u1 and openssl/libssl1.1@1.1.0j-1~deb9u1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl@1.1.0j-1~deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl/libssl1.1@1.1.0j-1~deb9u1

Overview

There is an overflow bug in the x64_64 Montgomery squaring procedure used in exponentiation with 512-bit moduli. No EC algorithms are affected. Analysis suggests that attacks against 2-prime RSA1024, 3-prime RSA1536, and DSA1024 as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH512 are considered just feasible. However, for an attack the target would have to re-use the DH512 private key, which is not recommended anyway. Also applications directly using the low level API BN_mod_exp may be affected if they use BN_FLG_CONSTTIME. Fixed in OpenSSL 1.1.1e (Affected 1.1.1-1.1.1d). Fixed in OpenSSL 1.0.2u (Affected 1.0.2-1.0.2t).

References

low severity

Missing Encryption of Sensitive Data

  • Vulnerable module: openssl
  • Introduced through: openssl@1.1.0j-1~deb9u1 and openssl/libssl1.1@1.1.0j-1~deb9u1
  • Fixed in: 1.1.0l-1~deb9u1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl@1.1.0j-1~deb9u1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl/libssl1.1@1.1.0j-1~deb9u1

Overview

In situations where an attacker receives automated notification of the success or failure of a decryption attempt an attacker, after sending a very large number of messages to be decrypted, can recover a CMS/PKCS7 transported encryption key or decrypt any RSA encrypted message that was encrypted with the public RSA key, using a Bleichenbacher padding oracle attack. Applications are not affected if they use a certificate together with the private RSA key to the CMS_decrypt or PKCS7_decrypt functions to select the correct recipient info to decrypt. Fixed in OpenSSL 1.1.1d (Affected 1.1.1-1.1.1c). Fixed in OpenSSL 1.1.0l (Affected 1.1.0-1.1.0k). Fixed in OpenSSL 1.0.2t (Affected 1.0.2-1.0.2s).

References

low severity

Inadequate Encryption Strength

  • Vulnerable module: openssl1.0/libssl1.0.2
  • Introduced through: openssl1.0/libssl1.0.2@1.0.2q-1~deb9u1
  • Fixed in: 1.0.2u-1~deb9u2

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl1.0/libssl1.0.2@1.0.2q-1~deb9u1

Overview

Affected versions of this package are vulnerable to Inadequate Encryption Strength. The Raccoon attack exploits a flaw in the TLS specification which can lead to an attacker being able to compute the pre-master secret in connections which have used a Diffie-Hellman (DH) based ciphersuite. In such a case this would result in the attacker being able to eavesdrop on all encrypted communications sent over that TLS connection. The attack can only be exploited if an implementation re-uses a DH secret across multiple TLS connections. Note that this issue only impacts DH ciphersuites and not ECDH ciphersuites. This issue affects OpenSSL 1.0.2 which is out of support and no longer receiving public updates. OpenSSL 1.1.1 is not vulnerable to this issue. Fixed in OpenSSL 1.0.2w (Affected 1.0.2-1.0.2v).

Remediation

Upgrade openssl1.0 to version or higher.

References

low severity

Missing Encryption of Sensitive Data

  • Vulnerable module: openssl1.0/libssl1.0.2
  • Introduced through: openssl1.0/libssl1.0.2@1.0.2q-1~deb9u1
  • Fixed in: 1.0.2t-1~deb9u1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* openssl1.0/libssl1.0.2@1.0.2q-1~deb9u1

Overview

In situations where an attacker receives automated notification of the success or failure of a decryption attempt an attacker, after sending a very large number of messages to be decrypted, can recover a CMS/PKCS7 transported encryption key or decrypt any RSA encrypted message that was encrypted with the public RSA key, using a Bleichenbacher padding oracle attack. Applications are not affected if they use a certificate together with the private RSA key to the CMS_decrypt or PKCS7_decrypt functions to select the correct recipient info to decrypt. Fixed in OpenSSL 1.1.1d (Affected 1.1.1-1.1.1c). Fixed in OpenSSL 1.1.0l (Affected 1.1.0-1.1.0k). Fixed in OpenSSL 1.0.2t (Affected 1.0.2-1.0.2s).

References

low severity

Out-of-Bounds

  • Vulnerable module: pcre3/libpcre3
  • Introduced through: pcre3/libpcre3@2:8.39-3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* pcre3/libpcre3@2:8.39-3

Overview

Stack-based buffer overflow in the pcre32_copy_substring function in pcre_get.c in libpcre1 in PCRE 8.40 allows remote attackers to cause a denial of service (WRITE of size 4) or possibly have unspecified other impact via a crafted file.

References

low severity

Out-of-Bounds

  • Vulnerable module: pcre3/libpcre3
  • Introduced through: pcre3/libpcre3@2:8.39-3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* pcre3/libpcre3@2:8.39-3

Overview

Stack-based buffer overflow in the pcre32_copy_substring function in pcre_get.c in libpcre1 in PCRE 8.40 allows remote attackers to cause a denial of service (WRITE of size 268) or possibly have unspecified other impact via a crafted file.

References

low severity

Out-of-Bounds

  • Vulnerable module: pcre3/libpcre3
  • Introduced through: pcre3/libpcre3@2:8.39-3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* pcre3/libpcre3@2:8.39-3

Overview

** DISPUTED ** In PCRE 8.41, after compiling, a pcretest load test PoC produces a crash overflow in the function match() in pcre_exec.c because of a self-recursive call. NOTE: third parties dispute the relevance of this report, noting that there are options that can be used to limit the amount of stack that is used.

References

low severity

Out-of-bounds Read

  • Vulnerable module: pcre3/libpcre3
  • Introduced through: pcre3/libpcre3@2:8.39-3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* pcre3/libpcre3@2:8.39-3

Overview

Affected versions of this package are vulnerable to Out-of-bounds Read libpcre in PCRE before 8.43 allows a subject buffer over-read in JIT when UTF is disabled, and \X or \R has more than one fixed quantifier, a related issue to CVE-2019-20454.

Remediation

There is no fixed version for pcre3.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: pcre3/libpcre3
  • Introduced through: pcre3/libpcre3@2:8.39-3

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* pcre3/libpcre3@2:8.39-3

Overview

In PCRE 8.41, the OP_KETRMAX feature in the match function in pcre_exec.c allows stack exhaustion (uncontrolled recursion) when processing a crafted regular expression.

References

low severity

Link Following

  • Vulnerable module: perl/perl-base
  • Introduced through: perl/perl-base@5.24.1-3+deb9u5

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* perl/perl-base@5.24.1-3+deb9u5

Overview

_is_safe in the File::Temp module for Perl does not properly handle symlinks.

References

low severity

Access Restriction Bypass

  • Vulnerable module: shadow/login
  • Introduced through: shadow/login@1:4.4-4.1 and shadow/passwd@1:4.4-4.1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* shadow/login@1:4.4-4.1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* shadow/passwd@1:4.4-4.1

Overview

initscripts in rPath Linux 1 sets insecure permissions for the /var/log/btmp file, which allows local users to obtain sensitive information regarding authentication attempts. NOTE: because sshd detects the insecure permissions and does not log certain events, this also prevents sshd from logging failed authentication attempts by remote attackers.

References

low severity

Incorrect Permission Assignment for Critical Resource

  • Vulnerable module: shadow/login
  • Introduced through: shadow/login@1:4.4-4.1 and shadow/passwd@1:4.4-4.1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* shadow/login@1:4.4-4.1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* shadow/passwd@1:4.4-4.1

Overview

An issue was discovered in shadow 4.5. newgidmap (in shadow-utils) is setuid and allows an unprivileged user to be placed in a user namespace where setgroups(2) is permitted. This allows an attacker to remove themselves from a supplementary group, which may allow access to certain filesystem paths if the administrator has used "group blacklisting" (e.g., chmod g-rwx) to restrict access to paths. This flaw effectively reverts a security feature in the kernel (in particular, the /proc/self/setgroups knob) to prevent this sort of privilege escalation.

References

low severity

Incorrect Permission Assignment for Critical Resource

  • Vulnerable module: shadow/login
  • Introduced through: shadow/login@1:4.4-4.1 and shadow/passwd@1:4.4-4.1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* shadow/login@1:4.4-4.1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* shadow/passwd@1:4.4-4.1

Overview

shadow 4.8, in certain circumstances affecting at least Gentoo, Arch Linux, and Void Linux, allows local users to obtain root access because setuid programs are misconfigured. Specifically, this affects shadow 4.8 when compiled using --with-libpam but without explicitly passing --disable-account-tools-setuid, and without a PAM configuration suitable for use with setuid account management tools. This combination leads to account management tools (groupadd, groupdel, groupmod, useradd, userdel, usermod) that can easily be used by unprivileged local users to escalate privileges to root in multiple ways. This issue became much more relevant in approximately December 2019 when an unrelated bug was fixed (i.e., the chmod calls to suidusbins were fixed in the upstream Makefile which is now included in the release version 4.8).

References

low severity

Time-of-check Time-of-use (TOCTOU)

  • Vulnerable module: shadow/login
  • Introduced through: shadow/login@1:4.4-4.1 and shadow/passwd@1:4.4-4.1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* shadow/login@1:4.4-4.1
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* shadow/passwd@1:4.4-4.1

Overview

shadow: TOCTOU (time-of-check time-of-use) race condition when copying and removing directory trees

References

low severity

Access Restriction Bypass

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@232-25+deb9u8 and systemd/libudev1@232-25+deb9u8

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libsystemd0@232-25+deb9u8
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libudev1@232-25+deb9u8

Overview

systemd-tmpfiles in systemd through 237 mishandles symlinks present in non-terminal path components, which allows local users to obtain ownership of arbitrary files via vectors involving creation of a directory and a file under that directory, and later replacing that directory with a symlink. This occurs even if the fs.protected_symlinks sysctl is turned on.

References

low severity

CVE-2019-9619

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@232-25+deb9u8 and systemd/libudev1@232-25+deb9u8

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libsystemd0@232-25+deb9u8
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libudev1@232-25+deb9u8

Overview

CVE-2019-9619

References

low severity

Improper Input Validation

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@232-25+deb9u8 and systemd/libudev1@232-25+deb9u8

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libsystemd0@232-25+deb9u8
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libudev1@232-25+deb9u8

Overview

It was discovered systemd does not correctly check the content of PIDFile files before using it to kill processes. When a service is run from an unprivileged user (e.g. User field set in the service file), a local attacker who is able to write to the PIDFile of the mentioned service may use this flaw to trick systemd into killing other services and/or privileged processes. Versions before v237 are vulnerable.

References

low severity

Improper Input Validation

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@232-25+deb9u8 and systemd/libudev1@232-25+deb9u8

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libsystemd0@232-25+deb9u8
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libudev1@232-25+deb9u8

Overview

systemd v233 and earlier fails to safely parse usernames starting with a numeric digit (e.g. "0day"), running the service in question with root privileges rather than the user intended.

References

low severity

Improper Input Validation

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@232-25+deb9u8 and systemd/libudev1@232-25+deb9u8

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libsystemd0@232-25+deb9u8
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libudev1@232-25+deb9u8

Overview

Affected versions of this package are vulnerable to Improper Input Validation systemd through v245 mishandles numerical usernames such as ones composed of decimal digits or 0x followed by hex digits, as demonstrated by use of root privileges when privileges of the 0x0 user account were intended. NOTE: this issue exists because of an incomplete fix for CVE-2017-1000082.

Remediation

There is no fixed version for systemd.

References

low severity

Link Following

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@232-25+deb9u8 and systemd/libudev1@232-25+deb9u8

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libsystemd0@232-25+deb9u8
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libudev1@232-25+deb9u8

Overview

systemd, when updating file permissions, allows local users to change the permissions and SELinux security contexts for arbitrary files via a symlink attack on unspecified files.

References

low severity

Link Following

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@232-25+deb9u8 and systemd/libudev1@232-25+deb9u8

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libsystemd0@232-25+deb9u8
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libudev1@232-25+deb9u8

Overview

systemd-tmpfiles in systemd before 237 attempts to support ownership/permission changes on hardlinked files even if the fs.protected_hardlinks sysctl is turned off, which allows local users to bypass intended access restrictions via vectors involving a hard link to a file for which the user lacks write access, as demonstrated by changing the ownership of the /etc/passwd file.

References

low severity

Missing Release of Resource after Effective Lifetime

  • Vulnerable module: systemd/libsystemd0
  • Introduced through: systemd/libsystemd0@232-25+deb9u8 and systemd/libudev1@232-25+deb9u8

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libsystemd0@232-25+deb9u8
  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* systemd/libudev1@232-25+deb9u8

Overview

An issue was discovered in button_open in login/logind-button.c in systemd before 243. When executing the udevadm trigger command, a memory leak may occur.

References

low severity

CVE-2005-2541

  • Vulnerable module: tar
  • Introduced through: tar@1.29b-1.1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* tar@1.29b-1.1

Overview

Tar 1.15.1 does not properly warn the user when extracting setuid or setgid files, which may allow local users or remote attackers to gain privileges.

This is considered intended behaviour, as tar is an archiving tool and one needs to give -p as a command line flag

References

low severity

CVE-2021-20193

  • Vulnerable module: tar
  • Introduced through: tar@1.29b-1.1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* tar@1.29b-1.1

Overview

Affected versions of this package are vulnerable to CVE-2021-20193.

Remediation

There is no fixed version for tar.

References

low severity

NULL Pointer Dereference

  • Vulnerable module: tar
  • Introduced through: tar@1.29b-1.1

Detailed paths

  • Introduced through: fluent/fluentd:v1.4.0-debian-onbuild-1.0@* tar@1.29b-1.1

Overview

pax_decode_header in sparse.c in GNU Tar before 1.32 had a NULL pointer dereference when parsing certain archives that have malformed extended headers.

References