Docker docker:git

Vulnerabilities

5 via 5 paths

Dependencies

26

Source

Group 6 Copy Created with Sketch. Docker

Target OS

alpine:3.13.5
Test your Docker Hub image against our market leading vulnerability database Sign up for free
Severity
  • 5
Status
  • 5
  • 0
  • 0

low severity
new

CVE-2021-36159

  • Vulnerable module: apk-tools/apk-tools
  • Introduced through: apk-tools/apk-tools@2.12.5-r0
  • Fixed in: 2.12.6-r0

Detailed paths

  • Introduced through: docker:git@* apk-tools/apk-tools@2.12.5-r0

NVD Description

Note: Versions mentioned in the description apply to the upstream apk-tools package. See Remediation section below for Alpine:3.13 relevant versions.

None

Remediation

Upgrade Alpine:3.13 apk-tools to version 2.12.6-r0 or higher.

low severity
new

CVE-2021-22922

  • Vulnerable module: curl/libcurl
  • Introduced through: curl/libcurl@7.77.0-r0
  • Fixed in: 7.78.0-r0

Detailed paths

  • Introduced through: docker:git@* curl/libcurl@7.77.0-r0

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Alpine:3.13 relevant versions.

None

Remediation

Upgrade Alpine:3.13 curl to version 7.78.0-r0 or higher.

low severity
new

CVE-2021-22923

  • Vulnerable module: curl/libcurl
  • Introduced through: curl/libcurl@7.77.0-r0
  • Fixed in: 7.78.0-r0

Detailed paths

  • Introduced through: docker:git@* curl/libcurl@7.77.0-r0

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Alpine:3.13 relevant versions.

None

Remediation

Upgrade Alpine:3.13 curl to version 7.78.0-r0 or higher.

low severity
new

CVE-2021-22924

  • Vulnerable module: curl/libcurl
  • Introduced through: curl/libcurl@7.77.0-r0
  • Fixed in: 7.78.0-r0

Detailed paths

  • Introduced through: docker:git@* curl/libcurl@7.77.0-r0

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Alpine:3.13 relevant versions.

None

Remediation

Upgrade Alpine:3.13 curl to version 7.78.0-r0 or higher.

low severity
new

CVE-2021-22925

  • Vulnerable module: curl/libcurl
  • Introduced through: curl/libcurl@7.77.0-r0
  • Fixed in: 7.78.0-r0

Detailed paths

  • Introduced through: docker:git@* curl/libcurl@7.77.0-r0

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Alpine:3.13 relevant versions.

None

Remediation

Upgrade Alpine:3.13 curl to version 7.78.0-r0 or higher.