Docker concourse/concourse:6-ubuntu

Vulnerabilities

22 via 50 paths

Dependencies

112

Source

Group 6 Copy Created with Sketch. Docker

Target OS

ubuntu:18.04
Test your Docker Hub image against our market leading vulnerability database Sign up for free
Severity
  • 1
  • 21
Status
  • 22
  • 0
  • 0

medium severity

Information Exposure

  • Vulnerable module: gcc-8/gcc-8-base
  • Introduced through: gcc-8/gcc-8-base@8.4.0-1ubuntu1~18.04, gcc-8/libgcc1@1:8.4.0-1ubuntu1~18.04 and others

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* gcc-8/gcc-8-base@8.4.0-1ubuntu1~18.04
  • Introduced through: concourse/concourse:6-ubuntu@* gcc-8/libgcc1@1:8.4.0-1ubuntu1~18.04
  • Introduced through: concourse/concourse:6-ubuntu@* gcc-8/libstdc++6@8.4.0-1ubuntu1~18.04

NVD Description

Note: Versions mentioned in the description apply to the upstream gcc-8 package.

Arm Armv8-A core implementations utilizing speculative execution past unconditional changes in control flow may allow unauthorized disclosure of information to an attacker with local user access via a side-channel analysis, aka "straight-line speculation."

Remediation

There is no fixed version for Ubuntu:18.04 gcc-8.

References

low severity

Improper Check for Dropped Privileges

  • Vulnerable module: bash
  • Introduced through: bash@4.4.18-2ubuntu1.2

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* bash@4.4.18-2ubuntu1.2

NVD Description

Note: Versions mentioned in the description apply to the upstream bash package.

An issue was discovered in disable_priv_mode in shell.c in GNU Bash through 5.0 patch 11. By default, if Bash is run with its effective UID not equal to its real UID, it will drop privileges by setting its effective UID to its real UID. However, it does so incorrectly. On Linux and other systems that support "saved UID" functionality, the saved UID is not dropped. An attacker with command execution in the shell can use "enable -f" for runtime loading of a new builtin, which can be a shared object that calls setuid() and therefore regains privileges. However, binaries running with an effective UID of 0 are unaffected.

Remediation

There is no fixed version for Ubuntu:18.04 bash.

References

low severity

Improper Input Validation

  • Vulnerable module: coreutils
  • Introduced through: coreutils@8.28-1ubuntu1

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* coreutils@8.28-1ubuntu1

NVD Description

Note: Versions mentioned in the description apply to the upstream coreutils package.

chroot in GNU coreutils, when used with --userspec, allows local users to escape to the parent session via a crafted TIOCSTI ioctl call, which pushes characters to the terminal's input buffer.

Remediation

There is no fixed version for Ubuntu:18.04 coreutils.

References

low severity

Improper Data Handling

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.27-3ubuntu1.4, glibc/libc6@2.27-3ubuntu1.4 and others

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* glibc/libc-bin@2.27-3ubuntu1.4
  • Introduced through: concourse/concourse:6-ubuntu@* glibc/libc6@2.27-3ubuntu1.4
  • Introduced through: concourse/concourse:6-ubuntu@* glibc/multiarch-support@2.27-3ubuntu1.4

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

In the GNU C Library (aka glibc or libc6) before 2.28, parse_reg_exp in posix/regcomp.c misparses alternatives, which allows attackers to cause a denial of service (assertion failure and application exit) or trigger an incorrect result by attempting a regular-expression match.

Remediation

There is no fixed version for Ubuntu:18.04 glibc.

References

low severity

Improper Data Handling

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.27-3ubuntu1.4, glibc/libc6@2.27-3ubuntu1.4 and others

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* glibc/libc-bin@2.27-3ubuntu1.4
  • Introduced through: concourse/concourse:6-ubuntu@* glibc/libc6@2.27-3ubuntu1.4
  • Introduced through: concourse/concourse:6-ubuntu@* glibc/multiarch-support@2.27-3ubuntu1.4

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The pop_fail_stack function in the GNU C Library (aka glibc or libc6) allows context-dependent attackers to cause a denial of service (assertion failure and application crash) via vectors related to extended regular expression processing.

Remediation

There is no fixed version for Ubuntu:18.04 glibc.

References

low severity

Improper Input Validation

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.27-3ubuntu1.4, glibc/libc6@2.27-3ubuntu1.4 and others

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* glibc/libc-bin@2.27-3ubuntu1.4
  • Introduced through: concourse/concourse:6-ubuntu@* glibc/libc6@2.27-3ubuntu1.4
  • Introduced through: concourse/concourse:6-ubuntu@* glibc/multiarch-support@2.27-3ubuntu1.4

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The iconv program in the GNU C Library (aka glibc or libc6) 2.31 and earlier, when invoked with multiple suffixes in the destination encoding (TRANSLATE or IGNORE) along with the -c option, enters an infinite loop when processing invalid multi-byte input sequences, leading to a denial of service.

Remediation

There is no fixed version for Ubuntu:18.04 glibc.

References

low severity

Improper Input Validation

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.27-3ubuntu1.4, glibc/libc6@2.27-3ubuntu1.4 and others

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* glibc/libc-bin@2.27-3ubuntu1.4
  • Introduced through: concourse/concourse:6-ubuntu@* glibc/libc6@2.27-3ubuntu1.4
  • Introduced through: concourse/concourse:6-ubuntu@* glibc/multiarch-support@2.27-3ubuntu1.4

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

In the GNU C Library (aka glibc or libc6) through 2.28, the getaddrinfo function would successfully parse a string that contained an IPv4 address followed by whitespace and arbitrary characters, which could lead applications to incorrectly assume that it had parsed a valid string, without the possibility of embedded HTTP headers or other potentially dangerous substrings.

Remediation

There is no fixed version for Ubuntu:18.04 glibc.

References

low severity

Integer Underflow

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.27-3ubuntu1.4, glibc/libc6@2.27-3ubuntu1.4 and others

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* glibc/libc-bin@2.27-3ubuntu1.4
  • Introduced through: concourse/concourse:6-ubuntu@* glibc/libc6@2.27-3ubuntu1.4
  • Introduced through: concourse/concourse:6-ubuntu@* glibc/multiarch-support@2.27-3ubuntu1.4

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

An exploitable signed comparison vulnerability exists in the ARMv7 memcpy() implementation of GNU glibc 2.30.9000. Calling memcpy() (on ARMv7 targets that utilize the GNU glibc implementation) with a negative value for the 'num' parameter results in a signed comparison vulnerability. If an attacker underflows the 'num' parameter to memcpy(), this vulnerability could lead to undefined behavior such as writing to out-of-bounds memory and potentially remote code execution. Furthermore, this memcpy() implementation allows for program execution to continue in scenarios where a segmentation fault or crash should have occurred. The dangers occur in that subsequent execution and iterations of this code will be executed with this corrupted data.

Remediation

There is no fixed version for Ubuntu:18.04 glibc.

References

low severity

Loop with Unreachable Exit Condition ('Infinite Loop')

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.27-3ubuntu1.4, glibc/libc6@2.27-3ubuntu1.4 and others

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* glibc/libc-bin@2.27-3ubuntu1.4
  • Introduced through: concourse/concourse:6-ubuntu@* glibc/libc6@2.27-3ubuntu1.4
  • Introduced through: concourse/concourse:6-ubuntu@* glibc/multiarch-support@2.27-3ubuntu1.4

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The iconv function in the GNU C Library (aka glibc or libc6) 2.32 and earlier, when processing invalid multi-byte input sequences in IBM1364, IBM1371, IBM1388, IBM1390, and IBM1399 encodings, fails to advance the input state, which could lead to an infinite loop in applications, resulting in a denial of service, a different vulnerability from CVE-2016-10228.

Remediation

There is no fixed version for Ubuntu:18.04 glibc.

References

low severity

Out-of-bounds Read

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.27-3ubuntu1.4, glibc/libc6@2.27-3ubuntu1.4 and others

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* glibc/libc-bin@2.27-3ubuntu1.4
  • Introduced through: concourse/concourse:6-ubuntu@* glibc/libc6@2.27-3ubuntu1.4
  • Introduced through: concourse/concourse:6-ubuntu@* glibc/multiarch-support@2.27-3ubuntu1.4

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The iconv feature in the GNU C Library (aka glibc or libc6) through 2.32, when processing invalid multi-byte input sequences in the EUC-KR encoding, may have a buffer over-read.

Remediation

There is no fixed version for Ubuntu:18.04 glibc.

References

low severity
new

Reachable Assertion

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.27-3ubuntu1.4, glibc/libc6@2.27-3ubuntu1.4 and others

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* glibc/libc-bin@2.27-3ubuntu1.4
  • Introduced through: concourse/concourse:6-ubuntu@* glibc/libc6@2.27-3ubuntu1.4
  • Introduced through: concourse/concourse:6-ubuntu@* glibc/multiarch-support@2.27-3ubuntu1.4

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The iconv function in the GNU C Library (aka glibc or libc6) 2.32 and earlier, when processing invalid input sequences in the ISO-2022-JP-3 encoding, fails an assertion in the code path and aborts the program, potentially resulting in a denial of service.

Remediation

There is no fixed version for Ubuntu:18.04 glibc.

References

low severity

Improper Certificate Validation

  • Vulnerable module: gnupg2/gpgv
  • Introduced through: gnupg2/gpgv@2.2.4-1ubuntu1.4

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* gnupg2/gpgv@2.2.4-1ubuntu1.4

NVD Description

Note: Versions mentioned in the description apply to the upstream gnupg2 package.

Interaction between the sks-keyserver code through 1.2.0 of the SKS keyserver network, and GnuPG through 2.2.16, makes it risky to have a GnuPG keyserver configuration line referring to a host on the SKS keyserver network. Retrieving data from this network may cause a persistent denial of service, because of a Certificate Spamming Attack.

Remediation

There is no fixed version for Ubuntu:18.04 gnupg2.

References

low severity

Information Exposure

  • Vulnerable module: gnutls28/libgnutls30
  • Introduced through: gnutls28/libgnutls30@3.5.18-1ubuntu1.4

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* gnutls28/libgnutls30@3.5.18-1ubuntu1.4

NVD Description

Note: Versions mentioned in the description apply to the upstream gnutls28 package.

A Bleichenbacher type side-channel based padding oracle attack was found in the way gnutls handles verification of RSA decrypted PKCS#1 v1.5 data. An attacker who is able to run process on the same physical core as the victim process, could use this to extract plaintext or in some cases downgrade any TLS connections to a vulnerable server.

Remediation

There is no fixed version for Ubuntu:18.04 gnutls28.

References

low severity

Information Exposure

  • Vulnerable module: libgcrypt20
  • Introduced through: libgcrypt20@1.8.1-4ubuntu1.2

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* libgcrypt20@1.8.1-4ubuntu1.2

NVD Description

Note: Versions mentioned in the description apply to the upstream libgcrypt20 package.

Libgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption because it lacks exponent blinding to address a side-channel attack against mpi_powm, and the window size is not chosen appropriately. (There is also an interoperability problem because the selection of the k integer value does not properly consider the differences between basic ElGamal encryption and generalized ElGamal encryption.) This, for example, affects use of ElGamal in OpenPGP.

Remediation

There is no fixed version for Ubuntu:18.04 libgcrypt20.

References

low severity

Resource Management Errors

  • Vulnerable module: libtasn1-6
  • Introduced through: libtasn1-6@4.13-2

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* libtasn1-6@4.13-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libtasn1-6 package.

GNU Libtasn1-4.13 libtasn1-4.13 version libtasn1-4.13, libtasn1-4.12 contains a DoS, specifically CPU usage will reach 100% when running asn1Paser against the POC due to an issue in _asn1_expand_object_id(p_tree), after a long time, the program will be killed. This attack appears to be exploitable via parsing a crafted file.

Remediation

There is no fixed version for Ubuntu:18.04 libtasn1-6.

References

low severity

Out-of-bounds Read

  • Vulnerable module: ncurses/libncurses5
  • Introduced through: ncurses/libncurses5@6.1-1ubuntu1.18.04, ncurses/libncursesw5@6.1-1ubuntu1.18.04 and others

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* ncurses/libncurses5@6.1-1ubuntu1.18.04
  • Introduced through: concourse/concourse:6-ubuntu@* ncurses/libncursesw5@6.1-1ubuntu1.18.04
  • Introduced through: concourse/concourse:6-ubuntu@* ncurses/libtinfo5@6.1-1ubuntu1.18.04
  • Introduced through: concourse/concourse:6-ubuntu@* ncurses/ncurses-base@6.1-1ubuntu1.18.04
  • Introduced through: concourse/concourse:6-ubuntu@* ncurses/ncurses-bin@6.1-1ubuntu1.18.04

NVD Description

Note: Versions mentioned in the description apply to the upstream ncurses package.

There is a heap-based buffer over-read in the fmt_entry function in tinfo/comp_hash.c in the terminfo library in ncurses before 6.1-20191012.

Remediation

There is no fixed version for Ubuntu:18.04 ncurses.

References

low severity

Out-of-bounds Read

  • Vulnerable module: ncurses/libncurses5
  • Introduced through: ncurses/libncurses5@6.1-1ubuntu1.18.04, ncurses/libncursesw5@6.1-1ubuntu1.18.04 and others

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* ncurses/libncurses5@6.1-1ubuntu1.18.04
  • Introduced through: concourse/concourse:6-ubuntu@* ncurses/libncursesw5@6.1-1ubuntu1.18.04
  • Introduced through: concourse/concourse:6-ubuntu@* ncurses/libtinfo5@6.1-1ubuntu1.18.04
  • Introduced through: concourse/concourse:6-ubuntu@* ncurses/ncurses-base@6.1-1ubuntu1.18.04
  • Introduced through: concourse/concourse:6-ubuntu@* ncurses/ncurses-bin@6.1-1ubuntu1.18.04

NVD Description

Note: Versions mentioned in the description apply to the upstream ncurses package.

There is a heap-based buffer over-read in the _nc_find_entry function in tinfo/comp_hash.c in the terminfo library in ncurses before 6.1-20191012.

Remediation

There is no fixed version for Ubuntu:18.04 ncurses.

References

low severity

Integer Overflow or Wraparound

  • Vulnerable module: pcre3/libpcre3
  • Introduced through: pcre3/libpcre3@2:8.39-9

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* pcre3/libpcre3@2:8.39-9

NVD Description

Note: Versions mentioned in the description apply to the upstream pcre3 package.

libpcre in PCRE before 8.44 allows an integer overflow via a large number after a (?C substring.

Remediation

There is no fixed version for Ubuntu:18.04 pcre3.

References

low severity

Out-of-bounds Read

  • Vulnerable module: pcre3/libpcre3
  • Introduced through: pcre3/libpcre3@2:8.39-9

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* pcre3/libpcre3@2:8.39-9

NVD Description

Note: Versions mentioned in the description apply to the upstream pcre3 package.

libpcre in PCRE before 8.43 allows a subject buffer over-read in JIT when UTF is disabled, and \X or \R has more than one fixed quantifier, a related issue to CVE-2019-20454.

Remediation

There is no fixed version for Ubuntu:18.04 pcre3.

References

low severity

Uncontrolled Recursion

  • Vulnerable module: pcre3/libpcre3
  • Introduced through: pcre3/libpcre3@2:8.39-9

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* pcre3/libpcre3@2:8.39-9

NVD Description

Note: Versions mentioned in the description apply to the upstream pcre3 package.

In PCRE 8.41, the OP_KETRMAX feature in the match function in pcre_exec.c allows stack exhaustion (uncontrolled recursion) when processing a crafted regular expression.

Remediation

There is no fixed version for Ubuntu:18.04 pcre3.

References

low severity

Incorrect Permission Assignment for Critical Resource

  • Vulnerable module: shadow/login
  • Introduced through: shadow/login@1:4.5-1ubuntu2 and shadow/passwd@1:4.5-1ubuntu2

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* shadow/login@1:4.5-1ubuntu2
  • Introduced through: concourse/concourse:6-ubuntu@* shadow/passwd@1:4.5-1ubuntu2

NVD Description

Note: Versions mentioned in the description apply to the upstream shadow package.

An issue was discovered in shadow 4.5. newgidmap (in shadow-utils) is setuid and allows an unprivileged user to be placed in a user namespace where setgroups(2) is permitted. This allows an attacker to remove themselves from a supplementary group, which may allow access to certain filesystem paths if the administrator has used "group blacklisting" (e.g., chmod g-rwx) to restrict access to paths. This flaw effectively reverts a security feature in the kernel (in particular, the /proc/self/setgroups knob) to prevent this sort of privilege escalation.

Remediation

There is no fixed version for Ubuntu:18.04 shadow.

References

low severity

Time-of-check Time-of-use (TOCTOU)

  • Vulnerable module: shadow/login
  • Introduced through: shadow/login@1:4.5-1ubuntu2 and shadow/passwd@1:4.5-1ubuntu2

Detailed paths

  • Introduced through: concourse/concourse:6-ubuntu@* shadow/login@1:4.5-1ubuntu2
  • Introduced through: concourse/concourse:6-ubuntu@* shadow/passwd@1:4.5-1ubuntu2

NVD Description

Note: Versions mentioned in the description apply to the upstream shadow package.

shadow: TOCTOU (time-of-check time-of-use) race condition when copying and removing directory trees

Remediation

There is no fixed version for Ubuntu:18.04 shadow.

References