Docker circleci/node:14.9.0-buster-browsers-legacy

Vulnerabilities

542 via 2194 paths

Dependencies

649

Source

Group 6 Copy Created with Sketch. Docker

Target OS

debian:10
Test your Docker Hub image against our market leading vulnerability database Sign up for free
Severity
  • 148
  • 105
  • 289
Status
  • 542
  • 0
  • 0
OS binaries
  • 530
  • 12

high severity

Link Following

  • Vulnerable module: avahi/libavahi-client3
  • Introduced through: avahi/libavahi-client3@0.7-4+b1, avahi/libavahi-common-data@0.7-4+b1 and others
  • Fixed in: 0.7-4+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* avahi/libavahi-client3@0.7-4+b1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* avahi/libavahi-common-data@0.7-4+b1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* avahi/libavahi-common3@0.7-4+b1

NVD Description

Note: Versions mentioned in the description apply to the upstream avahi package. See Remediation section below for Debian:10 relevant versions.

avahi-daemon-check-dns.sh in the Debian avahi package through 0.8-4 is executed as root via /etc/network/if-up.d/avahi-daemon, and allows a local attacker to cause a denial of service or create arbitrary empty files via a symlink attack on files under /run/avahi-daemon. NOTE: this only affects the packaging for Debian GNU/Linux (used indirectly by SUSE), not the upstream Avahi product.

Remediation

Upgrade Debian:10 avahi to version 0.7-4+deb10u1 or higher.

References

high severity

Stack-based Buffer Overflow

  • Vulnerable module: cairo/libcairo-gobject2
  • Introduced through: cairo/libcairo-gobject2@1.16.0-4, cairo/libcairo-script-interpreter2@1.16.0-4 and others
  • Fixed in: 1.16.0-4+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* cairo/libcairo-gobject2@1.16.0-4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* cairo/libcairo-script-interpreter2@1.16.0-4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* cairo/libcairo2@1.16.0-4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* cairo/libcairo2-dev@1.16.0-4

NVD Description

Note: Versions mentioned in the description apply to the upstream cairo package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in cairo's image-compositor.c in all versions prior to 1.17.4. This flaw allows an attacker who can provide a crafted input file to cairo's image-compositor (for example, by convincing a user to open a file in an application using cairo, or if an application uses cairo on untrusted input) to cause a stack buffer overflow -> out-of-bounds WRITE. The highest impact from this vulnerability is to confidentiality, integrity, as well as system availability.

Remediation

Upgrade Debian:10 cairo to version 1.16.0-4+deb10u1 or higher.

References

high severity

Arbitrary Code Injection

  • Vulnerable module: curl
  • Introduced through: curl@7.64.0-4+deb10u1, curl/libcurl3-gnutls@7.64.0-4+deb10u1 and others
  • Fixed in: 7.64.0-4+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl3-gnutls@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl4@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl4-openssl-dev@7.64.0-4+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Debian:10 relevant versions.

curl 7.20.0 through 7.70.0 is vulnerable to improper restriction of names for files and other resources that can lead too overwriting a local file when the -J flag is used.

Remediation

Upgrade Debian:10 curl to version 7.64.0-4+deb10u2 or higher.

References

high severity

Improper Certificate Validation

  • Vulnerable module: curl
  • Introduced through: curl@7.64.0-4+deb10u1, curl/libcurl3-gnutls@7.64.0-4+deb10u1 and others
  • Fixed in: 7.64.0-4+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl3-gnutls@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl4@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl4-openssl-dev@7.64.0-4+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Debian:10 relevant versions.

curl 7.41.0 through 7.73.0 is vulnerable to an improper check for certificate revocation due to insufficient verification of the OCSP response.

Remediation

Upgrade Debian:10 curl to version 7.64.0-4+deb10u2 or higher.

References

high severity

Information Exposure

  • Vulnerable module: curl
  • Introduced through: curl@7.64.0-4+deb10u1, curl/libcurl3-gnutls@7.64.0-4+deb10u1 and others
  • Fixed in: 7.64.0-4+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl3-gnutls@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl4@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl4-openssl-dev@7.64.0-4+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Debian:10 relevant versions.

curl 7.62.0 through 7.70.0 is vulnerable to an information disclosure vulnerability that can lead to a partial password being leaked over the network and to the DNS server(s).

Remediation

Upgrade Debian:10 curl to version 7.64.0-4+deb10u2 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: curl
  • Introduced through: curl@7.64.0-4+deb10u1, curl/libcurl3-gnutls@7.64.0-4+deb10u1 and others
  • Fixed in: 7.64.0-4+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl3-gnutls@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl4@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl4-openssl-dev@7.64.0-4+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Debian:10 relevant versions.

curl 7.21.0 to and including 7.73.0 is vulnerable to uncontrolled recursion due to a stack overflow issue in FTP wildcard match parsing.

Remediation

Upgrade Debian:10 curl to version 7.64.0-4+deb10u2 or higher.

References

high severity

Use After Free

  • Vulnerable module: curl
  • Introduced through: curl@7.64.0-4+deb10u1, curl/libcurl3-gnutls@7.64.0-4+deb10u1 and others
  • Fixed in: 7.64.0-4+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl3-gnutls@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl4@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl4-openssl-dev@7.64.0-4+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Debian:10 relevant versions.

Due to use of a dangling pointer, libcurl 7.29.0 through 7.71.1 can use the wrong connection when sending data.

Remediation

Upgrade Debian:10 curl to version 7.64.0-4+deb10u2 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

A flaw was found in djvulibre-3.5.28 and earlier. An integer overflow in function render() in tools/ddjvu via crafted djvu file may lead to application crash and other consequences.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

NULL Pointer Dereference

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

DjVuLibre 3.5.27 has a NULL pointer dereference in the function DJVU::filter_fv at IW44EncodeCodec.cpp.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

Out-of-bounds Read

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

A flaw was found in djvulibre-3.5.28 and earlier. An out of bounds read in function DJVU::DataPool::has_data() via crafted djvu file may lead to application crash and other consequences.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

Out-of-bounds Write

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

A flaw was found in djvulibre-3.5.28 and earlier. A Stack overflow in function DJVU::DjVuDocument::get_djvu_file() via crafted djvu file may lead to application crash and other consequences.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

Out-of-bounds Write

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

A flaw was found in djvulibre-3.5.28 and earlier. An out of bounds write in function DJVU::filter_bv() via crafted djvu file may lead to application crash and other consequences.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

Out-of-bounds Write

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

A flaw was found in djvulibre-3.5.28 and earlier. A heap buffer overflow in function DJVU::GBitmap::decode() via crafted djvu file may lead to application crash and other consequences.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

Arbitrary Argument Injection

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters, relevant in non-default configurations that enable Delivery Status Notification (DSN). Certain uses of ORCPT= can place a newline into a spool header file, and indirectly allow unauthenticated remote attackers to execute arbitrary commands as root.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

CVE-2020-28015

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters. Local users can alter the behavior of root processes because a recipient address can have a newline character.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

CVE-2020-28021

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters. An authenticated remote SMTP client can insert newline characters into a spool file (which indirectly leads to remote code execution as root) via AUTH= in a MAIL FROM command.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Exposure of Resource to Wrong Sphere

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Exposure of File Descriptor to Unintended Control Sphere because rda_interpret uses a privileged pipe that lacks a close-on-exec flag.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Improper Initialization

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 has Improper Initialization that can lead to recursion-based stack consumption or other consequences. This occurs because use of certain getc functions is mishandled when a client uses BDAT instead of DATA.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Improper Privilege Management

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. Because Exim operates as root in the spool directory (owned by a non-root user), an attacker can write to a /var/spool/exim4/input spool header file, in which a crafted recipient address can indirectly lead to command execution.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Integer Overflow to Buffer Overflow because get_stdinput allows unbounded reads that are accompanied by unbounded increases in a certain size variable. NOTE: exploitation may be impractical because of the execution time needed to overflow (multiple days).

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Integer Overflow to Buffer Overflow in receive_add_recipient via an e-mail message with fifty million recipients. NOTE: remote exploitation may be difficult because of resource consumption.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Link Following

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. Because Exim operates as root in the log directory (owned by a non-root user), a symlink or hard link attack allows overwriting critical root-owned files anywhere on the filesystem.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-Bounds

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 has Improper Restriction of Write Operations within the Bounds of a Memory Buffer. This occurs when processing name=value pairs within MAIL FROM and RCPT TO commands.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-Bounds

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Buffer Underwrite that may result in unauthenticated remote attackers executing arbitrary commands, because smtp_ungetc was only intended to push back characters, but can actually push back non-character error codes such as EOF.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Out-of-bounds Read. smtp_setup_msg may disclose sensitive information from process memory to an unauthenticated SMTP client.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Out-of-bounds Read because pdkim_finish_bodyhash does not validate the relationship between sig->bodyhash.len and b->bh.len; thus, a crafted DKIM-Signature header might lead to a leak of sensitive information from process memory.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Out-of-bounds Write because the main function, while setuid root, copies the current working directory pathname into a buffer that is too small (on some common platforms).

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Heap-based Buffer Overflow in queue_run via two sender options: -R and -S. This may cause privilege escalation from exim to root.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Heap-based Buffer Overflow because it mishandles "-F '.('" on the command line, and thus may allow privilege escalation from any user to root. This occurs because of the interpretation of negative sizes in strncpy.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Use After Free

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Use After Free in smtp_reset in certain situations that may be common for builds with OpenSSL.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Information Exposure

  • Vulnerable module: gcc-8
  • Introduced through: gcc-8@8.3.0-6, gcc-8/cpp-8@8.3.0-6 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/cpp-8@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/g++-8@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/gcc-8-base@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libasan5@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libatomic1@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libcc1-0@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libgcc-8-dev@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libgcc1@1:8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libgomp1@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libitm1@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/liblsan0@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libmpx2@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libquadmath0@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libstdc++-8-dev@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libstdc++6@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libtsan0@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libubsan1@8.3.0-6

NVD Description

Note: Versions mentioned in the description apply to the upstream gcc-8 package.

stack_protect_prologue in cfgexpand.c and stack_protect_epilogue in function.c in GNU Compiler Collection (GCC) 4.1 through 8 (under certain circumstances) generate instruction sequences when targeting ARM targets that spill the address of the stack protector guard, which allows an attacker to bypass the protection of -fstack-protector, -fstack-protector-all, -fstack-protector-strong, and -fstack-protector-explicit against stack overflow by controlling what the stack canary is compared against.

Remediation

There is no fixed version for Debian:10 gcc-8.

References

high severity

Insufficient Entropy

  • Vulnerable module: gcc-8
  • Introduced through: gcc-8@8.3.0-6, gcc-8/cpp-8@8.3.0-6 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/cpp-8@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/g++-8@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/gcc-8-base@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libasan5@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libatomic1@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libcc1-0@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libgcc-8-dev@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libgcc1@1:8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libgomp1@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libitm1@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/liblsan0@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libmpx2@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libquadmath0@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libstdc++-8-dev@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libstdc++6@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libtsan0@8.3.0-6
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gcc-8/libubsan1@8.3.0-6

NVD Description

Note: Versions mentioned in the description apply to the upstream gcc-8 package.

The POWER9 backend in GNU Compiler Collection (GCC) before version 10 could optimize multiple calls of the __builtin_darn intrinsic into a single call, thus reducing the entropy of the random number generator. This occurred because a volatile operation was not specified. For example, within a single execution of a program, the output of every __builtin_darn() call may be the same.

Remediation

There is no fixed version for Debian:10 gcc-8.

References

high severity

Out-of-bounds Read

  • Vulnerable module: giflib/libgif7
  • Introduced through: giflib/libgif7@5.1.4-3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* giflib/libgif7@5.1.4-3

NVD Description

Note: Versions mentioned in the description apply to the upstream giflib package.

An issue was discovered in giflib through 5.1.4. DumpScreen2RGB in gif2rgb.c has a heap-based buffer over-read.

Remediation

There is no fixed version for Debian:10 giflib.

References

high severity

Out-of-bounds Write

  • Vulnerable module: giflib/libgif7
  • Introduced through: giflib/libgif7@5.1.4-3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* giflib/libgif7@5.1.4-3

NVD Description

Note: Versions mentioned in the description apply to the upstream giflib package.

The DGifDecompressLine function in dgif_lib.c in GIFLIB (possibly version 3.0.x), as later shipped in cgif.c in sam2p 0.49.4, has a heap-based buffer overflow because a certain "Private->RunningCode - 2" array index is not checked. This will lead to a denial of service or possibly unspecified other impact.

Remediation

There is no fixed version for Debian:10 giflib.

References

high severity

Out-of-bounds Write

  • Vulnerable module: giflib/libgif7
  • Introduced through: giflib/libgif7@5.1.4-3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* giflib/libgif7@5.1.4-3

NVD Description

Note: Versions mentioned in the description apply to the upstream giflib package.

The DGifDecompressLine function in dgif_lib.c in GIFLIB (possibly version 3.0.x), as later shipped in cgif.c in sam2p 0.49.4, has a heap-based buffer overflow because a certain CrntCode array index is not checked. This will lead to a denial of service or possibly unspecified other impact.

Remediation

There is no fixed version for Debian:10 giflib.

References

high severity

Link Following

  • Vulnerable module: git
  • Introduced through: git@1:2.20.1-2+deb10u3 and git/git-man@1:2.20.1-2+deb10u3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* git@1:2.20.1-2+deb10u3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* git/git-man@1:2.20.1-2+deb10u3

NVD Description

Note: Versions mentioned in the description apply to the upstream git package.

Git is an open-source distributed revision control system. In affected versions of Git a specially crafted repository that contains symbolic links as well as files using a clean/smudge filter such as Git LFS, may cause just-checked out script to be executed while cloning onto a case-insensitive file system such as NTFS, HFS+ or APFS (i.e. the default file systems on Windows and macOS). Note that clean/smudge filters have to be configured for that. Git for Windows configures Git LFS by default, and is therefore vulnerable. The problem has been patched in the versions published on Tuesday, March 9th, 2021. As a workaound, if symbolic link support is disabled in Git (e.g. via git config --global core.symlinks false), the described attack won't work. Likewise, if no clean/smudge filters such as Git LFS are configured globally (i.e. before cloning), the attack is foiled. As always, it is best to avoid cloning repositories from untrusted sources. The earliest impacted version is 2.14.2. The fix versions are: 2.30.1, 2.29.3, 2.28.1, 2.27.1, 2.26.3, 2.25.5, 2.24.4, 2.23.4, 2.22.5, 2.21.4, 2.20.5, 2.19.6, 2.18.5, 2.17.62.17.6.

Remediation

There is no fixed version for Debian:10 git.

References

high severity

Incorrect Conversion between Numeric Types

  • Vulnerable module: glib2.0/libglib2.0-0
  • Introduced through: glib2.0/libglib2.0-0@2.58.3-2+deb10u2, glib2.0/libglib2.0-bin@2.58.3-2+deb10u2 and others
  • Fixed in: 2.58.3-2+deb10u3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glib2.0/libglib2.0-0@2.58.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glib2.0/libglib2.0-bin@2.58.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glib2.0/libglib2.0-data@2.58.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glib2.0/libglib2.0-dev@2.58.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glib2.0/libglib2.0-dev-bin@2.58.3-2+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream glib2.0 package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in GNOME GLib before 2.66.7 and 2.67.x before 2.67.4. If g_byte_array_new_take() was called with a buffer of 4GB or more on a 64-bit platform, the length would be truncated modulo 2**32, causing unintended length truncation.

Remediation

Upgrade Debian:10 glib2.0 to version 2.58.3-2+deb10u3 or higher.

References

high severity

Incorrect Conversion between Numeric Types

  • Vulnerable module: glib2.0/libglib2.0-0
  • Introduced through: glib2.0/libglib2.0-0@2.58.3-2+deb10u2, glib2.0/libglib2.0-bin@2.58.3-2+deb10u2 and others
  • Fixed in: 2.58.3-2+deb10u3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glib2.0/libglib2.0-0@2.58.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glib2.0/libglib2.0-bin@2.58.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glib2.0/libglib2.0-data@2.58.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glib2.0/libglib2.0-dev@2.58.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glib2.0/libglib2.0-dev-bin@2.58.3-2+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream glib2.0 package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in GNOME GLib before 2.66.6 and 2.67.x before 2.67.3. The function g_bytes_new has an integer overflow on 64-bit platforms due to an implicit cast from 64 bits to 32 bits. The overflow could potentially lead to memory corruption.

Remediation

Upgrade Debian:10 glib2.0 to version 2.58.3-2+deb10u3 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The wordexp function in the GNU C Library (aka glibc) through 2.33 may crash or read arbitrary memory in parse_param (in posix/wordexp.c) when called with an untrusted, crafted pattern, potentially resulting in a denial of service or disclosure of information. This occurs because atoi was used but strtoul should have been used to ensure correct calculations.

Remediation

There is no fixed version for Debian:10 glibc.

References

high severity

Out-of-bounds Write

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

An out-of-bounds write vulnerability was found in glibc before 2.31 when handling signal trampolines on PowerPC. Specifically, the backtrace function did not properly check the array bounds when storing the frame address, resulting in a denial of service or potential code execution. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 glibc.

References

high severity

Reachable Assertion

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The iconv function in the GNU C Library (aka glibc or libc6) 2.32 and earlier, when processing invalid input sequences in the ISO-2022-JP-3 encoding, fails an assertion in the code path and aborts the program, potentially resulting in a denial of service.

Remediation

There is no fixed version for Debian:10 glibc.

References

high severity

Use After Free

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The mq_notify function in the GNU C Library (aka glibc) versions 2.32 and 2.33 has a use-after-free. It may use the notification thread attributes object (passed through its struct sigevent parameter) after it has been freed by the caller, leading to a denial of service (application crash) or possibly unspecified other impact.

Remediation

There is no fixed version for Debian:10 glibc.

References

high severity

Use After Free

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

A use-after-free vulnerability introduced in glibc upstream version 2.14 was found in the way the tilde expansion was carried out. Directory paths containing an initial tilde followed by a valid username were affected by this issue. A local attacker could exploit this flaw by creating a specially crafted path that, when processed by the glob function, would potentially lead to arbitrary code execution. This was fixed in version 2.32.

Remediation

There is no fixed version for Debian:10 glibc.

References

high severity

Out-of-bounds Write

  • Vulnerable module: gnutls28/libgnutls-dane0
  • Introduced through: gnutls28/libgnutls-dane0@3.6.7-4+deb10u5, gnutls28/libgnutls-openssl27@3.6.7-4+deb10u5 and others
  • Fixed in: 3.6.7-4+deb10u7

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gnutls28/libgnutls-dane0@3.6.7-4+deb10u5
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gnutls28/libgnutls-openssl27@3.6.7-4+deb10u5
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gnutls28/libgnutls28-dev@3.6.7-4+deb10u5
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gnutls28/libgnutls30@3.6.7-4+deb10u5
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gnutls28/libgnutlsxx28@3.6.7-4+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream gnutls28 package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in GnuTLS before 3.6.15. A server can trigger a NULL pointer dereference in a TLS 1.3 client if a no_renegotiation alert is sent with unexpected timing, and then an invalid second handshake occurs. The crash happens in the application's error handling path, where the gnutls_deinit function is called after detecting a handshake failure.

Remediation

Upgrade Debian:10 gnutls28 to version 3.6.7-4+deb10u7 or higher.

References

high severity

Use After Free

  • Vulnerable module: gnutls28/libgnutls-dane0
  • Introduced through: gnutls28/libgnutls-dane0@3.6.7-4+deb10u5, gnutls28/libgnutls-openssl27@3.6.7-4+deb10u5 and others
  • Fixed in: 3.6.7-4+deb10u7

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gnutls28/libgnutls-dane0@3.6.7-4+deb10u5
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gnutls28/libgnutls-openssl27@3.6.7-4+deb10u5
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gnutls28/libgnutls28-dev@3.6.7-4+deb10u5
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gnutls28/libgnutls30@3.6.7-4+deb10u5
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gnutls28/libgnutlsxx28@3.6.7-4+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream gnutls28 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in gnutls. A use after free issue in client sending key_share extension may lead to memory corruption and other consequences.

Remediation

Upgrade Debian:10 gnutls28 to version 3.6.7-4+deb10u7 or higher.

References

high severity

Use After Free

  • Vulnerable module: gnutls28/libgnutls-dane0
  • Introduced through: gnutls28/libgnutls-dane0@3.6.7-4+deb10u5, gnutls28/libgnutls-openssl27@3.6.7-4+deb10u5 and others
  • Fixed in: 3.6.7-4+deb10u7

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gnutls28/libgnutls-dane0@3.6.7-4+deb10u5
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gnutls28/libgnutls-openssl27@3.6.7-4+deb10u5
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gnutls28/libgnutls28-dev@3.6.7-4+deb10u5
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gnutls28/libgnutls30@3.6.7-4+deb10u5
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* gnutls28/libgnutlsxx28@3.6.7-4+deb10u5

NVD Description

Note: Versions mentioned in the description apply to the upstream gnutls28 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in gnutls. A use after free issue in client_send_params in lib/ext/pre_shared_key.c may lead to memory corruption and other potential consequences.

Remediation

Upgrade Debian:10 gnutls28 to version 3.6.7-4+deb10u7 or higher.

References

high severity

Double Free

  • Vulnerable module: icu/icu-devtools
  • Introduced through: icu/icu-devtools@63.1-6+deb10u1, icu/libicu-dev@63.1-6+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* icu/icu-devtools@63.1-6+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* icu/libicu-dev@63.1-6+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* icu/libicu63@63.1-6+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream icu package.

Double free in ICU in Google Chrome prior to 91.0.4472.77 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

Remediation

There is no fixed version for Debian:10 icu.

References

high severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in versions before 7.0.11 and before 6.9.12, where a division by zero in WaveImage() of MagickCore/visual-effects.c may trigger undefined behavior via a crafted image file submitted to an application using ImageMagick. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Information Exposure

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in versions before 7.0.11. A potential cipher leak when the calculate signatures in TransformSignature is possible. The highest threat from this vulnerability is to data confidentiality.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in MagickCore/statistic.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of values outside the range of type unsigned long. This would most likely lead to an impact to application availability, but could potentially cause other problems related to undefined behavior. This flaw affects ImageMagick versions prior to 7.0.8-69.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in versions 7.0.11, where an integer overflow in WriteTHUMBNAILImage of coders/thumbnail.c may trigger undefined behavior via a crafted image file that is submitted by an attacker and processed by an application using ImageMagick. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Out-of-bounds Write

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

Stack-based buffer overflow and unconditional jump in ReadXPMImage in coders/xpm.c in ImageMagick 7.0.10-7.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Out-of-bounds Write

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in MagickCore/quantum-private.h. An attacker who submits a crafted file that is processed by ImageMagick could trigger a heap buffer overflow. This would most likely lead to an impact to application availability, but could potentially lead to an impact to data integrity as well. This flaw affects ImageMagick versions prior to 7.0.9-0.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

XML Injection

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

ImageMagick before 6.9.11-40 and 7.x before 7.0.10-40 mishandles the -authenticate option, which allows setting a password for password-protected PDF files. The user-controlled password was not properly escaped/sanitized and it was therefore possible to inject additional shell commands via coders/pdf.c.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity
new

NULL Pointer Dereference

  • Vulnerable module: krb5/krb5-multidev
  • Introduced through: krb5/krb5-multidev@1.17-3, krb5/libgssapi-krb5-2@1.17-3 and others
  • Fixed in: 1.17-3+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/krb5-multidev@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libgssapi-krb5-2@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libgssrpc4@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libk5crypto3@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libkadm5clnt-mit11@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libkadm5srv-mit11@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libkdb5-9@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libkrb5-3@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libkrb5-dev@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libkrb5support0@1.17-3

NVD Description

Note: Versions mentioned in the description apply to the upstream krb5 package. See Remediation section below for Debian:10 relevant versions.

ec_verify in kdc/kdc_preauth_ec.c in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) before 1.18.4 and 1.19.x before 1.19.2 allows remote attackers to cause a NULL pointer dereference and daemon crash. This occurs because a return value is not properly managed in a certain situation.

Remediation

Upgrade Debian:10 krb5 to version 1.17-3+deb10u2 or higher.

References

high severity

Uncontrolled Recursion

  • Vulnerable module: krb5/krb5-multidev
  • Introduced through: krb5/krb5-multidev@1.17-3, krb5/libgssapi-krb5-2@1.17-3 and others
  • Fixed in: 1.17-3+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/krb5-multidev@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libgssapi-krb5-2@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libgssrpc4@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libk5crypto3@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libkadm5clnt-mit11@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libkadm5srv-mit11@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libkdb5-9@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libkrb5-3@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libkrb5-dev@1.17-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* krb5/libkrb5support0@1.17-3

NVD Description

Note: Versions mentioned in the description apply to the upstream krb5 package. See Remediation section below for Debian:10 relevant versions.

MIT Kerberos 5 (aka krb5) before 1.17.2 and 1.18.x before 1.18.3 allows unbounded recursion via an ASN.1-encoded Kerberos message because the lib/krb5/asn.1/asn1_encode.c support for BER indefinite lengths lacks a recursion limit.

Remediation

Upgrade Debian:10 krb5 to version 1.17-3+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libbsd/libbsd0
  • Introduced through: libbsd/libbsd0@0.9.1-2
  • Fixed in: 0.9.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libbsd/libbsd0@0.9.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libbsd package. See Remediation section below for Debian:10 relevant versions.

nlist.c in libbsd before 0.10.0 has an out-of-bounds read during a comparison for a symbol name from the string table (strtab).

Remediation

Upgrade Debian:10 libbsd to version 0.9.1-2+deb10u1 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: libexif/libexif-dev
  • Introduced through: libexif/libexif-dev@0.6.21-5.1+deb10u4 and libexif/libexif12@0.6.21-5.1+deb10u4
  • Fixed in: 0.6.21-5.1+deb10u5

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libexif/libexif-dev@0.6.21-5.1+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libexif/libexif12@0.6.21-5.1+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream libexif package. See Remediation section below for Debian:10 relevant versions.

In exif_entry_get_value of exif-entry.c, there is a possible out of bounds write due to an integer overflow. This could lead to remote code execution if a third party app used this library to process remote image data with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-8.1 Android-9 Android-10 Android-11 Android-8.0Android ID: A-159625731

Remediation

Upgrade Debian:10 libexif to version 0.6.21-5.1+deb10u5 or higher.

References

high severity

Information Exposure

  • Vulnerable module: libgcrypt20
  • Introduced through: libgcrypt20@1.8.4-5
  • Fixed in: 1.8.4-5+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libgcrypt20@1.8.4-5

NVD Description

Note: Versions mentioned in the description apply to the upstream libgcrypt20 package. See Remediation section below for Debian:10 relevant versions.

Libgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption because it lacks exponent blinding to address a side-channel attack against mpi_powm, and the window size is not chosen appropriately. (There is also an interoperability problem because the selection of the k integer value does not properly consider the differences between basic ElGamal encryption and generalized ElGamal encryption.) This, for example, affects use of ElGamal in OpenPGP.

Remediation

Upgrade Debian:10 libgcrypt20 to version 1.8.4-5+deb10u1 or higher.

References

high severity
new

CVE-2020-19498

  • Vulnerable module: libheif/libheif1
  • Introduced through: libheif/libheif1@1.3.2-2~deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libheif/libheif1@1.3.2-2~deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream libheif package.

Floating point exception in function Fraction in libheif 1.4.0, allows attackers to cause a Denial of Service or possibly other unspecified impacts.

Remediation

There is no fixed version for Debian:10 libheif.

References

high severity
new

Out-of-bounds Read

  • Vulnerable module: libheif/libheif1
  • Introduced through: libheif/libheif1@1.3.2-2~deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libheif/libheif1@1.3.2-2~deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream libheif package.

An issue was discovered in heif::Box_iref::get_references in libheif 1.4.0, allows attackers to cause a Denial of Service or possibly other unspecified impact due to an invalid memory read.

Remediation

There is no fixed version for Debian:10 libheif.

References

high severity

Improper Input Validation

  • Vulnerable module: libidn2/libidn2-0
  • Introduced through: libidn2/libidn2-0@2.0.5-1+deb10u1 and libidn2/libidn2-dev@2.0.5-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libidn2/libidn2-0@2.0.5-1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libidn2/libidn2-dev@2.0.5-1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream libidn2 package.

GNU libidn2 before 2.2.0 fails to perform the roundtrip checks specified in RFC3490 Section 4.2 when converting A-labels to U-labels. This makes it possible in some circumstances for one domain to impersonate another. By creating a malicious domain that matches a target domain except for the inclusion of certain punycoded Unicode characters (that would be discarded when converted first to a Unicode label and then back to an ASCII label), arbitrary domains can be impersonated.

Remediation

There is no fixed version for Debian:10 libidn2.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libjpeg-turbo/libjpeg-dev
  • Introduced through: libjpeg-turbo/libjpeg-dev@1:1.5.2-2, libjpeg-turbo/libjpeg62-turbo@1:1.5.2-2+b1 and others
  • Fixed in: 1:1.5.2-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libjpeg-turbo/libjpeg-dev@1:1.5.2-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libjpeg-turbo/libjpeg62-turbo@1:1.5.2-2+b1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libjpeg-turbo/libjpeg62-turbo-dev@1:1.5.2-2+b1

NVD Description

Note: Versions mentioned in the description apply to the upstream libjpeg-turbo package. See Remediation section below for Debian:10 relevant versions.

libjpeg-turbo 2.0.4, and mozjpeg 4.0.0, has a heap-based buffer over-read in get_rgb_row() in rdppm.c via a malformed PPM input file.

Remediation

Upgrade Debian:10 libjpeg-turbo to version 1:1.5.2-2+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: libjpeg-turbo/libjpeg-dev
  • Introduced through: libjpeg-turbo/libjpeg-dev@1:1.5.2-2, libjpeg-turbo/libjpeg62-turbo@1:1.5.2-2+b1 and others
  • Fixed in: 1:1.5.2-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libjpeg-turbo/libjpeg-dev@1:1.5.2-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libjpeg-turbo/libjpeg62-turbo@1:1.5.2-2+b1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libjpeg-turbo/libjpeg62-turbo-dev@1:1.5.2-2+b1

NVD Description

Note: Versions mentioned in the description apply to the upstream libjpeg-turbo package. See Remediation section below for Debian:10 relevant versions.

In generate_jsimd_ycc_rgb_convert_neon of jsimd_arm64_neon.S, there is a possible out of bounds write due to a missing bounds check. This could lead to remote code execution in an unprivileged process with no additional execution privileges needed. User interaction is needed for exploitation.Product: AndroidVersions: Android-8.0 Android-8.1 Android-9 Android-10Android ID: A-120551338

Remediation

Upgrade Debian:10 libjpeg-turbo to version 1:1.5.2-2+deb10u1 or higher.

References

high severity

Buffer Overflow

  • Vulnerable module: libproxy/libproxy1v5
  • Introduced through: libproxy/libproxy1v5@0.4.15-5
  • Fixed in: 0.4.15-5+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libproxy/libproxy1v5@0.4.15-5

NVD Description

Note: Versions mentioned in the description apply to the upstream libproxy package. See Remediation section below for Debian:10 relevant versions.

url.cpp in libproxy through 0.4.15 is prone to a buffer overflow when PAC is enabled, as demonstrated by a large PAC file that is delivered without a Content-length header.

Remediation

Upgrade Debian:10 libproxy to version 0.4.15-5+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: libproxy/libproxy1v5
  • Introduced through: libproxy/libproxy1v5@0.4.15-5
  • Fixed in: 0.4.15-5+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libproxy/libproxy1v5@0.4.15-5

NVD Description

Note: Versions mentioned in the description apply to the upstream libproxy package. See Remediation section below for Debian:10 relevant versions.

url::recvline in url.cpp in libproxy 0.4.x through 0.4.15 allows a remote HTTP server to trigger uncontrolled recursion via a response composed of an infinite stream that lacks a newline character. This leads to stack exhaustion.

Remediation

Upgrade Debian:10 libproxy to version 0.4.15-5+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libssh2/libssh2-1
  • Introduced through: libssh2/libssh2-1@1.8.0-2.1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libssh2/libssh2-1@1.8.0-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream libssh2 package.

In libssh2 before 1.9.0, kex_method_diffie_hellman_group_exchange_sha256_key_exchange in kex.c has an integer overflow that could lead to an out-of-bounds read in the way packets are read from the server. A remote attacker who compromises a SSH server may be able to disclose sensitive information or cause a denial of service condition on the client system when a user connects to the server. This is related to an _libssh2_check_length mistake, and is different from the various issues fixed in 1.8.1, such as CVE-2019-3855.

Remediation

There is no fixed version for Debian:10 libssh2.

References

high severity

Improper Input Validation

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. When reading a file libwebp allocates an excessive amount of memory. The highest threat from this vulnerability is to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function ApplyFilter. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function ShiftBytes. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function ChunkVerifyAndAssign. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function WebPMuxCreateInternal. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function WebPMuxCreateInternal. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function ChunkAssignData. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. A heap-based buffer overflow in function WebPDecodeRGBInto is possible due to an invalid check for buffer size. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. A heap-based buffer overflow was found in PutLE16(). The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Use After Free

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. A use-after-free was found due to a thread being killed too early. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Use of Uninitialized Resource

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An unitialized variable is used in function ReadSymbol. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Buffer Overflow

  • Vulnerable module: libx11/libx11-6
  • Introduced through: libx11/libx11-6@2:1.6.7-1, libx11/libx11-data@2:1.6.7-1 and others
  • Fixed in: 2:1.6.7-1+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libx11/libx11-6@2:1.6.7-1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libx11/libx11-data@2:1.6.7-1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libx11/libx11-dev@2:1.6.7-1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libx11/libx11-xcb1@2:1.6.7-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libx11 package. See Remediation section below for Debian:10 relevant versions.

LookupCol.c in X.Org X through X11R7.7 and libX11 before 1.7.1 might allow remote attackers to execute arbitrary code. The libX11 XLookupColor request (intended for server-side color lookup) contains a flaw allowing a client to send color-name requests with a name longer than the maximum size allowed by the protocol (and also longer than the maximum packet size for normal-sized packets). The user-controlled data exceeding the maximum size is then interpreted by the server as additional X protocol requests and executed, e.g., to disable X server authorization completely. For example, if the victim encounters malicious terminal control sequences for color codes, then the attacker may be able to take full control of the running graphical session.

Remediation

Upgrade Debian:10 libx11 to version 2:1.6.7-1+deb10u2 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: libx11/libx11-6
  • Introduced through: libx11/libx11-6@2:1.6.7-1, libx11/libx11-data@2:1.6.7-1 and others
  • Fixed in: 2:1.6.7-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libx11/libx11-6@2:1.6.7-1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libx11/libx11-data@2:1.6.7-1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libx11/libx11-dev@2:1.6.7-1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libx11/libx11-xcb1@2:1.6.7-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libx11 package. See Remediation section below for Debian:10 relevant versions.

An integer overflow vulnerability leading to a double-free was found in libX11. This flaw allows a local privileged attacker to cause an application compiled with libX11 to crash, or in some cases, result in arbitrary code execution. The highest threat from this flaw is to confidentiality, integrity as well as system availability.

Remediation

Upgrade Debian:10 libx11 to version 2:1.6.7-1+deb10u1 or higher.

References

high severity

Improper Resource Shutdown or Release

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

xmlSchemaPreRun in xmlschemas.c in libxml2 2.9.10 allows an xmlSchemaValidateStream memory leak.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u1 or higher.

References

high severity

Loop with Unreachable Exit Condition ('Infinite Loop')

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package.

parser.c in libxml2 before 2.9.5 does not prevent infinite recursion in parameter entities.

Remediation

There is no fixed version for Debian:10 libxml2.

References

high severity

Loop with Unreachable Exit Condition ('Infinite Loop')

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

xmlStringLenDecodeEntities in parser.c in libxml2 2.9.10 has an infinite loop in a certain end-of-file situation.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u1 or higher.

References

high severity

Missing Release of Resource after Effective Lifetime

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

xmlParseBalancedChunkMemoryRecover in parser.c in libxml2 before 2.9.10 has a memory leak related to newDoc->oldNs.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u1 or higher.

References

high severity

NULL Pointer Dereference

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

A NULL pointer dereference vulnerability exists in the xpath.c:xmlXPathCompOpEval() function of libxml2 through 2.9.8 when parsing an invalid XPath expression in the XPATH_OP_AND or XPATH_OP_OR case. Applications processing untrusted XSL format inputs with the use of the libxml2 library may be vulnerable to a denial of service attack due to a crash of the application.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u1 or higher.

References

high severity

Out-of-Bounds

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

There is a flaw in the xml entity encoding functionality of libxml2 in versions before 2.9.11. An attacker who is able to supply a crafted file to be processed by an application linked with the affected functionality of libxml2 could trigger an out-of-bounds read. The most likely impact of this flaw is to application availability, with some potential impact to confidentiality and integrity if an attacker is able to use memory information to further exploit the application.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u2 or higher.

References

high severity

Use After Free

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

There's a flaw in libxml2's xmllint in versions before 2.9.11. An attacker who is able to submit a crafted file to be processed by xmllint could trigger a use-after-free. The greatest impact of this flaw is to confidentiality, integrity, and availability.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u2 or higher.

References

high severity

Use After Free

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

There's a flaw in libxml2 in versions before 2.9.11. An attacker who is able to submit a crafted file to be processed by an application linked with libxml2 could trigger a use-after-free. The greatest impact from this flaw is to confidentiality, integrity, and availability.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u2 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: lz4/liblz4-1
  • Introduced through: lz4/liblz4-1@1.8.3-1
  • Fixed in: 1.8.3-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* lz4/liblz4-1@1.8.3-1

NVD Description

Note: Versions mentioned in the description apply to the upstream lz4 package. See Remediation section below for Debian:10 relevant versions.

There's a flaw in lz4. An attacker who submits a crafted file to an application linked with lz4 may be able to trigger an integer overflow, leading to calling of memmove() on a negative size argument, causing an out-of-bounds write and/or a crash. The greatest impact of this flaw is to availability, with some potential impact to confidentiality and integrity as well.

Remediation

Upgrade Debian:10 lz4 to version 1.8.3-1+deb10u1 or higher.

References

high severity

Improper Input Validation

  • Vulnerable module: mariadb-10.3/libmariadb-dev
  • Introduced through: mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1, mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1 and others
  • Fixed in: 1:10.3.25-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb3@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/mariadb-common@1:10.3.23-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.3 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in the mysql-wsrep component of mariadb. Lack of input sanitization in wsrep_sst_method allows for command injection that can be exploited by a remote attacker to execute arbitrary commands on galera cluster nodes. This threatens the system's confidentiality, integrity, and availability. This flaw affects mariadb versions before 10.1.47, before 10.2.34, before 10.3.25, before 10.4.15 and before 10.5.6.

Remediation

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.25-0+deb10u1 or higher.

References

high severity

OS Command Injection

  • Vulnerable module: mariadb-10.3/libmariadb-dev
  • Introduced through: mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1, mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1 and others
  • Fixed in: 1:10.3.29-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb3@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/mariadb-common@1:10.3.23-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.3 package. See Remediation section below for Debian:10 relevant versions.

A remote code execution issue was discovered in MariaDB 10.2 before 10.2.37, 10.3 before 10.3.28, 10.4 before 10.4.18, and 10.5 before 10.5.9; Percona Server through 2021-03-03; and the wsrep patch through 2021-03-03 for MySQL. An untrusted search path leads to eval injection, in which a database SUPER user can execute OS commands after modifying wsrep_provider and wsrep_notify_cmd. NOTE: this does not affect an Oracle product.

Remediation

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.29-0+deb10u1 or higher.

References

high severity

Use of a Broken or Risky Cryptographic Algorithm

  • Vulnerable module: nettle/libhogweed4
  • Introduced through: nettle/libhogweed4@3.4.1-1, nettle/libnettle6@3.4.1-1 and others
  • Fixed in: 3.4.1-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* nettle/libhogweed4@3.4.1-1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* nettle/libnettle6@3.4.1-1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* nettle/nettle-dev@3.4.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream nettle package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in Nettle in versions before 3.7.2, where several Nettle signature verification functions (GOST DSA, EDDSA & ECDSA) result in the Elliptic Curve Cryptography point (ECC) multiply function being called with out-of-range scalers, possibly resulting in incorrect results. This flaw allows an attacker to force an invalid signature, causing an assertion failure or possible validation. The highest threat to this vulnerability is to confidentiality, integrity, as well as system availability.

Remediation

Upgrade Debian:10 nettle to version 3.4.1-1+deb10u1 or higher.

References

high severity

Denial of Service (DoS)

  • Vulnerable module: node
  • Introduced through: node@14.9.0
  • Fixed in: 14.16.0

Detailed paths

  • Introduced through: docker-image|circleci/node@14.9.0-buster-browsers-legacy node@14.9.0

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Denial of Service (DoS). When too many connection attempts with an HTTP2 unknownProtocol are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening. If no file descriptor limit is configured, then this leads to an excessive memory usage and causes the system to run out of memory.

Details

Denial of Service (DoS) describes a family of attacks, all aimed at making a system inaccessible to its intended and legitimate users.

Unlike other vulnerabilities, DoS attacks usually do not aim at breaching security. Rather, they are focused on making websites and services unavailable to genuine users resulting in downtime.

One popular Denial of Service vulnerability is DDoS (a Distributed Denial of Service), an attack that attempts to clog network pipes to the system by generating a large volume of traffic from many machines.

When it comes to open source libraries, DoS vulnerabilities allow attackers to trigger such a crash or crippling of the service by using a flaw either in the application code or from the use of open source libraries.

Two common types of DoS vulnerabilities:

  • High CPU/Memory Consumption- An attacker sending crafted requests that could cause the system to take a disproportionate amount of time to process. For example, commons-fileupload:commons-fileupload.

  • Crash - An attacker sending crafted requests that could cause the system to crash. For Example, npm ws package

Remediation

Upgrade node to version 15.10.0, 14.16.0, 12.21.0, 10.24.0 or higher.

References

high severity

Denial of Service (DoS)

  • Vulnerable module: node
  • Introduced through: node@14.9.0
  • Fixed in: 14.11.0

Detailed paths

  • Introduced through: docker-image|circleci/node@14.9.0-buster-browsers-legacy node@14.9.0

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Denial of Service (DoS). Node.js 14.x versions prior to 14.11 are vulnerable to a denial of service condition based on delayed requests. When used as an edge server, an attacker can initiate but not complete a large number of HTTP requests causing resource exhaustion and rendering the server unable to accept new connections.

Details

Denial of Service (DoS) describes a family of attacks, all aimed at making a system inaccessible to its intended and legitimate users.

Unlike other vulnerabilities, DoS attacks usually do not aim at breaching security. Rather, they are focused on making websites and services unavailable to genuine users resulting in downtime.

One popular Denial of Service vulnerability is DDoS (a Distributed Denial of Service), an attack that attempts to clog network pipes to the system by generating a large volume of traffic from many machines.

When it comes to open source libraries, DoS vulnerabilities allow attackers to trigger such a crash or crippling of the service by using a flaw either in the application code or from the use of open source libraries.

Two common types of DoS vulnerabilities:

  • High CPU/Memory Consumption- An attacker sending crafted requests that could cause the system to take a disproportionate amount of time to process. For example, commons-fileupload:commons-fileupload.

  • Crash - An attacker sending crafted requests that could cause the system to crash. For Example, npm ws package

Remediation

Upgrade node to version 14.11.0 or higher.

References

high severity

HTTP Request Smuggling

  • Vulnerable module: node
  • Introduced through: node@14.9.0
  • Fixed in: 14.15.4

Detailed paths

  • Introduced through: docker-image|circleci/node@14.9.0-buster-browsers-legacy node@14.9.0

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to HTTP Request Smuggling. Two copies of a header field are allowed in a HTTP request, which causes Node.js to identifiy the first header and ignore the second.

Remediation

Upgrade node to version 10.23.1, 12.20.1, 14.15.4, 15.5.1 or higher.

References

high severity

Improper Certificate Validation

  • Vulnerable module: node
  • Introduced through: node@14.9.0
  • Fixed in: 14.16.1

Detailed paths

  • Introduced through: docker-image|circleci/node@14.9.0-buster-browsers-legacy node@14.9.0

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Improper Certificate Validation. There is insufficient verification of a certificate chain when using the X509_V_FLAG_X509_STRICT flag.

Remediation

Upgrade node to version 15.14.0, 14.16.1, 12.22.1, 10.24.1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: node
  • Introduced through: node@14.9.0
  • Fixed in: 14.17.2

Detailed paths

  • Introduced through: docker-image|circleci/node@14.9.0-buster-browsers-legacy node@14.9.0

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Out-of-bounds Read in libuv's uv__idna_toascii() function which is used to convert strings to ASCII. This is called by Node's dns module's lookup() function and can lead to information disclosures or crashes.

Remediation

Upgrade node to version 16.4.1, 14.17.2, 12.22.2 or higher.

References

high severity

Privilege Escalation

  • Vulnerable module: node
  • Introduced through: node@14.9.0
  • Fixed in: 14.17.2

Detailed paths

  • Introduced through: docker-image|circleci/node@14.9.0-buster-browsers-legacy node@14.9.0

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Privilege Escalation under certain conditions on Windows platforms. More specifically, improper configuration of permissions in the installation directory allows an attacker to perform two different escalation attacks: PATH variable hijacking and DLL hijacking.

Remediation

Upgrade node to version 16.4.1, 14.17.2, 12.22.2 or higher.

References

high severity
new

Use After Free

  • Vulnerable module: node
  • Introduced through: node@14.9.0
  • Fixed in: 14.17.4

Detailed paths

  • Introduced through: docker-image|circleci/node@14.9.0-buster-browsers-legacy node@14.9.0

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Use After Free on close http2 on stream canceling. An attacker might be able to exploit the memory corruption to change process behaviour.

Remediation

Upgrade node to version 16.6.0, 14.17.4, 12.22.4 or higher.

References

high severity

Allocation of Resources Without Limits or Throttling

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1+deb10u3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* nss/libnss3@2:3.42.1-1+deb10u3

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package.

A flaw was found in the way NSS handled CCS (ChangeCipherSpec) messages in TLS 1.3. This flaw allows a remote attacker to send multiple CCS messages, causing a denial of service for servers compiled with the NSS library. The highest threat from this vulnerability is to system availability. This flaw affects NSS versions before 3.58.

Remediation

There is no fixed version for Debian:10 nss.

References

high severity

Out-of-bounds Read

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1+deb10u3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* nss/libnss3@2:3.42.1-1+deb10u3

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package.

A flaw was found in the way CHACHA20-POLY1305 was implemented in NSS in versions before 3.55. When using multi-part Chacha20, it could cause out-of-bounds reads. This issue was fixed by explicitly disabling multi-part ChaCha20 (which was not functioning correctly) and strictly enforcing tag length. The highest threat from this vulnerability is to confidentiality and system availability.

Remediation

There is no fixed version for Debian:10 nss.

References

high severity
new

CVE-2021-2388

  • Vulnerable module: openjdk-11/openjdk-11-jdk
  • Introduced through: openjdk-11/openjdk-11-jdk@11.0.8+10-1~deb10u1, openjdk-11/openjdk-11-jdk-headless@11.0.8+10-1~deb10u1 and others
  • Fixed in: 11.0.12+7-2~deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openjdk-11/openjdk-11-jdk@11.0.8+10-1~deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openjdk-11/openjdk-11-jdk-headless@11.0.8+10-1~deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openjdk-11/openjdk-11-jre@11.0.8+10-1~deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openjdk-11/openjdk-11-jre-headless@11.0.8+10-1~deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openjdk-11 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the Java SE, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Hotspot). Supported versions that are affected are Java SE: 8u291, 11.0.11, 16.0.1; Oracle GraalVM Enterprise Edition: 20.3.2 and 21.1.0. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Oracle GraalVM Enterprise Edition. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in takeover of Java SE, Oracle GraalVM Enterprise Edition. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.1 Base Score 7.5 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H).

Remediation

Upgrade Debian:10 openjdk-11 to version 11.0.12+7-2~deb10u1 or higher.

References

high severity

Heap-based Buffer Overflow

  • Vulnerable module: openjpeg2/libopenjp2-7
  • Introduced through: openjpeg2/libopenjp2-7@2.3.0-2+deb10u1 and openjpeg2/libopenjp2-7-dev@2.3.0-2+deb10u1
  • Fixed in: 2.3.0-2+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openjpeg2/libopenjp2-7@2.3.0-2+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openjpeg2/libopenjp2-7-dev@2.3.0-2+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openjpeg2 package. See Remediation section below for Debian:10 relevant versions.

A heap-buffer overflow was found in the way openjpeg2 handled certain PNG format files. An attacker could use this flaw to cause an application crash or in some cases execute arbitrary code with the permission of the user running such an application.

Remediation

Upgrade Debian:10 openjpeg2 to version 2.3.0-2+deb10u2 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: openjpeg2/libopenjp2-7
  • Introduced through: openjpeg2/libopenjp2-7@2.3.0-2+deb10u1 and openjpeg2/libopenjp2-7-dev@2.3.0-2+deb10u1
  • Fixed in: 2.3.0-2+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openjpeg2/libopenjp2-7@2.3.0-2+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openjpeg2/libopenjp2-7-dev@2.3.0-2+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openjpeg2 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in OpenJPEG’s encoder. This flaw allows an attacker to pass specially crafted x,y offset input to OpenJPEG to use during encoding. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.

Remediation

Upgrade Debian:10 openjpeg2 to version 2.3.0-2+deb10u2 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: openjpeg2/libopenjp2-7
  • Introduced through: openjpeg2/libopenjp2-7@2.3.0-2+deb10u1 and openjpeg2/libopenjp2-7-dev@2.3.0-2+deb10u1
  • Fixed in: 2.3.0-2+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openjpeg2/libopenjp2-7@2.3.0-2+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openjpeg2/libopenjp2-7-dev@2.3.0-2+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openjpeg2 package. See Remediation section below for Debian:10 relevant versions.

OpenJPEG through 2.3.1 has a heap-based buffer overflow in opj_t1_clbl_decode_processor in openjp2/t1.c because of lack of opj_j2k_update_image_dimensions validation.

Remediation

Upgrade Debian:10 openjpeg2 to version 2.3.0-2+deb10u2 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: openjpeg2/libopenjp2-7
  • Introduced through: openjpeg2/libopenjp2-7@2.3.0-2+deb10u1 and openjpeg2/libopenjp2-7-dev@2.3.0-2+deb10u1
  • Fixed in: 2.3.0-2+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openjpeg2/libopenjp2-7@2.3.0-2+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openjpeg2/libopenjp2-7-dev@2.3.0-2+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openjpeg2 package. See Remediation section below for Debian:10 relevant versions.

opj_t1_clbl_decode_processor in openjp2/t1.c in OpenJPEG 2.3.1 through 2020-01-28 has a heap-based buffer overflow in the qmfbid==1 case, a different issue than CVE-2020-6851.

Remediation

Upgrade Debian:10 openjpeg2 to version 2.3.0-2+deb10u2 or higher.

References

high severity

Access of Resource Using Incompatible Type ('Type Confusion')

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 and openldap/libldap-common@2.4.47+dfsg-3+deb10u2
  • Fixed in: 2.4.47+dfsg-3+deb10u5

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-common@2.4.47+dfsg-3+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See Remediation section below for Debian:10 relevant versions.

A flaw was discovered in ldap_X509dn2bv in OpenLDAP before 2.4.57 leading to a slapd crash in the X.509 DN parsing in ad_keystring, resulting in denial of service.

Remediation

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u5 or higher.

References

high severity

CVE-2020-36226

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 and openldap/libldap-common@2.4.47+dfsg-3+deb10u2
  • Fixed in: 2.4.47+dfsg-3+deb10u5

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-common@2.4.47+dfsg-3+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See Remediation section below for Debian:10 relevant versions.

A flaw was discovered in OpenLDAP before 2.4.57 leading to a memch->bv_len miscalculation and slapd crash in the saslAuthzTo processing, resulting in denial of service.

Remediation

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u5 or higher.

References

high severity

Double Free

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 and openldap/libldap-common@2.4.47+dfsg-3+deb10u2
  • Fixed in: 2.4.47+dfsg-3+deb10u5

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-common@2.4.47+dfsg-3+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See Remediation section below for Debian:10 relevant versions.

A flaw was discovered in OpenLDAP before 2.4.57 leading to a double free and slapd crash in the saslAuthzTo processing, resulting in denial of service.

Remediation

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u5 or higher.

References

high severity

Integer Underflow

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 and openldap/libldap-common@2.4.47+dfsg-3+deb10u2
  • Fixed in: 2.4.47+dfsg-3+deb10u5

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-common@2.4.47+dfsg-3+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See Remediation section below for Debian:10 relevant versions.

An integer underflow was discovered in OpenLDAP before 2.4.57 leading to slapd crashes in the Certificate Exact Assertion processing, resulting in denial of service (schema_init.c serialNumberAndIssuerCheck).

Remediation

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u5 or higher.

References

high severity

Integer Underflow

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 and openldap/libldap-common@2.4.47+dfsg-3+deb10u2
  • Fixed in: 2.4.47+dfsg-3+deb10u5

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-common@2.4.47+dfsg-3+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See Remediation section below for Debian:10 relevant versions.

An integer underflow was discovered in OpenLDAP before 2.4.57 leading to a slapd crash in the Certificate List Exact Assertion processing, resulting in denial of service.

Remediation

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u5 or higher.

References

high severity

Loop with Unreachable Exit Condition ('Infinite Loop')

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 and openldap/libldap-common@2.4.47+dfsg-3+deb10u2
  • Fixed in: 2.4.47+dfsg-3+deb10u5

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-common@2.4.47+dfsg-3+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See Remediation section below for Debian:10 relevant versions.

A flaw was discovered in OpenLDAP before 2.4.57 leading to an infinite loop in slapd with the cancel_extop Cancel operation, resulting in denial of service.

Remediation

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u5 or higher.

References

high severity

NULL Pointer Dereference

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 and openldap/libldap-common@2.4.47+dfsg-3+deb10u2
  • Fixed in: 2.4.47+dfsg-3+deb10u3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-common@2.4.47+dfsg-3+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See Remediation section below for Debian:10 relevant versions.

A NULL pointer dereference was found in OpenLDAP server and was fixed in openldap 2.4.55, during a request for renaming RDNs. An unauthenticated attacker could remotely crash the slapd process by sending a specially crafted request, causing a Denial of Service.

Remediation

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u3 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 and openldap/libldap-common@2.4.47+dfsg-3+deb10u2
  • Fixed in: 2.4.47+dfsg-3+deb10u5

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-common@2.4.47+dfsg-3+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See Remediation section below for Debian:10 relevant versions.

A flaw was discovered in OpenLDAP before 2.4.57 leading to a slapd crash in the Values Return Filter control handling, resulting in denial of service (double free and out-of-bounds read).

Remediation

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u5 or higher.

References

high severity

Reachable Assertion

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 and openldap/libldap-common@2.4.47+dfsg-3+deb10u2
  • Fixed in: 2.4.47+dfsg-3+deb10u4

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-common@2.4.47+dfsg-3+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in OpenLDAP in versions before 2.4.56. This flaw allows an attacker who sends a malicious packet processed by OpenLDAP to force a failed assertion in csnNormalize23(). The highest threat from this vulnerability is to system availability.

Remediation

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u4 or higher.

References

high severity

Reachable Assertion

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 and openldap/libldap-common@2.4.47+dfsg-3+deb10u2
  • Fixed in: 2.4.47+dfsg-3+deb10u4

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-common@2.4.47+dfsg-3+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in OpenLDAP. This flaw allows an attacker who can send a malicious packet to be processed by OpenLDAP’s slapd server, to trigger an assertion failure. The highest threat from this vulnerability is to system availability.

Remediation

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u4 or higher.

References

high severity

Reachable Assertion

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 and openldap/libldap-common@2.4.47+dfsg-3+deb10u2
  • Fixed in: 2.4.47+dfsg-3+deb10u5

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-common@2.4.47+dfsg-3+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See Remediation section below for Debian:10 relevant versions.

A flaw was discovered in OpenLDAP before 2.4.57 leading to an assertion failure in slapd in the saslAuthzTo validation, resulting in denial of service.

Remediation

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u5 or higher.

References

high severity

Reachable Assertion

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 and openldap/libldap-common@2.4.47+dfsg-3+deb10u2
  • Fixed in: 2.4.47+dfsg-3+deb10u5

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-common@2.4.47+dfsg-3+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See Remediation section below for Debian:10 relevant versions.

A flaw was discovered in OpenLDAP before 2.4.57 leading in an assertion failure in slapd in the X.509 DN parsing in decode.c ber_next_element, resulting in denial of service.

Remediation

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u5 or higher.

References

high severity

Reachable Assertion

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 and openldap/libldap-common@2.4.47+dfsg-3+deb10u2
  • Fixed in: 2.4.47+dfsg-3+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-common@2.4.47+dfsg-3+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See Remediation section below for Debian:10 relevant versions.

In OpenLDAP through 2.4.57 and 2.5.x through 2.5.1alpha, an assertion failure in slapd can occur in the issuerAndThisUpdateCheck function via a crafted packet, resulting in a denial of service (daemon exit) via a short timestamp. This is related to schema_init.c and checkTime.

Remediation

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u6 or higher.

References

high severity

Release of Invalid Pointer or Reference

  • Vulnerable module: openldap/libldap-2.4-2
  • Introduced through: openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2 and openldap/libldap-common@2.4.47+dfsg-3+deb10u2
  • Fixed in: 2.4.47+dfsg-3+deb10u5

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-2.4-2@2.4.47+dfsg-3+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openldap/libldap-common@2.4.47+dfsg-3+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream openldap package. See Remediation section below for Debian:10 relevant versions.

A flaw was discovered in OpenLDAP before 2.4.57 leading to an invalid pointer free and slapd crash in the saslAuthzTo processing, resulting in denial of service.

Remediation

Upgrade Debian:10 openldap to version 2.4.47+dfsg-3+deb10u5 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: openssl
  • Introduced through: openssl@1.1.1d-0+deb10u3, openssl/libssl-dev@1.1.1d-0+deb10u3 and others
  • Fixed in: 1.1.1d-0+deb10u5

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openssl@1.1.1d-0+deb10u3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openssl/libssl-dev@1.1.1d-0+deb10u3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openssl/libssl1.1@1.1.1d-0+deb10u3

NVD Description

Note: Versions mentioned in the description apply to the upstream openssl package. See Remediation section below for Debian:10 relevant versions.

Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

Remediation

Upgrade Debian:10 openssl to version 1.1.1d-0+deb10u5 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: p11-kit/libp11-kit-dev
  • Introduced through: p11-kit/libp11-kit-dev@0.23.15-2 and p11-kit/libp11-kit0@0.23.15-2
  • Fixed in: 0.23.15-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* p11-kit/libp11-kit-dev@0.23.15-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* p11-kit/libp11-kit0@0.23.15-2

NVD Description

Note: Versions mentioned in the description apply to the upstream p11-kit package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in p11-kit 0.21.1 through 0.23.21. Multiple integer overflows have been discovered in the array allocations in the p11-kit library and the p11-kit list command, where overflow checks are missing before calling realloc or calloc.

Remediation

Upgrade Debian:10 p11-kit to version 0.23.15-2+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: p11-kit/libp11-kit-dev
  • Introduced through: p11-kit/libp11-kit-dev@0.23.15-2 and p11-kit/libp11-kit0@0.23.15-2
  • Fixed in: 0.23.15-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* p11-kit/libp11-kit-dev@0.23.15-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* p11-kit/libp11-kit0@0.23.15-2

NVD Description

Note: Versions mentioned in the description apply to the upstream p11-kit package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in p11-kit 0.23.6 through 0.23.21. A heap-based buffer overflow has been discovered in the RPC protocol used by p11-kit server/remote commands and the client library. When the remote entity supplies a serialized byte array in a CK_ATTRIBUTE, the receiving entity may not allocate sufficient length for the buffer to store the deserialized value.

Remediation

Upgrade Debian:10 p11-kit to version 0.23.15-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: pcre2/libpcre2-8-0
  • Introduced through: pcre2/libpcre2-8-0@10.32-5

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* pcre2/libpcre2-8-0@10.32-5

NVD Description

Note: Versions mentioned in the description apply to the upstream pcre2 package.

An out-of-bounds read was discovered in PCRE before 10.34 when the pattern \X is JIT compiled and used to match specially crafted subjects in non-UTF mode. Applications that use PCRE to parse untrusted input may be vulnerable to this flaw, which would allow an attacker to crash the application. The flaw occurs in do_extuni_no_utf in pcre2_jit_compile.c.

Remediation

There is no fixed version for Debian:10 pcre2.

References

high severity

Out-of-Bounds

  • Vulnerable module: postgresql-11/libpq-dev
  • Introduced through: postgresql-11/libpq-dev@11.7-0+deb10u1 and postgresql-11/libpq5@11.7-0+deb10u1
  • Fixed in: 11.12-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* postgresql-11/libpq-dev@11.7-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* postgresql-11/libpq5@11.7-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream postgresql-11 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in postgresql in versions before 13.3, before 12.7, before 11.12, before 10.17 and before 9.6.22. While modifying certain SQL array values, missing bounds checks let authenticated database users write arbitrary bytes to a wide area of server memory. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 postgresql-11 to version 11.12-0+deb10u1 or higher.

References

high severity

Permissive Whitelist

  • Vulnerable module: postgresql-11/libpq-dev
  • Introduced through: postgresql-11/libpq-dev@11.7-0+deb10u1 and postgresql-11/libpq5@11.7-0+deb10u1
  • Fixed in: 11.10-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* postgresql-11/libpq-dev@11.7-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* postgresql-11/libpq5@11.7-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream postgresql-11 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in the psql interactive terminal of PostgreSQL in versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. If an interactive psql session uses \gset when querying a compromised server, the attacker can execute arbitrary code as the operating system account running psql. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 postgresql-11 to version 11.10-0+deb10u1 or higher.

References

high severity

SQL Injection

  • Vulnerable module: postgresql-11/libpq-dev
  • Introduced through: postgresql-11/libpq-dev@11.7-0+deb10u1 and postgresql-11/libpq5@11.7-0+deb10u1
  • Fixed in: 11.10-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* postgresql-11/libpq-dev@11.7-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* postgresql-11/libpq5@11.7-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream postgresql-11 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. An attacker having permission to create non-temporary objects in at least one schema can execute arbitrary SQL functions under the identity of a superuser. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 postgresql-11 to version 11.10-0+deb10u1 or higher.

References

high severity

SQL Injection

  • Vulnerable module: postgresql-11/libpq-dev
  • Introduced through: postgresql-11/libpq-dev@11.7-0+deb10u1 and postgresql-11/libpq5@11.7-0+deb10u1
  • Fixed in: 11.9-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* postgresql-11/libpq-dev@11.7-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* postgresql-11/libpq5@11.7-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream postgresql-11 package. See Remediation section below for Debian:10 relevant versions.

It was found that PostgreSQL versions before 12.4, before 11.9 and before 10.14 did not properly sanitize the search_path during logical replication. An authenticated attacker could use this flaw in an attack similar to CVE-2018-1058, in order to execute arbitrary SQL command in the context of the user used for replication.

Remediation

Upgrade Debian:10 postgresql-11 to version 11.9-0+deb10u1 or higher.

References

high severity

Untrusted Search Path

  • Vulnerable module: postgresql-11/libpq-dev
  • Introduced through: postgresql-11/libpq-dev@11.7-0+deb10u1 and postgresql-11/libpq5@11.7-0+deb10u1
  • Fixed in: 11.9-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* postgresql-11/libpq-dev@11.7-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* postgresql-11/libpq5@11.7-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream postgresql-11 package. See Remediation section below for Debian:10 relevant versions.

It was found that some PostgreSQL extensions did not use search_path safely in their installation script. An attacker with sufficient privileges could use this flaw to trick an administrator into executing a specially crafted script, during the installation or update of such extension. This affects PostgreSQL versions before 12.4, before 11.9, before 10.14, before 9.6.19, and before 9.5.23.

Remediation

Upgrade Debian:10 postgresql-11 to version 11.9-0+deb10u1 or higher.

References

high severity

Use of a Broken or Risky Cryptographic Algorithm

  • Vulnerable module: postgresql-11/libpq-dev
  • Introduced through: postgresql-11/libpq-dev@11.7-0+deb10u1 and postgresql-11/libpq5@11.7-0+deb10u1
  • Fixed in: 11.10-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* postgresql-11/libpq-dev@11.7-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* postgresql-11/libpq5@11.7-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream postgresql-11 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. If a client application that creates additional database connections only reuses the basic connection parameters while dropping security-relevant parameters, an opportunity for a man-in-the-middle attack, or the ability to observe clear-text transmissions, could exist. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 postgresql-11 to version 11.10-0+deb10u1 or higher.

References

high severity

Buffer Overflow

  • Vulnerable module: python2.7
  • Introduced through: python2.7@2.7.16-2+deb10u1, python2.7/libpython2.7@2.7.16-2+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* python2.7@2.7.16-2+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* python2.7/libpython2.7@2.7.16-2+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* python2.7/libpython2.7-minimal@2.7.16-2+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* python2.7/libpython2.7-stdlib@2.7.16-2+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* python2.7/python2.7-minimal@2.7.16-2+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream python2.7 package.

Python 3.x through 3.9.1 has a buffer overflow in PyCArg_repr in _ctypes/callproc.c, which may lead to remote code execution in certain Python applications that accept floating-point numbers as untrusted input, as demonstrated by a 1e300 argument to c_double.from_param. This occurs because sprintf is used unsafely.

Remediation

There is no fixed version for Debian:10 python2.7.

References

high severity

Buffer Overflow

  • Vulnerable module: python3.7
  • Introduced through: python3.7@3.7.3-2+deb10u2, python3.7/libpython3.7-minimal@3.7.3-2+deb10u2 and others
  • Fixed in: 3.7.3-2+deb10u3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* python3.7@3.7.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* python3.7/libpython3.7-minimal@3.7.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* python3.7/libpython3.7-stdlib@3.7.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* python3.7/python3.7-minimal@3.7.3-2+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream python3.7 package. See Remediation section below for Debian:10 relevant versions.

Python 3.x through 3.9.1 has a buffer overflow in PyCArg_repr in _ctypes/callproc.c, which may lead to remote code execution in certain Python applications that accept floating-point numbers as untrusted input, as demonstrated by a 1e300 argument to c_double.from_param. This occurs because sprintf is used unsafely.

Remediation

Upgrade Debian:10 python3.7 to version 3.7.3-2+deb10u3 or higher.

References

high severity

Improper Encoding or Escaping of Output

  • Vulnerable module: python3.7
  • Introduced through: python3.7@3.7.3-2+deb10u2, python3.7/libpython3.7-minimal@3.7.3-2+deb10u2 and others
  • Fixed in: 3.7.3-2+deb10u3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* python3.7@3.7.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* python3.7/libpython3.7-minimal@3.7.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* python3.7/libpython3.7-stdlib@3.7.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* python3.7/python3.7-minimal@3.7.3-2+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream python3.7 package. See Remediation section below for Debian:10 relevant versions.

http.client in Python 3.x before 3.5.10, 3.6.x before 3.6.12, 3.7.x before 3.7.9, and 3.8.x before 3.8.5 allows CRLF injection if the attacker controls the HTTP request method, as demonstrated by inserting CR and LF control characters in the first argument of HTTPConnection.request.

Remediation

Upgrade Debian:10 python3.7 to version 3.7.3-2+deb10u3 or higher.

References

high severity

CVE-2019-19603

  • Vulnerable module: sqlite3/libsqlite3-0
  • Introduced through: sqlite3/libsqlite3-0@3.27.2-3 and sqlite3/libsqlite3-dev@3.27.2-3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* sqlite3/libsqlite3-0@3.27.2-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* sqlite3/libsqlite3-dev@3.27.2-3

NVD Description

Note: Versions mentioned in the description apply to the upstream sqlite3 package.

SQLite 3.30.1 mishandles certain SELECT statements with a nonexistent VIEW, leading to an application crash.

Remediation

There is no fixed version for Debian:10 sqlite3.

References

high severity

CVE-2019-19959

  • Vulnerable module: sqlite3/libsqlite3-0
  • Introduced through: sqlite3/libsqlite3-0@3.27.2-3 and sqlite3/libsqlite3-dev@3.27.2-3
  • Fixed in: 3.27.2-3+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* sqlite3/libsqlite3-0@3.27.2-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* sqlite3/libsqlite3-dev@3.27.2-3

NVD Description

Note: Versions mentioned in the description apply to the upstream sqlite3 package. See Remediation section below for Debian:10 relevant versions.

ext/misc/zipfile.c in SQLite 3.30.1 mishandles certain uses of INSERT INTO in situations involving embedded '\0' characters in filenames, leading to a memory-management error that can be detected by (for example) valgrind.

Remediation

Upgrade Debian:10 sqlite3 to version 3.27.2-3+deb10u1 or higher.

References

high severity

Improper Handling of Exceptional Conditions

  • Vulnerable module: sqlite3/libsqlite3-0
  • Introduced through: sqlite3/libsqlite3-0@3.27.2-3 and sqlite3/libsqlite3-dev@3.27.2-3
  • Fixed in: 3.27.2-3+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* sqlite3/libsqlite3-0@3.27.2-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* sqlite3/libsqlite3-dev@3.27.2-3

NVD Description

Note: Versions mentioned in the description apply to the upstream sqlite3 package. See Remediation section below for Debian:10 relevant versions.

selectExpander in select.c in SQLite 3.30.1 proceeds with WITH stack unwinding even after a parsing error.

Remediation

Upgrade Debian:10 sqlite3 to version 3.27.2-3+deb10u1 or higher.

References

high severity

NULL Pointer Dereference

  • Vulnerable module: sqlite3/libsqlite3-0
  • Introduced through: sqlite3/libsqlite3-0@3.27.2-3 and sqlite3/libsqlite3-dev@3.27.2-3
  • Fixed in: 3.27.2-3+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* sqlite3/libsqlite3-0@3.27.2-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* sqlite3/libsqlite3-dev@3.27.2-3

NVD Description

Note: Versions mentioned in the description apply to the upstream sqlite3 package. See Remediation section below for Debian:10 relevant versions.

flattenSubquery in select.c in SQLite 3.30.1 mishandles certain uses of SELECT DISTINCT involving a LEFT JOIN in which the right-hand side is a view. This can cause a NULL pointer dereference (or incorrect results).

Remediation

Upgrade Debian:10 sqlite3 to version 3.27.2-3+deb10u1 or higher.

References

high severity

Unrestricted Upload of File with Dangerous Type

  • Vulnerable module: sqlite3/libsqlite3-0
  • Introduced through: sqlite3/libsqlite3-0@3.27.2-3 and sqlite3/libsqlite3-dev@3.27.2-3
  • Fixed in: 3.27.2-3+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* sqlite3/libsqlite3-0@3.27.2-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* sqlite3/libsqlite3-dev@3.27.2-3

NVD Description

Note: Versions mentioned in the description apply to the upstream sqlite3 package. See Remediation section below for Debian:10 relevant versions.

zipfileUpdate in ext/misc/zipfile.c in SQLite 3.30.1 mishandles a NULL pathname during an update of a ZIP archive.

Remediation

Upgrade Debian:10 sqlite3 to version 3.27.2-3+deb10u1 or higher.

References

high severity

Use After Free

  • Vulnerable module: sqlite3/libsqlite3-0
  • Introduced through: sqlite3/libsqlite3-0@3.27.2-3 and sqlite3/libsqlite3-dev@3.27.2-3
  • Fixed in: 3.27.2-3+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* sqlite3/libsqlite3-0@3.27.2-3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* sqlite3/libsqlite3-dev@3.27.2-3

NVD Description

Note: Versions mentioned in the description apply to the upstream sqlite3 package. See Remediation section below for Debian:10 relevant versions.

ext/fts3/fts3.c in SQLite before 3.32.0 has a use-after-free in fts3EvalNextRow, related to the snippet feature.

Remediation

Upgrade Debian:10 sqlite3 to version 3.27.2-3+deb10u1 or higher.

References

high severity

NULL Pointer Dereference

  • Vulnerable module: subversion
  • Introduced through: subversion@1.10.4-1+deb10u1 and subversion/libsvn1@1.10.4-1+deb10u1
  • Fixed in: 1.10.4-1+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* subversion@1.10.4-1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* subversion/libsvn1@1.10.4-1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream subversion package. See Remediation section below for Debian:10 relevant versions.

Subversion's mod_authz_svn module will crash if the server is using in-repository authz rules with the AuthzSVNReposRelativeAccessFile option and a client sends a request for a non-existing repository URL. This can lead to disruption for users of the service. This issue was fixed in mod_dav_svn+mod_authz_svn servers 1.14.1 and mod_dav_svn+mod_authz_svn servers 1.10.7

Remediation

Upgrade Debian:10 subversion to version 1.10.4-1+deb10u2 or higher.

References

high severity

Off-by-one Error

  • Vulnerable module: sudo
  • Introduced through: sudo@1.8.27-1+deb10u2
  • Fixed in: 1.8.27-1+deb10u3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* sudo@1.8.27-1+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream sudo package. See Remediation section below for Debian:10 relevant versions.

Sudo before 1.9.5p2 contains an off-by-one error that can result in a heap-based buffer overflow, which allows privilege escalation to root via "sudoedit -s" and a command-line argument that ends with a single backslash character.

Remediation

Upgrade Debian:10 sudo to version 1.8.27-1+deb10u3 or higher.

References

high severity

Incorrect Privilege Assignment

  • Vulnerable module: systemd
  • Introduced through: systemd@241-7~deb10u4, systemd/libnss-systemd@241-7~deb10u4 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* systemd@241-7~deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* systemd/libnss-systemd@241-7~deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* systemd/libpam-systemd@241-7~deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* systemd/libsystemd0@241-7~deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* systemd/libudev1@241-7~deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* systemd/systemd-sysv@241-7~deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream systemd package.

It was discovered that a systemd service that uses DynamicUser property can create a SUID/SGID binary that would be allowed to run as the transient service UID/GID even after the service is terminated. A local attacker may use this flaw to access resources that will be owned by a potentially different service in the future, when the UID/GID will be recycled.

Remediation

There is no fixed version for Debian:10 systemd.

References

high severity

Privilege Chaining

  • Vulnerable module: systemd
  • Introduced through: systemd@241-7~deb10u4, systemd/libnss-systemd@241-7~deb10u4 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* systemd@241-7~deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* systemd/libnss-systemd@241-7~deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* systemd/libpam-systemd@241-7~deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* systemd/libsystemd0@241-7~deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* systemd/libudev1@241-7~deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* systemd/systemd-sysv@241-7~deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream systemd package.

It was discovered that a systemd service that uses DynamicUser property can get new privileges through the execution of SUID binaries, which would allow to create binaries owned by the service transient group with the setgid bit set. A local attacker may use this flaw to access resources that will be owned by a potentially different service in the future, when the GID will be recycled.

Remediation

There is no fixed version for Debian:10 systemd.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: tiff/libtiff-dev
  • Introduced through: tiff/libtiff-dev@4.1.0+git191117-2~deb10u1, tiff/libtiff5@4.1.0+git191117-2~deb10u1 and others
  • Fixed in: 4.1.0+git191117-2~deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* tiff/libtiff-dev@4.1.0+git191117-2~deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* tiff/libtiff5@4.1.0+git191117-2~deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* tiff/libtiffxx5@4.1.0+git191117-2~deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream tiff package. See Remediation section below for Debian:10 relevant versions.

An integer overflow flaw was found in libtiff that exists in the tif_getimage.c file. This flaw allows an attacker to inject and execute arbitrary code when a user opens a crafted TIFF file. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.

Remediation

Upgrade Debian:10 tiff to version 4.1.0+git191117-2~deb10u2 or higher.

References

high severity

Out-of-Bounds

  • Vulnerable module: tiff/libtiff-dev
  • Introduced through: tiff/libtiff-dev@4.1.0+git191117-2~deb10u1, tiff/libtiff5@4.1.0+git191117-2~deb10u1 and others
  • Fixed in: 4.1.0+git191117-2~deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* tiff/libtiff-dev@4.1.0+git191117-2~deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* tiff/libtiff5@4.1.0+git191117-2~deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* tiff/libtiffxx5@4.1.0+git191117-2~deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream tiff package. See Remediation section below for Debian:10 relevant versions.

A heap-based buffer overflow flaw was found in libtiff in the handling of TIFF images in libtiff's TIFF2PDF tool. A specially crafted TIFF file can lead to arbitrary code execution. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.

Remediation

Upgrade Debian:10 tiff to version 4.1.0+git191117-2~deb10u2 or higher.

References

high severity

Heap-based Buffer Overflow

  • Vulnerable module: xorg-server/xserver-common
  • Introduced through: xorg-server/xserver-common@2:1.20.4-1+deb10u1 and xorg-server/xvfb@2:1.20.4-1+deb10u1
  • Fixed in: 2:1.20.4-1+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* xorg-server/xserver-common@2:1.20.4-1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* xorg-server/xvfb@2:1.20.4-1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream xorg-server package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in xorg-x11-server before 1.20.10. A heap-buffer overflow in XkbSetDeviceInfo may lead to a privilege escalation vulnerability. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 xorg-server to version 2:1.20.4-1+deb10u2 or higher.

References

high severity

Integer Underflow

  • Vulnerable module: xorg-server/xserver-common
  • Introduced through: xorg-server/xserver-common@2:1.20.4-1+deb10u1 and xorg-server/xvfb@2:1.20.4-1+deb10u1
  • Fixed in: 2:1.20.4-1+deb10u3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* xorg-server/xserver-common@2:1.20.4-1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* xorg-server/xvfb@2:1.20.4-1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream xorg-server package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in xorg-x11-server in versions before 1.20.11. An integer underflow can occur in xserver which can lead to a local privilege escalation. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 xorg-server to version 2:1.20.4-1+deb10u3 or higher.

References

high severity

Out-of-Bounds

  • Vulnerable module: xorg-server/xserver-common
  • Introduced through: xorg-server/xserver-common@2:1.20.4-1+deb10u1 and xorg-server/xvfb@2:1.20.4-1+deb10u1
  • Fixed in: 2:1.20.4-1+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* xorg-server/xserver-common@2:1.20.4-1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* xorg-server/xvfb@2:1.20.4-1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream xorg-server package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in the X.Org Server before version 1.20.10. An out-of-bounds access in the XkbSetMap function may lead to a privilege escalation vulnerability. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 xorg-server to version 2:1.20.4-1+deb10u2 or higher.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: apt
  • Introduced through: apt@1.8.2.1 and apt/libapt-pkg5.0@1.8.2.1
  • Fixed in: 1.8.2.2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* apt@1.8.2.1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* apt/libapt-pkg5.0@1.8.2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream apt package. See Remediation section below for Debian:10 relevant versions.

APT had several integer overflows and underflows while parsing .deb packages, aka GHSL-2020-168 GHSL-2020-169, in files apt-pkg/contrib/extracttar.cc, apt-pkg/deb/debfile.cc, and apt-pkg/contrib/arfile.cc. This issue affects: apt 1.2.32ubuntu0 versions prior to 1.2.32ubuntu0.2; 1.6.12ubuntu0 versions prior to 1.6.12ubuntu0.2; 2.0.2ubuntu0 versions prior to 2.0.2ubuntu0.2; 2.1.10ubuntu0 versions prior to 2.1.10ubuntu0.1;

Remediation

Upgrade Debian:10 apt to version 1.8.2.2 or higher.

References

medium severity

Loop with Unreachable Exit Condition ('Infinite Loop')

  • Vulnerable module: avahi/libavahi-client3
  • Introduced through: avahi/libavahi-client3@0.7-4+b1, avahi/libavahi-common-data@0.7-4+b1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* avahi/libavahi-client3@0.7-4+b1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* avahi/libavahi-common-data@0.7-4+b1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* avahi/libavahi-common3@0.7-4+b1

NVD Description

Note: Versions mentioned in the description apply to the upstream avahi package.

A flaw was found in avahi in versions 0.6 up to 0.8. The event used to signal the termination of the client connection on the avahi Unix socket is not correctly handled in the client_work function, allowing a local attacker to trigger an infinite loop. The highest threat from this vulnerability is to the availability of the avahi service, which becomes unresponsive after this flaw is triggered.

Remediation

There is no fixed version for Debian:10 avahi.

References

medium severity

Improper Input Validation

  • Vulnerable module: cups/libcups2
  • Introduced through: cups/libcups2@2.2.10-6+deb10u3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* cups/libcups2@2.2.10-6+deb10u3

NVD Description

Note: Versions mentioned in the description apply to the upstream cups package.

An input validation issue was addressed with improved memory handling. This issue is fixed in macOS Big Sur 11.1, Security Update 2020-001 Catalina, Security Update 2020-007 Mojave. A malicious application may be able to read restricted memory.

Remediation

There is no fixed version for Debian:10 cups.

References

medium severity

Information Exposure

  • Vulnerable module: curl
  • Introduced through: curl@7.64.0-4+deb10u1, curl/libcurl3-gnutls@7.64.0-4+deb10u1 and others
  • Fixed in: 7.64.0-4+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl3-gnutls@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl4@7.64.0-4+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* curl/libcurl4-openssl-dev@7.64.0-4+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Debian:10 relevant versions.

curl 7.1.1 to and including 7.75.0 is vulnerable to an "Exposure of Private Personal Information to an Unauthorized Actor" by leaking credentials in the HTTP Referer: header. libcurl does not strip off user credentials from the URL when automatically populating the Referer: HTTP request header field in outgoing HTTP requests, and therefore risks leaking sensitive data to the server that is the target of the second HTTP request.

Remediation

Upgrade Debian:10 curl to version 7.64.0-4+deb10u2 or higher.

References

medium severity

Out-of-bounds Write

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

An out-of-bounds write vulnerability was found in DjVuLibre in DJVU::DjVuTXT::decode() in DjVuText.cpp via a crafted djvu file which may lead to crash and segmentation fault. This flaw affects DjVuLibre versions prior to 3.5.28.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

medium severity

CVE-2020-28014

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u4, exim4/exim4-config@4.92-8+deb10u4 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u4
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u4

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. The -oP option is available to the exim user, and allows a denial of service because root-owned files can be overwritten.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

medium severity

Out-of-bounds Write

  • Vulnerable module: freetype/libfreetype6
  • Introduced through: freetype/libfreetype6@2.9.1-3+deb10u1 and freetype/libfreetype6-dev@2.9.1-3+deb10u1
  • Fixed in: 2.9.1-3+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* freetype/libfreetype6@2.9.1-3+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* freetype/libfreetype6-dev@2.9.1-3+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream freetype package. See Remediation section below for Debian:10 relevant versions.

Heap buffer overflow in Freetype in Google Chrome prior to 86.0.4240.111 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

Remediation

Upgrade Debian:10 freetype to version 2.9.1-3+deb10u2 or higher.

References

medium severity

Divide By Zero

  • Vulnerable module: giflib/libgif7
  • Introduced through: giflib/libgif7@5.1.4-3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* giflib/libgif7@5.1.4-3

NVD Description

Note: Versions mentioned in the description apply to the upstream giflib package.

In GIFLIB before 2019-02-16, a malformed GIF file triggers a divide-by-zero exception in the decoder function DGifSlurp in dgif_lib.c if the height field of the ImageSize data structure is equal to zero.

Remediation

There is no fixed version for Debian:10 giflib.

References

medium severity

Link Following

  • Vulnerable module: glib2.0/libglib2.0-0
  • Introduced through: glib2.0/libglib2.0-0@2.58.3-2+deb10u2, glib2.0/libglib2.0-bin@2.58.3-2+deb10u2 and others
  • Fixed in: 2.58.3-2+deb10u3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glib2.0/libglib2.0-0@2.58.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glib2.0/libglib2.0-bin@2.58.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glib2.0/libglib2.0-data@2.58.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glib2.0/libglib2.0-dev@2.58.3-2+deb10u2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glib2.0/libglib2.0-dev-bin@2.58.3-2+deb10u2

NVD Description

Note: Versions mentioned in the description apply to the upstream glib2.0 package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in GNOME GLib before 2.66.8. When g_file_replace() is used with G_FILE_CREATE_REPLACE_DESTINATION to replace a path that is a dangling symlink, it incorrectly also creates the target of the symlink as an empty file, which could conceivably have security relevance if the symlink is attacker-controlled. (If the path is a symlink to a file that already exists, then the contents of that file correctly remain unchanged.)

Remediation

Upgrade Debian:10 glib2.0 to version 2.58.3-2+deb10u3 or higher.

References

medium severity

Loop with Unreachable Exit Condition ('Infinite Loop')

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The iconv function in the GNU C Library (aka glibc or libc6) 2.32 and earlier, when processing invalid multi-byte input sequences in IBM1364, IBM1371, IBM1388, IBM1390, and IBM1399 encodings, fails to advance the input state, which could lead to an infinite loop in applications, resulting in a denial of service, a different vulnerability from CVE-2016-10228.

Remediation

There is no fixed version for Debian:10 glibc.

References

medium severity

Out-of-Bounds

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The GNU C Library (aka glibc or libc6) before 2.32 could overflow an on-stack buffer during range reduction if an input to an 80-bit long double function contains a non-canonical bit pattern, a seen when passing a 0x5d414141414141410000 value to sinl on x86 targets. This is related to sysdeps/ieee754/ldbl-96/e_rem_pio2l.c.

Remediation

There is no fixed version for Debian:10 glibc.

References

medium severity

Out-of-bounds Read

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The iconv feature in the GNU C Library (aka glibc or libc6) through 2.32, when processing invalid multi-byte input sequences in the EUC-KR encoding, may have a buffer over-read.

Remediation

There is no fixed version for Debian:10 glibc.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in MagickCore/colorspace-private.h and MagickCore/quantum.h. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of values outside the range of type unsigned char and math division by zero. This would most likely lead to an impact to application availability, but could potentially cause other problems related to undefined behavior. This flaw affects ImageMagick versions prior to 7.0.8-68.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

In ParseMetaGeometry() of MagickCore/geometry.c, image height and width calculations can lead to divide-by-zero conditions which also lead to undefined behavior. This flaw can be triggered by a crafted input file processed by ImageMagick and could impact application availability. The patch uses multiplication in addition to the function PerceptibleReciprocal() in order to prevent such divide-by-zero conditions. This flaw affects ImageMagick versions prior to 7.0.9-0.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

In GammaImage() of /MagickCore/enhance.c, depending on the gamma value, it's possible to trigger a divide-by-zero condition when a crafted input file is processed by ImageMagick. This could lead to an impact to application availability. The patch uses the PerceptibleReciprocal() to prevent the divide-by-zero from occurring. This flaw affects ImageMagick versions prior to ImageMagick 7.0.8-68.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A divide-by-zero flaw was found in ImageMagick 6.9.11-57 and 7.0.10-57 in gem.c. This flaw allows an attacker who submits a crafted file that is processed by ImageMagick to trigger undefined behavior through a division by zero. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in coders/jp2.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of math division by zero. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in coders/webp.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of math division by zero. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in MagickCore/resample.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of math division by zero. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in MagickCore/visual-effects.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of math division by zero. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in MagickCore/resize.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of math division by zero. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in coders/hdr.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of values outside the range of type unsigned char. This would most likely lead to an impact to application availability, but could potentially cause other problems related to undefined behavior. This flaw affects ImageMagick versions prior to ImageMagick 7.0.8-68.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

In CatromWeights(), MeshInterpolate(), InterpolatePixelChannel(), InterpolatePixelChannels(), and InterpolatePixelInfo(), which are all functions in /MagickCore/pixel.c, there were multiple unconstrained pixel offset calculations which were being used with the floor() function. These calculations produced undefined behavior in the form of out-of-range and integer overflows, as identified by UndefinedBehaviorSanitizer. These instances of undefined behavior could be triggered by an attacker who is able to supply a crafted input file to be processed by ImageMagick. These issues could impact application availability or potentially cause other problems related to undefined behavior. This flaw affects ImageMagick versions prior to 7.0.9-0.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

Due to a missing check for 0 value of replace_extent, it is possible for offset p to overflow in SubstituteString(), causing potential impact to application availability. This could be triggered by a crafted input file that is processed by ImageMagick. This flaw affects ImageMagick versions prior to 7.0.8-68.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Out-of-bounds Read

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

WriteOnePNGImage() from coders/png.c (the PNG coder) has a for loop with an improper exit condition that can allow an out-of-bounds READ via heap-buffer-overflow. This occurs because it is possible for the colormap to have less than 256 valid values but the loop condition will loop 256 times, attempting to pass invalid colormap data to the event logger. The patch replaces the hardcoded 256 value with a call to MagickMin() to ensure the proper value is used. This could impact application availability when a specially crafted input file is processed by ImageMagick. This flaw affects ImageMagick versions prior to 7.0.8-68.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Out-of-bounds Read

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

The PALM image coder at coders/palm.c makes an improper call to AcquireQuantumMemory() in routine WritePALMImage() because it needs to be offset by 256. This can cause a out-of-bounds read later on in the routine. The patch adds 256 to bytes_per_row in the call to AcquireQuantumMemory(). This could cause impact to reliability. This flaw affects ImageMagick versions prior to 7.0.8-68.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Out-of-bounds Write

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

In WriteOnePNGImage() of the PNG coder at coders/png.c, an improper call to AcquireVirtualMemory() and memset() allows for an out-of-bounds write later when PopShortPixel() from MagickCore/quantum-private.h is called. The patch fixes the calls by adding 256 to rowbytes. An attacker who is able to supply a specially crafted image could affect availability with a low impact to data integrity. This flaw affects ImageMagick versions prior to 6.9.10-68 and 7.0.8-68.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

medium severity

Use After Free

  • Vulnerable module: iproute2
  • Introduced through: iproute2@4.20.0-2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* iproute2@4.20.0-2

NVD Description

Note: Versions mentioned in the description apply to the upstream iproute2 package.

iproute2 before 5.1.0 has a use-after-free in get_netnsid_from_name in ip/ipnetns.c. NOTE: security relevance may be limited to certain uses of setuid that, although not a default, are sometimes a configuration option offered to end users. Even when setuid is used, other factors (such as C library configuration) may block exploitability.

Remediation

There is no fixed version for Debian:10 iproute2.

References

medium severity

Race Condition

  • Vulnerable module: libgcrypt20
  • Introduced through: libgcrypt20@1.8.4-5

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libgcrypt20@1.8.4-5

NVD Description

Note: Versions mentioned in the description apply to the upstream libgcrypt20 package.

It was discovered that there was a ECDSA timing attack in the libgcrypt20 cryptographic library. Version affected: 1.8.4-5, 1.7.6-2+deb9u3, and 1.6.3-2+deb8u4. Versions fixed: 1.8.5-2 and 1.6.3-2+deb8u7.

Remediation

There is no fixed version for Debian:10 libgcrypt20.

References

medium severity

Divide By Zero

  • Vulnerable module: libjpeg-turbo/libjpeg-dev
  • Introduced through: libjpeg-turbo/libjpeg-dev@1:1.5.2-2, libjpeg-turbo/libjpeg62-turbo@1:1.5.2-2+b1 and others
  • Fixed in: 1:1.5.2-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libjpeg-turbo/libjpeg-dev@1:1.5.2-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libjpeg-turbo/libjpeg62-turbo@1:1.5.2-2+b1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libjpeg-turbo/libjpeg62-turbo-dev@1:1.5.2-2+b1

NVD Description

Note: Versions mentioned in the description apply to the upstream libjpeg-turbo package. See Remediation section below for Debian:10 relevant versions.

libjpeg-turbo 1.5.90 is vulnerable to a denial of service vulnerability caused by a divide by zero when processing a crafted BMP image.

Remediation

Upgrade Debian:10 libjpeg-turbo to version 1:1.5.2-2+deb10u1 or higher.

References

medium severity

Out-of-bounds Read

  • Vulnerable module: libjpeg-turbo/libjpeg-dev
  • Introduced through: libjpeg-turbo/libjpeg-dev@1:1.5.2-2, libjpeg-turbo/libjpeg62-turbo@1:1.5.2-2+b1 and others
  • Fixed in: 1:1.5.2-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libjpeg-turbo/libjpeg-dev@1:1.5.2-2
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libjpeg-turbo/libjpeg62-turbo@1:1.5.2-2+b1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libjpeg-turbo/libjpeg62-turbo-dev@1:1.5.2-2+b1

NVD Description

Note: Versions mentioned in the description apply to the upstream libjpeg-turbo package. See Remediation section below for Debian:10 relevant versions.

get_8bit_row in rdbmp.c in libjpeg-turbo through 1.5.90 and MozJPEG through 3.3.1 allows attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted 8-bit BMP in which one or more of the color indices is out of range for the number of palette entries.

Remediation

Upgrade Debian:10 libjpeg-turbo to version 1:1.5.2-2+deb10u1 or higher.

References

medium severity

Out-of-bounds Write

  • Vulnerable module: libmaxminddb/libmaxminddb-dev
  • Introduced through: libmaxminddb/libmaxminddb-dev@1.3.2-1 and libmaxminddb/libmaxminddb0@1.3.2-1
  • Fixed in: 1.3.2-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libmaxminddb/libmaxminddb-dev@1.3.2-1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libmaxminddb/libmaxminddb0@1.3.2-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libmaxminddb package. See Remediation section below for Debian:10 relevant versions.

libmaxminddb before 1.4.3 has a heap-based buffer over-read in dump_entry_data_list in maxminddb.c.

Remediation

Upgrade Debian:10 libmaxminddb to version 1.3.2-1+deb10u1 or higher.

References

medium severity

Resource Exhaustion

  • Vulnerable module: librsvg/gir1.2-rsvg-2.0
  • Introduced through: librsvg/gir1.2-rsvg-2.0@2.44.10-2.1, librsvg/librsvg2-2@2.44.10-2.1 and others

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* librsvg/gir1.2-rsvg-2.0@2.44.10-2.1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* librsvg/librsvg2-2@2.44.10-2.1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* librsvg/librsvg2-common@2.44.10-2.1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* librsvg/librsvg2-dev@2.44.10-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream librsvg package.

In xml.rs in GNOME librsvg before 2.46.2, a crafted SVG file with nested patterns can cause denial of service when passed to the library for processing. The attacker constructs pattern elements so that the number of final rendered objects grows exponentially.

Remediation

There is no fixed version for Debian:10 librsvg.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: libx11/libx11-6
  • Introduced through: libx11/libx11-6@2:1.6.7-1, libx11/libx11-data@2:1.6.7-1 and others
  • Fixed in: 2:1.6.7-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libx11/libx11-6@2:1.6.7-1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libx11/libx11-data@2:1.6.7-1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libx11/libx11-dev@2:1.6.7-1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libx11/libx11-xcb1@2:1.6.7-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libx11 package. See Remediation section below for Debian:10 relevant versions.

An integer overflow leading to a heap-buffer overflow was found in The X Input Method (XIM) client was implemented in libX11 before version 1.6.10. As per upstream this is security relevant when setuid programs call XIM client functions while running with elevated privileges. No such programs are shipped with Red Hat Enterprise Linux.

Remediation

Upgrade Debian:10 libx11 to version 2:1.6.7-1+deb10u1 or higher.

References

medium severity

Allocation of Resources Without Limits or Throttling

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

The xz_head function in xzlib.c in libxml2 before 2.9.6 allows remote attackers to cause a denial of service (memory consumption) via a crafted LZMA file, because the decoder functionality does not restrict memory usage to what is required for a legitimate file.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u1 or higher.

References

medium severity

Improper Restriction of Recursive Entity References in DTDs ('XML Entity Expansion')

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libxml2. Exponential entity expansion attack its possible bypassing all existing protection mechanisms and leading to denial of service.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u2 or higher.

References

medium severity

Loop with Unreachable Exit Condition ('Infinite Loop')

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

libxml2 2.9.8, if --with-lzma is used, allows remote attackers to cause a denial of service (infinite loop) via a crafted XML file that triggers LZMA_MEMLIMIT_ERROR, as demonstrated by xmllint, a different vulnerability than CVE-2015-8035 and CVE-2018-9251.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u1 or higher.

References

medium severity

NULL Pointer Dereference

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

A vulnerability found in libxml2 in versions before 2.9.11 shows that it did not propagate errors while parsing XML mixed content, causing a NULL dereference. If an untrusted XML document was parsed in recovery mode and post-validated, the flaw could be used to crash the application. The highest threat from this vulnerability is to system availability.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u2 or higher.

References

medium severity

Out-of-bounds Read

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

GNOME project libxml2 v2.9.10 has a global buffer over-read vulnerability in xmlEncodeEntitiesInternal at libxml2/entities.c. The issue has been fixed in commit 50f06b3e.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u2 or higher.

References

medium severity

XML External Entity (XXE) Injection

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package.

libxml2 2.9.4 and earlier, as used in XMLSec 1.2.23 and earlier and other products, does not offer a flag directly indicating that the current document may be read but other files may not be opened, which makes it easier for remote attackers to conduct XML External Entity (XXE) attacks via a crafted document.

Remediation

There is no fixed version for Debian:10 libxml2.

References

medium severity

Incorrect Default Permissions

  • Vulnerable module: libzstd/libzstd1
  • Introduced through: libzstd/libzstd1@1.3.8+dfsg-3
  • Fixed in: 1.3.8+dfsg-3+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libzstd/libzstd1@1.3.8+dfsg-3

NVD Description

Note: Versions mentioned in the description apply to the upstream libzstd package. See Remediation section below for Debian:10 relevant versions.

In the Zstandard command-line utility prior to v1.4.1, output files were created with default permissions. Correct file permissions (matching the input) would only be set at completion time. Output files could therefore be readable or writable to unintended parties.

Remediation

Upgrade Debian:10 libzstd to version 1.3.8+dfsg-3+deb10u1 or higher.

References

medium severity

Incorrect Default Permissions

  • Vulnerable module: libzstd/libzstd1
  • Introduced through: libzstd/libzstd1@1.3.8+dfsg-3
  • Fixed in: 1.3.8+dfsg-3+deb10u2

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* libzstd/libzstd1@1.3.8+dfsg-3

NVD Description

Note: Versions mentioned in the description apply to the upstream libzstd package. See Remediation section below for Debian:10 relevant versions.

Beginning in v1.4.1 and prior to v1.4.9, due to an incomplete fix for CVE-2021-24031, the Zstandard command-line utility created output files with default permissions and restricted those permissions immediately afterwards. Output files could therefore momentarily be readable or writable to unintended parties.

Remediation

Upgrade Debian:10 libzstd to version 1.3.8+dfsg-3+deb10u2 or higher.

References

medium severity

CVE-2020-14765

  • Vulnerable module: mariadb-10.3/libmariadb-dev
  • Introduced through: mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1, mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1 and others
  • Fixed in: 1:10.3.27-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb3@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/mariadb-common@1:10.3.23-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.3 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: FTS). Supported versions that are affected are 5.6.49 and prior, 5.7.31 and prior and 8.0.21 and prior. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 6.5 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H).

Remediation

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.27-0+deb10u1 or higher.

References

medium severity

CVE-2020-14776

  • Vulnerable module: mariadb-10.3/libmariadb-dev
  • Introduced through: mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1, mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1 and others
  • Fixed in: 1:10.3.27-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb3@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/mariadb-common@1:10.3.23-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.3 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the MySQL Server product of Oracle MySQL (component: InnoDB). Supported versions that are affected are 5.7.31 and prior and 8.0.21 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).

Remediation

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.27-0+deb10u1 or higher.

References

medium severity

CVE-2020-14789

  • Vulnerable module: mariadb-10.3/libmariadb-dev
  • Introduced through: mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1, mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1 and others
  • Fixed in: 1:10.3.27-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb3@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/mariadb-common@1:10.3.23-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.3 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: FTS). Supported versions that are affected are 5.7.31 and prior and 8.0.21 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).

Remediation

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.27-0+deb10u1 or higher.

References

medium severity

CVE-2020-14812

  • Vulnerable module: mariadb-10.3/libmariadb-dev
  • Introduced through: mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1, mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1 and others
  • Fixed in: 1:10.3.27-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb3@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/mariadb-common@1:10.3.23-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.3 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: Locking). Supported versions that are affected are 5.6.49 and prior, 5.7.31 and prior and 8.0.21 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).

Remediation

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.27-0+deb10u1 or higher.

References

medium severity

CVE-2021-2022

  • Vulnerable module: mariadb-10.3/libmariadb-dev
  • Introduced through: mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1, mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1 and others
  • Fixed in: 1:10.3.25-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb3@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/mariadb-common@1:10.3.23-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.3 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the MySQL Server product of Oracle MySQL (component: InnoDB). Supported versions that are affected are 5.6.50 and prior, 5.7.32 and prior and 8.0.22 and prior. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.4 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H).

Remediation

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.25-0+deb10u1 or higher.

References

medium severity

CVE-2021-2154

  • Vulnerable module: mariadb-10.3/libmariadb-dev
  • Introduced through: mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1, mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1 and others
  • Fixed in: 1:10.3.29-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb3@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/mariadb-common@1:10.3.23-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.3 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: DML). Supported versions that are affected are 5.7.33 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).

Remediation

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.29-0+deb10u1 or higher.

References

medium severity

CVE-2021-2166

  • Vulnerable module: mariadb-10.3/libmariadb-dev
  • Introduced through: mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1, mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1 and others
  • Fixed in: 1:10.3.29-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb3@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/mariadb-common@1:10.3.23-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.3 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: DML). Supported versions that are affected are 5.7.33 and prior and 8.0.23 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).

Remediation

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.29-0+deb10u1 or higher.

References

medium severity

CVE-2021-2194

  • Vulnerable module: mariadb-10.3/libmariadb-dev
  • Introduced through: mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1, mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1 and others
  • Fixed in: 1:10.3.27-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev-compat@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/libmariadb3@1:10.3.23-0+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* mariadb-10.3/mariadb-common@1:10.3.23-0+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.3 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the MySQL Server product of Oracle MySQL (component: InnoDB). Supported versions that are affected are 5.7.33 and prior and 8.0.23 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).

Remediation

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.27-0+deb10u1 or higher.

References

medium severity

DNS Rebinding

  • Vulnerable module: node
  • Introduced through: node@14.9.0
  • Fixed in: 14.16.0

Detailed paths

  • Introduced through: docker-image|circleci/node@14.9.0-buster-browsers-legacy node@14.9.0

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to DNS Rebinding. A Denial of Service can occur when the whitelist in /etc/hosts includes localhost6. If an attacker controls the victim's DNS server or can spoof its responses, the DNS rebinding protection can be bypassed by using the localhost6 domain.

Remediation

Upgrade node to version 15.10.0, 14.16.0, 12.21.0, 10.24.0 or higher.

References

medium severity

HTTP Request Smuggling

  • Vulnerable module: node
  • Introduced through: node@14.9.0
  • Fixed in: 14.11.0

Detailed paths

  • Introduced through: docker-image|circleci/node@14.9.0-buster-browsers-legacy node@14.9.0

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to HTTP Request Smuggling. Affected Node.js versions converted carriage returns in HTTP request headers to a hyphen before parsing. This can lead to HTTP Request Smuggling as it is a non-standard interpretation of the header.

Remediation

Upgrade node to version 14.11.0 or higher.

References

medium severity

NULL Pointer Dereference

  • Vulnerable module: node
  • Introduced through: node@14.9.0
  • Fixed in: 14.16.1

Detailed paths

  • Introduced through: docker-image|circleci/node@14.9.0-buster-browsers-legacy node@14.9.0

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to NULL Pointer Dereference. If sent a maliciously crafted renegotiation ClientHello message from a client, an OpenSSL TLS server may crash. If a TLSv1.2 renegotiation ClientHello omits the signature_algorithms extension (where it was present in the initial ClientHello), but includes a signature_algorithms_cert extension then a NULL pointer dereference will result, leading to a crash and a Denial of Service.

Remediation

Upgrade node to version 15.14.0, 14.16.1, 12.22.1, 10.24.1 or higher.

References

medium severity

Use After Free

  • Vulnerable module: node
  • Introduced through: node@14.9.0
  • Fixed in: 14.15.4

Detailed paths

  • Introduced through: docker-image|circleci/node@14.9.0-buster-browsers-legacy node@14.9.0

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Use After Free. When writing to a TLS enabled socket, node::StreamBase::Write calls node::TLSWrap::DoWrite with a freshly allocated WriteWrap object as first argument. If the DoWrite method does not return an error, this object is passed back to the caller as part of a StreamWriteResult structure. This may be exploited to corrupt memory.

Remediation

Upgrade node to version 10.23.1, 12.20.1, 14.15.4, 15.5.1 or higher.

References

medium severity

CVE-2020-6829

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1+deb10u3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* nss/libnss3@2:3.42.1-1+deb10u3

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package.

When performing EC scalar point multiplication, the wNAF point multiplication algorithm was used; which leaked partial information about the nonce used during signature generation. Given an electro-magnetic trace of a few signature generations, the private key could have been computed. This vulnerability affects Firefox < 80 and Firefox for Android < 80.

Remediation

There is no fixed version for Debian:10 nss.

References

medium severity

Information Exposure

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1+deb10u3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* nss/libnss3@2:3.42.1-1+deb10u3

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package.

When converting coordinates from projective to affine, the modular inversion was not performed in constant time, resulting in a possible timing-based side channel attack. This vulnerability affects Firefox < 80 and Firefox for Android < 80.

Remediation

There is no fixed version for Debian:10 nss.

References

medium severity

Use of a Broken or Risky Cryptographic Algorithm

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1+deb10u3

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* nss/libnss3@2:3.42.1-1+deb10u3

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package.

During ECDSA signature generation, padding applied in the nonce designed to ensure constant-time scalar multiplication was removed, resulting in variable-time execution dependent on secret data. This vulnerability affects Firefox < 80 and Firefox for Android < 80.

Remediation

There is no fixed version for Debian:10 nss.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1+deb10u1 and openexr/libopenexr23@2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openexr/libopenexr-dev@2.2.1-4.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openexr/libopenexr23@2.2.1-4.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package.

A flaw was found in OpenEXR's B44 uncompression functionality in versions before 3.0.0-beta. An attacker who is able to submit a crafted file to OpenEXR could trigger shift overflows, potentially affecting application availability.

Remediation

There is no fixed version for Debian:10 openexr.

References

medium severity

Integer Overflow or Wraparound

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1+deb10u1 and openexr/libopenexr23@2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openexr/libopenexr-dev@2.2.1-4.1+deb10u1
  • Introduced through: circleci/node:14.9.0-buster-browsers-legacy@* openexr/libopenexr23@2.2.1-4.1+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package.

There's a flaw in OpenEXR in versions before 3.0.0-beta. A crafted input file that is processed by OpenEXR could cause a shift overflow in the FastHufDecoder, potentially leading to problems with application availability.

Remediation

There is no fixed version for Debian:10 openexr.

References

<