Docker circleci/node:12.8-buster-browsers-legacy

Vulnerabilities

773 via 3286 paths

Dependencies

651

Source

Group 6 Copy Created with Sketch. Docker

Target OS

debian:10
Test your Docker Hub image against our market leading vulnerability database Sign up for free
Severity
  • 258
  • 192
  • 323
Status
  • 773
  • 0
  • 0
OS binaries
  • 753
  • 20

high severity

Link Following

  • Vulnerable module: avahi/libavahi-client3
  • Introduced through: avahi/libavahi-client3@0.7-4+b1, avahi/libavahi-common-data@0.7-4+b1 and others
  • Fixed in: 0.7-4+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* avahi/libavahi-client3@0.7-4+b1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* avahi/libavahi-common-data@0.7-4+b1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* avahi/libavahi-common3@0.7-4+b1

NVD Description

Note: Versions mentioned in the description apply to the upstream avahi package. See Remediation section below for Debian:10 relevant versions.

avahi-daemon-check-dns.sh in the Debian avahi package through 0.8-4 is executed as root via /etc/network/if-up.d/avahi-daemon, and allows a local attacker to cause a denial of service or create arbitrary empty files via a symlink attack on files under /run/avahi-daemon. NOTE: this only affects the packaging for Debian GNU/Linux (used indirectly by SUSE), not the upstream Avahi product.

Remediation

Upgrade Debian:10 avahi to version 0.7-4+deb10u1 or higher.

References

high severity

Stack-based Buffer Overflow

  • Vulnerable module: cairo/libcairo-gobject2
  • Introduced through: cairo/libcairo-gobject2@1.16.0-4, cairo/libcairo-script-interpreter2@1.16.0-4 and others
  • Fixed in: 1.16.0-4+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* cairo/libcairo-gobject2@1.16.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* cairo/libcairo-script-interpreter2@1.16.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* cairo/libcairo2@1.16.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* cairo/libcairo2-dev@1.16.0-4

NVD Description

Note: Versions mentioned in the description apply to the upstream cairo package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in cairo's image-compositor.c in all versions prior to 1.17.4. This flaw allows an attacker who can provide a crafted input file to cairo's image-compositor (for example, by convincing a user to open a file in an application using cairo, or if an application uses cairo on untrusted input) to cause a stack buffer overflow -> out-of-bounds WRITE. The highest impact from this vulnerability is to confidentiality, integrity, as well as system availability.

Remediation

Upgrade Debian:10 cairo to version 1.16.0-4+deb10u1 or higher.

References

high severity

Buffer Overflow

  • Vulnerable module: cups/libcups2
  • Introduced through: cups/libcups2@2.2.10-6
  • Fixed in: 2.2.10-6+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* cups/libcups2@2.2.10-6

NVD Description

Note: Versions mentioned in the description apply to the upstream cups package. See Remediation section below for Debian:10 relevant versions.

A buffer overflow issue was addressed with improved memory handling. This issue is fixed in macOS Mojave 10.14.6, Security Update 2019-004 High Sierra, Security Update 2019-004 Sierra. An attacker in a privileged network position may be able to execute arbitrary code.

Remediation

Upgrade Debian:10 cups to version 2.2.10-6+deb10u1 or higher.

References

high severity

Buffer Overflow

  • Vulnerable module: cups/libcups2
  • Introduced through: cups/libcups2@2.2.10-6
  • Fixed in: 2.2.10-6+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* cups/libcups2@2.2.10-6

NVD Description

Note: Versions mentioned in the description apply to the upstream cups package. See Remediation section below for Debian:10 relevant versions.

A buffer overflow issue was addressed with improved memory handling. This issue is fixed in macOS Mojave 10.14.6, Security Update 2019-004 High Sierra, Security Update 2019-004 Sierra. An attacker in a privileged network position may be able to execute arbitrary code.

Remediation

Upgrade Debian:10 cups to version 2.2.10-6+deb10u1 or higher.

References

high severity

Out-of-Bounds

  • Vulnerable module: cups/libcups2
  • Introduced through: cups/libcups2@2.2.10-6
  • Fixed in: 2.2.10-6+deb10u3

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* cups/libcups2@2.2.10-6

NVD Description

Note: Versions mentioned in the description apply to the upstream cups package. See Remediation section below for Debian:10 relevant versions.

A memory corruption issue was addressed with improved validation. This issue is fixed in macOS Catalina 10.15.4. An application may be able to gain elevated privileges.

Remediation

Upgrade Debian:10 cups to version 2.2.10-6+deb10u3 or higher.

References

high severity

Arbitrary Code Injection

  • Vulnerable module: curl
  • Introduced through: curl@7.64.0-4, curl/libcurl3-gnutls@7.64.0-4 and others
  • Fixed in: 7.64.0-4+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl3-gnutls@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl4@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl4-openssl-dev@7.64.0-4

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Debian:10 relevant versions.

curl 7.20.0 through 7.70.0 is vulnerable to improper restriction of names for files and other resources that can lead too overwriting a local file when the -J flag is used.

Remediation

Upgrade Debian:10 curl to version 7.64.0-4+deb10u2 or higher.

References

high severity

Buffer Overflow

  • Vulnerable module: curl
  • Introduced through: curl@7.64.0-4, curl/libcurl3-gnutls@7.64.0-4 and others
  • Fixed in: 7.64.0-4+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl3-gnutls@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl4@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl4-openssl-dev@7.64.0-4

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Debian:10 relevant versions.

Heap buffer overflow in the TFTP protocol handler in cURL 7.19.4 to 7.65.3.

Remediation

Upgrade Debian:10 curl to version 7.64.0-4+deb10u1 or higher.

References

high severity

Double Free

  • Vulnerable module: curl
  • Introduced through: curl@7.64.0-4, curl/libcurl3-gnutls@7.64.0-4 and others
  • Fixed in: 7.64.0-4+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl3-gnutls@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl4@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl4-openssl-dev@7.64.0-4

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Debian:10 relevant versions.

Double-free vulnerability in the FTP-kerberos code in cURL 7.52.0 to 7.65.3.

Remediation

Upgrade Debian:10 curl to version 7.64.0-4+deb10u1 or higher.

References

high severity

Improper Certificate Validation

  • Vulnerable module: curl
  • Introduced through: curl@7.64.0-4, curl/libcurl3-gnutls@7.64.0-4 and others
  • Fixed in: 7.64.0-4+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl3-gnutls@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl4@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl4-openssl-dev@7.64.0-4

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Debian:10 relevant versions.

curl 7.41.0 through 7.73.0 is vulnerable to an improper check for certificate revocation due to insufficient verification of the OCSP response.

Remediation

Upgrade Debian:10 curl to version 7.64.0-4+deb10u2 or higher.

References

high severity

Information Exposure

  • Vulnerable module: curl
  • Introduced through: curl@7.64.0-4, curl/libcurl3-gnutls@7.64.0-4 and others
  • Fixed in: 7.64.0-4+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl3-gnutls@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl4@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl4-openssl-dev@7.64.0-4

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Debian:10 relevant versions.

curl 7.62.0 through 7.70.0 is vulnerable to an information disclosure vulnerability that can lead to a partial password being leaked over the network and to the DNS server(s).

Remediation

Upgrade Debian:10 curl to version 7.64.0-4+deb10u2 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: curl
  • Introduced through: curl@7.64.0-4, curl/libcurl3-gnutls@7.64.0-4 and others
  • Fixed in: 7.64.0-4+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl3-gnutls@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl4@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl4-openssl-dev@7.64.0-4

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Debian:10 relevant versions.

curl 7.21.0 to and including 7.73.0 is vulnerable to uncontrolled recursion due to a stack overflow issue in FTP wildcard match parsing.

Remediation

Upgrade Debian:10 curl to version 7.64.0-4+deb10u2 or higher.

References

high severity

Use After Free

  • Vulnerable module: curl
  • Introduced through: curl@7.64.0-4, curl/libcurl3-gnutls@7.64.0-4 and others
  • Fixed in: 7.64.0-4+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl3-gnutls@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl4@7.64.0-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* curl/libcurl4-openssl-dev@7.64.0-4

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Debian:10 relevant versions.

Due to use of a dangling pointer, libcurl 7.29.0 through 7.71.1 can use the wrong connection when sending data.

Remediation

Upgrade Debian:10 curl to version 7.64.0-4+deb10u2 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: cyrus-sasl2/libsasl2-2
  • Introduced through: cyrus-sasl2/libsasl2-2@2.1.27+dfsg-1 and cyrus-sasl2/libsasl2-modules-db@2.1.27+dfsg-1
  • Fixed in: 2.1.27+dfsg-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* cyrus-sasl2/libsasl2-2@2.1.27+dfsg-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* cyrus-sasl2/libsasl2-modules-db@2.1.27+dfsg-1

NVD Description

Note: Versions mentioned in the description apply to the upstream cyrus-sasl2 package. See Remediation section below for Debian:10 relevant versions.

cyrus-sasl (aka Cyrus SASL) 2.1.27 has an out-of-bounds write leading to unauthenticated remote denial-of-service in OpenLDAP via a malformed LDAP packet. The OpenLDAP crash is ultimately caused by an off-by-one error in _sasl_add_string in common.c in cyrus-sasl.

Remediation

Upgrade Debian:10 cyrus-sasl2 to version 2.1.27+dfsg-1+deb10u1 or higher.

References

high severity

Use After Free

  • Vulnerable module: dbus
  • Introduced through: dbus@1.12.16-1, dbus/dbus-user-session@1.12.16-1 and others
  • Fixed in: 1.12.20-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* dbus@1.12.16-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* dbus/dbus-user-session@1.12.16-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* dbus/libdbus-1-3@1.12.16-1

NVD Description

Note: Versions mentioned in the description apply to the upstream dbus package. See Remediation section below for Debian:10 relevant versions.

A use-after-free flaw was found in D-Bus Development branch <= 1.13.16, dbus-1.12.x stable branch <= 1.12.18, and dbus-1.10.x and older branches <= 1.10.30 when a system has multiple usernames sharing the same UID. When a set of policy rules references these usernames, D-Bus may free some memory in the heap, which is still used by data structures necessary for the other usernames sharing the UID, possibly leading to a crash or other undefined behaviors

Remediation

Upgrade Debian:10 dbus to version 1.12.20-0+deb10u1 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

A flaw was found in djvulibre-3.5.28 and earlier. An integer overflow in function render() in tools/ddjvu via crafted djvu file may lead to application crash and other consequences.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

NULL Pointer Dereference

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

DjVuLibre 3.5.27 has a NULL pointer dereference in the function DJVU::filter_fv at IW44EncodeCodec.cpp.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

Out-of-bounds Read

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

A flaw was found in djvulibre-3.5.28 and earlier. An out of bounds read in function DJVU::DataPool::has_data() via crafted djvu file may lead to application crash and other consequences.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

Out-of-bounds Write

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

A flaw was found in djvulibre-3.5.28 and earlier. A Stack overflow in function DJVU::DjVuDocument::get_djvu_file() via crafted djvu file may lead to application crash and other consequences.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

Out-of-bounds Write

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

A flaw was found in djvulibre-3.5.28 and earlier. An out of bounds write in function DJVU::filter_bv() via crafted djvu file may lead to application crash and other consequences.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

Out-of-bounds Write

  • Vulnerable module: djvulibre/libdjvulibre-dev
  • Introduced through: djvulibre/libdjvulibre-dev@3.5.27.1-10, djvulibre/libdjvulibre-text@3.5.27.1-10 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre-dev@3.5.27.1-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre-text@3.5.27.1-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* djvulibre/libdjvulibre21@3.5.27.1-10

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package.

A flaw was found in djvulibre-3.5.28 and earlier. A heap buffer overflow in function DJVU::GBitmap::decode() via crafted djvu file may lead to application crash and other consequences.

Remediation

There is no fixed version for Debian:10 djvulibre.

References

high severity

Arbitrary Argument Injection

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters, relevant in non-default configurations that enable Delivery Status Notification (DSN). Certain uses of ORCPT= can place a newline into a spool header file, and indirectly allow unauthenticated remote attackers to execute arbitrary commands as root.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Buffer Overflow

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u3

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than CVE-2019-15846. There is a heap-based buffer overflow in string_vformat in string.c involving a long EHLO command.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u3 or higher.

References

high severity

CVE-2020-28015

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters. Local users can alter the behavior of root processes because a recipient address can have a newline character.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

CVE-2020-28021

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 has Improper Neutralization of Line Delimiters. An authenticated remote SMTP client can insert newline characters into a spool file (which indirectly leads to remote code execution as root) via AUTH= in a MAIL FROM command.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Exposure of Resource to Wrong Sphere

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Exposure of File Descriptor to Unintended Control Sphere because rda_interpret uses a privileged pipe that lacks a close-on-exec flag.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Improper Initialization

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 has Improper Initialization that can lead to recursion-based stack consumption or other consequences. This occurs because use of certain getc functions is mishandled when a client uses BDAT instead of DATA.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Improper Privilege Management

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. Because Exim operates as root in the spool directory (owned by a non-root user), an attacker can write to a /var/spool/exim4/input spool header file, in which a crafted recipient address can indirectly lead to command execution.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Integer Overflow to Buffer Overflow because get_stdinput allows unbounded reads that are accompanied by unbounded increases in a certain size variable. NOTE: exploitation may be impractical because of the execution time needed to overflow (multiple days).

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Integer Overflow to Buffer Overflow in receive_add_recipient via an e-mail message with fifty million recipients. NOTE: remote exploitation may be difficult because of resource consumption.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Link Following

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Execution with Unnecessary Privileges. Because Exim operates as root in the log directory (owned by a non-root user), a symlink or hard link attack allows overwriting critical root-owned files anywhere on the filesystem.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-Bounds

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 has Improper Restriction of Write Operations within the Bounds of a Memory Buffer. This occurs when processing name=value pairs within MAIL FROM and RCPT TO commands.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-Bounds

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Buffer Underwrite that may result in unauthenticated remote attackers executing arbitrary commands, because smtp_ungetc was only intended to push back characters, but can actually push back non-character error codes such as EOF.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-Bounds

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim before 4.92.2 allows remote attackers to execute arbitrary code as root via a trailing backslash.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u2 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Out-of-bounds Read. smtp_setup_msg may disclose sensitive information from process memory to an unauthenticated SMTP client.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Out-of-bounds Read because pdkim_finish_bodyhash does not validate the relationship between sig->bodyhash.len and b->bh.len; thus, a crafted DKIM-Signature header might lead to a leak of sensitive information from process memory.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u4

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim through 4.93 has an out-of-bounds read in the SPA authenticator that could result in SPA/NTLM authentication bypass in auths/spa.c and auths/auth-spa.c.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u4 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Out-of-bounds Write because the main function, while setuid root, copies the current working directory pathname into a buffer that is too small (on some common platforms).

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Heap-based Buffer Overflow in queue_run via two sender options: -R and -S. This may cause privilege escalation from exim to root.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Heap-based Buffer Overflow because it mishandles "-F '.('" on the command line, and thus may allow privilege escalation from any user to root. This occurs because of the interpretation of negative sizes in strncpy.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Use After Free

  • Vulnerable module: exim4/exim4-base
  • Introduced through: exim4/exim4-base@4.92-8+deb10u1, exim4/exim4-config@4.92-8+deb10u1 and others
  • Fixed in: 4.92-8+deb10u6

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-base@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-config@4.92-8+deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* exim4/exim4-daemon-light@4.92-8+deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See Remediation section below for Debian:10 relevant versions.

Exim 4 before 4.94.2 allows Use After Free in smtp_reset in certain situations that may be common for builds with OpenSSL.

Remediation

Upgrade Debian:10 exim4 to version 4.92-8+deb10u6 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: expat/libexpat1
  • Introduced through: expat/libexpat1@2.2.6-2 and expat/libexpat1-dev@2.2.6-2
  • Fixed in: 2.2.6-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* expat/libexpat1@2.2.6-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* expat/libexpat1-dev@2.2.6-2

NVD Description

Note: Versions mentioned in the description apply to the upstream expat package. See Remediation section below for Debian:10 relevant versions.

In libexpat before 2.2.8, crafted XML input could fool the parser into changing from DTD parsing to document parsing too early; a consecutive call to XML_GetCurrentLineNumber (or XML_GetCurrentColumnNumber) then resulted in a heap-based buffer over-read.

Remediation

Upgrade Debian:10 expat to version 2.2.6-2+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: file
  • Introduced through: file@1:5.35-4, file/libmagic-mgc@1:5.35-4 and others
  • Fixed in: 1:5.35-4+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* file@1:5.35-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* file/libmagic-mgc@1:5.35-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* file/libmagic1@1:5.35-4

NVD Description

Note: Versions mentioned in the description apply to the upstream file package. See Remediation section below for Debian:10 relevant versions.

cdf_read_property_info in cdf.c in file through 5.37 does not restrict the number of CDF_VECTOR elements, which allows a heap-based buffer overflow (4-byte out-of-bounds write).

Remediation

Upgrade Debian:10 file to version 1:5.35-4+deb10u1 or higher.

References

high severity

Buffer Overflow

  • Vulnerable module: fribidi/libfribidi0
  • Introduced through: fribidi/libfribidi0@1.0.5-3.1
  • Fixed in: 1.0.5-3.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* fribidi/libfribidi0@1.0.5-3.1

NVD Description

Note: Versions mentioned in the description apply to the upstream fribidi package. See Remediation section below for Debian:10 relevant versions.

A buffer overflow in the fribidi_get_par_embedding_levels_ex() function in lib/fribidi-bidi.c of GNU FriBidi through 1.0.7 allows an attacker to cause a denial of service or possibly execute arbitrary code by delivering crafted text content to a user, when this content is then rendered by an application that uses FriBidi for text layout calculations. Examples include any GNOME or GTK+ based application that uses Pango for text layout, as this internally uses FriBidi for bidirectional text layout. For example, the attacker can construct a crafted text file to be opened in GEdit, or a crafted IRC message to be viewed in HexChat.

Remediation

Upgrade Debian:10 fribidi to version 1.0.5-3.1+deb10u1 or higher.

References

high severity

Information Exposure

  • Vulnerable module: gcc-8
  • Introduced through: gcc-8@8.3.0-6, gcc-8/cpp-8@8.3.0-6 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/cpp-8@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/g++-8@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/gcc-8-base@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libasan5@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libatomic1@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libcc1-0@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libgcc-8-dev@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libgcc1@1:8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libgomp1@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libitm1@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/liblsan0@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libmpx2@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libquadmath0@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libstdc++-8-dev@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libstdc++6@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libtsan0@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libubsan1@8.3.0-6

NVD Description

Note: Versions mentioned in the description apply to the upstream gcc-8 package.

stack_protect_prologue in cfgexpand.c and stack_protect_epilogue in function.c in GNU Compiler Collection (GCC) 4.1 through 8 (under certain circumstances) generate instruction sequences when targeting ARM targets that spill the address of the stack protector guard, which allows an attacker to bypass the protection of -fstack-protector, -fstack-protector-all, -fstack-protector-strong, and -fstack-protector-explicit against stack overflow by controlling what the stack canary is compared against.

Remediation

There is no fixed version for Debian:10 gcc-8.

References

high severity

Insufficient Entropy

  • Vulnerable module: gcc-8
  • Introduced through: gcc-8@8.3.0-6, gcc-8/cpp-8@8.3.0-6 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/cpp-8@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/g++-8@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/gcc-8-base@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libasan5@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libatomic1@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libcc1-0@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libgcc-8-dev@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libgcc1@1:8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libgomp1@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libitm1@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/liblsan0@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libmpx2@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libquadmath0@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libstdc++-8-dev@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libstdc++6@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libtsan0@8.3.0-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gcc-8/libubsan1@8.3.0-6

NVD Description

Note: Versions mentioned in the description apply to the upstream gcc-8 package.

The POWER9 backend in GNU Compiler Collection (GCC) before version 10 could optimize multiple calls of the __builtin_darn intrinsic into a single call, thus reducing the entropy of the random number generator. This occurred because a volatile operation was not specified. For example, within a single execution of a program, the output of every __builtin_darn() call may be the same.

Remediation

There is no fixed version for Debian:10 gcc-8.

References

high severity

Out-of-bounds Read

  • Vulnerable module: giflib/libgif7
  • Introduced through: giflib/libgif7@5.1.4-3

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* giflib/libgif7@5.1.4-3

NVD Description

Note: Versions mentioned in the description apply to the upstream giflib package.

An issue was discovered in giflib through 5.1.4. DumpScreen2RGB in gif2rgb.c has a heap-based buffer over-read.

Remediation

There is no fixed version for Debian:10 giflib.

References

high severity

Out-of-bounds Write

  • Vulnerable module: giflib/libgif7
  • Introduced through: giflib/libgif7@5.1.4-3

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* giflib/libgif7@5.1.4-3

NVD Description

Note: Versions mentioned in the description apply to the upstream giflib package.

The DGifDecompressLine function in dgif_lib.c in GIFLIB (possibly version 3.0.x), as later shipped in cgif.c in sam2p 0.49.4, has a heap-based buffer overflow because a certain "Private->RunningCode - 2" array index is not checked. This will lead to a denial of service or possibly unspecified other impact.

Remediation

There is no fixed version for Debian:10 giflib.

References

high severity

Out-of-bounds Write

  • Vulnerable module: giflib/libgif7
  • Introduced through: giflib/libgif7@5.1.4-3

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* giflib/libgif7@5.1.4-3

NVD Description

Note: Versions mentioned in the description apply to the upstream giflib package.

The DGifDecompressLine function in dgif_lib.c in GIFLIB (possibly version 3.0.x), as later shipped in cgif.c in sam2p 0.49.4, has a heap-based buffer overflow because a certain CrntCode array index is not checked. This will lead to a denial of service or possibly unspecified other impact.

Remediation

There is no fixed version for Debian:10 giflib.

References

high severity

CVE-2019-1353

  • Vulnerable module: git
  • Introduced through: git@1:2.20.1-2 and git/git-man@1:2.20.1-2
  • Fixed in: 1:2.20.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git@1:2.20.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git/git-man@1:2.20.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream git package. See Remediation section below for Debian:10 relevant versions.

An issue was found in Git before v2.24.1, v2.23.1, v2.22.2, v2.21.1, v2.20.2, v2.19.3, v2.18.2, v2.17.3, v2.16.6, v2.15.4, and v2.14.6. When running Git in the Windows Subsystem for Linux (also known as "WSL") while accessing a working directory on a regular Windows drive, none of the NTFS protections were active.

Remediation

Upgrade Debian:10 git to version 1:2.20.1-2+deb10u1 or higher.

References

high severity

Improper Input Validation

  • Vulnerable module: git
  • Introduced through: git@1:2.20.1-2 and git/git-man@1:2.20.1-2
  • Fixed in: 1:2.20.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git@1:2.20.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git/git-man@1:2.20.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream git package. See Remediation section below for Debian:10 relevant versions.

A remote code execution vulnerability exists when Git for Visual Studio improperly sanitizes input, aka 'Git for Visual Studio Remote Code Execution Vulnerability'. This CVE ID is unique from CVE-2019-1349, CVE-2019-1352, CVE-2019-1354, CVE-2019-1387.

Remediation

Upgrade Debian:10 git to version 1:2.20.1-2+deb10u1 or higher.

References

high severity

Improper Input Validation

  • Vulnerable module: git
  • Introduced through: git@1:2.20.1-2 and git/git-man@1:2.20.1-2
  • Fixed in: 1:2.20.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git@1:2.20.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git/git-man@1:2.20.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream git package. See Remediation section below for Debian:10 relevant versions.

Arbitrary command execution is possible in Git before 2.20.2, 2.21.x before 2.21.1, 2.22.x before 2.22.2, 2.23.x before 2.23.1, and 2.24.x before 2.24.1 because a "git submodule update" operation can run commands found in the .gitmodules file of a malicious repository.

Remediation

Upgrade Debian:10 git to version 1:2.20.1-2+deb10u1 or higher.

References

high severity

Improper Input Validation

  • Vulnerable module: git
  • Introduced through: git@1:2.20.1-2 and git/git-man@1:2.20.1-2
  • Fixed in: 1:2.20.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git@1:2.20.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git/git-man@1:2.20.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream git package. See Remediation section below for Debian:10 relevant versions.

A remote code execution vulnerability exists when Git for Visual Studio improperly sanitizes input, aka 'Git for Visual Studio Remote Code Execution Vulnerability'. This CVE ID is unique from CVE-2019-1349, CVE-2019-1350, CVE-2019-1352, CVE-2019-1387.

Remediation

Upgrade Debian:10 git to version 1:2.20.1-2+deb10u1 or higher.

References

high severity

Improper Input Validation

  • Vulnerable module: git
  • Introduced through: git@1:2.20.1-2 and git/git-man@1:2.20.1-2
  • Fixed in: 1:2.20.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git@1:2.20.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git/git-man@1:2.20.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream git package. See Remediation section below for Debian:10 relevant versions.

An issue was found in Git before v2.24.1, v2.23.1, v2.22.2, v2.21.1, v2.20.2, v2.19.3, v2.18.2, v2.17.3, v2.16.6, v2.15.4, and v2.14.6. Recursive clones are currently affected by a vulnerability that is caused by too-lax validation of submodule names, allowing very targeted attacks via remote code execution in recursive clones.

Remediation

Upgrade Debian:10 git to version 1:2.20.1-2+deb10u1 or higher.

References

high severity

Improper Input Validation

  • Vulnerable module: git
  • Introduced through: git@1:2.20.1-2 and git/git-man@1:2.20.1-2
  • Fixed in: 1:2.20.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git@1:2.20.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git/git-man@1:2.20.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream git package. See Remediation section below for Debian:10 relevant versions.

A remote code execution vulnerability exists when Git for Visual Studio improperly sanitizes input, aka 'Git for Visual Studio Remote Code Execution Vulnerability'. This CVE ID is unique from CVE-2019-1350, CVE-2019-1352, CVE-2019-1354, CVE-2019-1387.

Remediation

Upgrade Debian:10 git to version 1:2.20.1-2+deb10u1 or higher.

References

high severity

Improper Input Validation

  • Vulnerable module: git
  • Introduced through: git@1:2.20.1-2 and git/git-man@1:2.20.1-2
  • Fixed in: 1:2.20.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git@1:2.20.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git/git-man@1:2.20.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream git package. See Remediation section below for Debian:10 relevant versions.

A remote code execution vulnerability exists when Git for Visual Studio improperly sanitizes input, aka 'Git for Visual Studio Remote Code Execution Vulnerability'. This CVE ID is unique from CVE-2019-1349, CVE-2019-1350, CVE-2019-1354, CVE-2019-1387.

Remediation

Upgrade Debian:10 git to version 1:2.20.1-2+deb10u1 or higher.

References

high severity

Insufficiently Protected Credentials

  • Vulnerable module: git
  • Introduced through: git@1:2.20.1-2 and git/git-man@1:2.20.1-2
  • Fixed in: 1:2.20.1-2+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git@1:2.20.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git/git-man@1:2.20.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream git package. See Remediation section below for Debian:10 relevant versions.

Affected versions of Git have a vulnerability whereby Git can be tricked into sending private credentials to a host controlled by an attacker. Git uses external "credential helper" programs to store and retrieve passwords or other credentials from secure storage provided by the operating system. Specially-crafted URLs that contain an encoded newline can inject unintended values into the credential helper protocol stream, causing the credential helper to retrieve the password for one server (e.g., good.example.com) for an HTTP request being made to another server (e.g., evil.example.com), resulting in credentials for the former being sent to the latter. There are no restrictions on the relationship between the two, meaning that an attacker can craft a URL that will present stored credentials for any host to a host of their choosing. The vulnerability can be triggered by feeding a malicious URL to git clone. However, the affected URLs look rather suspicious; the likely vector would be through systems which automatically clone URLs not visible to the user, such as Git submodules, or package systems built around Git. The problem has been patched in the versions published on April 14th, 2020, going back to v2.17.x. Anyone wishing to backport the change further can do so by applying commit 9a6bbee (the full release includes extra checks for git fsck, but that commit is sufficient to protect clients against the vulnerability). The patched versions are: 2.17.4, 2.18.3, 2.19.4, 2.20.3, 2.21.2, 2.22.3, 2.23.2, 2.24.2, 2.25.3, 2.26.1.

Remediation

Upgrade Debian:10 git to version 1:2.20.1-2+deb10u2 or higher.

References

high severity

Insufficiently Protected Credentials

  • Vulnerable module: git
  • Introduced through: git@1:2.20.1-2 and git/git-man@1:2.20.1-2
  • Fixed in: 1:2.20.1-2+deb10u3

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git@1:2.20.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git/git-man@1:2.20.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream git package. See Remediation section below for Debian:10 relevant versions.

Affected versions of Git have a vulnerability whereby Git can be tricked into sending private credentials to a host controlled by an attacker. This bug is similar to CVE-2020-5260(GHSA-qm7j-c969-7j4q). The fix for that bug still left the door open for an exploit where some credential is leaked (but the attacker cannot control which one). Git uses external "credential helper" programs to store and retrieve passwords or other credentials from secure storage provided by the operating system. Specially-crafted URLs that are considered illegal as of the recently published Git versions can cause Git to send a "blank" pattern to helpers, missing hostname and protocol fields. Many helpers will interpret this as matching any URL, and will return some unspecified stored password, leaking the password to an attacker's server. The vulnerability can be triggered by feeding a malicious URL to git clone. However, the affected URLs look rather suspicious; the likely vector would be through systems which automatically clone URLs not visible to the user, such as Git submodules, or package systems built around Git. The root of the problem is in Git itself, which should not be feeding blank input to helpers. However, the ability to exploit the vulnerability in practice depends on which helpers are in use. Credential helpers which are known to trigger the vulnerability: - Git's "store" helper - Git's "cache" helper - the "osxkeychain" helper that ships in Git's "contrib" directory Credential helpers which are known to be safe even with vulnerable versions of Git: - Git Credential Manager for Windows Any helper not in this list should be assumed to trigger the vulnerability.

Remediation

Upgrade Debian:10 git to version 1:2.20.1-2+deb10u3 or higher.

References

high severity

Link Following

  • Vulnerable module: git
  • Introduced through: git@1:2.20.1-2 and git/git-man@1:2.20.1-2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git@1:2.20.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git/git-man@1:2.20.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream git package.

Git is an open-source distributed revision control system. In affected versions of Git a specially crafted repository that contains symbolic links as well as files using a clean/smudge filter such as Git LFS, may cause just-checked out script to be executed while cloning onto a case-insensitive file system such as NTFS, HFS+ or APFS (i.e. the default file systems on Windows and macOS). Note that clean/smudge filters have to be configured for that. Git for Windows configures Git LFS by default, and is therefore vulnerable. The problem has been patched in the versions published on Tuesday, March 9th, 2021. As a workaound, if symbolic link support is disabled in Git (e.g. via git config --global core.symlinks false), the described attack won't work. Likewise, if no clean/smudge filters such as Git LFS are configured globally (i.e. before cloning), the attack is foiled. As always, it is best to avoid cloning repositories from untrusted sources. The earliest impacted version is 2.14.2. The fix versions are: 2.30.1, 2.29.3, 2.28.1, 2.27.1, 2.26.3, 2.25.5, 2.24.4, 2.23.4, 2.22.5, 2.21.4, 2.20.5, 2.19.6, 2.18.5, 2.17.62.17.6.

Remediation

There is no fixed version for Debian:10 git.

References

high severity

Use of Incorrectly-Resolved Name or Reference

  • Vulnerable module: git
  • Introduced through: git@1:2.20.1-2 and git/git-man@1:2.20.1-2
  • Fixed in: 1:2.20.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git@1:2.20.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* git/git-man@1:2.20.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream git package. See Remediation section below for Debian:10 relevant versions.

A tampering vulnerability exists when Git for Visual Studio improperly handles virtual drive paths, aka 'Git for Visual Studio Tampering Vulnerability'.

Remediation

Upgrade Debian:10 git to version 1:2.20.1-2+deb10u1 or higher.

References

high severity

Incorrect Conversion between Numeric Types

  • Vulnerable module: glib2.0/libglib2.0-0
  • Introduced through: glib2.0/libglib2.0-0@2.58.3-2, glib2.0/libglib2.0-bin@2.58.3-2 and others
  • Fixed in: 2.58.3-2+deb10u3

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glib2.0/libglib2.0-0@2.58.3-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glib2.0/libglib2.0-bin@2.58.3-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glib2.0/libglib2.0-data@2.58.3-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glib2.0/libglib2.0-dev@2.58.3-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glib2.0/libglib2.0-dev-bin@2.58.3-2

NVD Description

Note: Versions mentioned in the description apply to the upstream glib2.0 package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in GNOME GLib before 2.66.7 and 2.67.x before 2.67.4. If g_byte_array_new_take() was called with a buffer of 4GB or more on a 64-bit platform, the length would be truncated modulo 2**32, causing unintended length truncation.

Remediation

Upgrade Debian:10 glib2.0 to version 2.58.3-2+deb10u3 or higher.

References

high severity

Incorrect Conversion between Numeric Types

  • Vulnerable module: glib2.0/libglib2.0-0
  • Introduced through: glib2.0/libglib2.0-0@2.58.3-2, glib2.0/libglib2.0-bin@2.58.3-2 and others
  • Fixed in: 2.58.3-2+deb10u3

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glib2.0/libglib2.0-0@2.58.3-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glib2.0/libglib2.0-bin@2.58.3-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glib2.0/libglib2.0-data@2.58.3-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glib2.0/libglib2.0-dev@2.58.3-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glib2.0/libglib2.0-dev-bin@2.58.3-2

NVD Description

Note: Versions mentioned in the description apply to the upstream glib2.0 package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in GNOME GLib before 2.66.6 and 2.67.x before 2.67.3. The function g_bytes_new has an integer overflow on 64-bit platforms due to an implicit cast from 64 bits to 32 bits. The overflow could potentially lead to memory corruption.

Remediation

Upgrade Debian:10 glib2.0 to version 2.58.3-2+deb10u3 or higher.

References

high severity

Incorrect Permission Assignment for Critical Resource

  • Vulnerable module: glib2.0/libglib2.0-0
  • Introduced through: glib2.0/libglib2.0-0@2.58.3-2, glib2.0/libglib2.0-bin@2.58.3-2 and others
  • Fixed in: 2.58.3-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glib2.0/libglib2.0-0@2.58.3-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glib2.0/libglib2.0-bin@2.58.3-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glib2.0/libglib2.0-data@2.58.3-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glib2.0/libglib2.0-dev@2.58.3-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glib2.0/libglib2.0-dev-bin@2.58.3-2

NVD Description

Note: Versions mentioned in the description apply to the upstream glib2.0 package. See Remediation section below for Debian:10 relevant versions.

The keyfile settings backend in GNOME GLib (aka glib2.0) before 2.60.0 creates directories using g_file_make_directory_with_parents (kfsb->dir, NULL, NULL) and files using g_file_replace_contents (kfsb->file, contents, length, NULL, FALSE, G_FILE_CREATE_REPLACE_DESTINATION, NULL, NULL, NULL). Consequently, it does not properly restrict directory (and file) permissions. Instead, for directories, 0777 permissions are used; for files, default file permissions are used. This is similar to CVE-2019-12450.

Remediation

Upgrade Debian:10 glib2.0 to version 2.58.3-2+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

An out-of-bounds write vulnerability was found in glibc before 2.31 when handling signal trampolines on PowerPC. Specifically, the backtrace function did not properly check the array bounds when storing the frame address, resulting in a denial of service or potential code execution. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 glibc.

References

high severity

Reachable Assertion

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The iconv function in the GNU C Library (aka glibc or libc6) 2.32 and earlier, when processing invalid input sequences in the ISO-2022-JP-3 encoding, fails an assertion in the code path and aborts the program, potentially resulting in a denial of service.

Remediation

There is no fixed version for Debian:10 glibc.

References

high severity

Use After Free

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

The mq_notify function in the GNU C Library (aka glibc) versions 2.32 and 2.33 has a use-after-free. It may use the notification thread attributes object (passed through its struct sigevent parameter) after it has been freed by the caller, leading to a denial of service (application crash) or possibly unspecified other impact.

Remediation

There is no fixed version for Debian:10 glibc.

References

high severity

Use After Free

  • Vulnerable module: glibc/libc-bin
  • Introduced through: glibc/libc-bin@2.28-10, glibc/libc-dev-bin@2.28-10 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc-bin@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc-dev-bin@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc-l10n@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc6@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/libc6-dev@2.28-10
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* glibc/locales@2.28-10

NVD Description

Note: Versions mentioned in the description apply to the upstream glibc package.

A use-after-free vulnerability introduced in glibc upstream version 2.14 was found in the way the tilde expansion was carried out. Directory paths containing an initial tilde followed by a valid username were affected by this issue. A local attacker could exploit this flaw by creating a specially crafted path that, when processed by the glob function, would potentially lead to arbitrary code execution. This was fixed in version 2.32.

Remediation

There is no fixed version for Debian:10 glibc.

References

high severity

Out-of-bounds Write

  • Vulnerable module: gnutls28/libgnutls-dane0
  • Introduced through: gnutls28/libgnutls-dane0@3.6.7-4, gnutls28/libgnutls-openssl27@3.6.7-4 and others
  • Fixed in: 3.6.7-4+deb10u7

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls-dane0@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls-openssl27@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls28-dev@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls30@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutlsxx28@3.6.7-4

NVD Description

Note: Versions mentioned in the description apply to the upstream gnutls28 package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in GnuTLS before 3.6.15. A server can trigger a NULL pointer dereference in a TLS 1.3 client if a no_renegotiation alert is sent with unexpected timing, and then an invalid second handshake occurs. The crash happens in the application's error handling path, where the gnutls_deinit function is called after detecting a handshake failure.

Remediation

Upgrade Debian:10 gnutls28 to version 3.6.7-4+deb10u7 or higher.

References

high severity

Use After Free

  • Vulnerable module: gnutls28/libgnutls-dane0
  • Introduced through: gnutls28/libgnutls-dane0@3.6.7-4, gnutls28/libgnutls-openssl27@3.6.7-4 and others
  • Fixed in: 3.6.7-4+deb10u7

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls-dane0@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls-openssl27@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls28-dev@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls30@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutlsxx28@3.6.7-4

NVD Description

Note: Versions mentioned in the description apply to the upstream gnutls28 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in gnutls. A use after free issue in client sending key_share extension may lead to memory corruption and other consequences.

Remediation

Upgrade Debian:10 gnutls28 to version 3.6.7-4+deb10u7 or higher.

References

high severity

Use After Free

  • Vulnerable module: gnutls28/libgnutls-dane0
  • Introduced through: gnutls28/libgnutls-dane0@3.6.7-4, gnutls28/libgnutls-openssl27@3.6.7-4 and others
  • Fixed in: 3.6.7-4+deb10u7

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls-dane0@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls-openssl27@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls28-dev@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls30@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutlsxx28@3.6.7-4

NVD Description

Note: Versions mentioned in the description apply to the upstream gnutls28 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in gnutls. A use after free issue in client_send_params in lib/ext/pre_shared_key.c may lead to memory corruption and other potential consequences.

Remediation

Upgrade Debian:10 gnutls28 to version 3.6.7-4+deb10u7 or higher.

References

high severity

Use of a Broken or Risky Cryptographic Algorithm

  • Vulnerable module: gnutls28/libgnutls-dane0
  • Introduced through: gnutls28/libgnutls-dane0@3.6.7-4, gnutls28/libgnutls-openssl27@3.6.7-4 and others
  • Fixed in: 3.6.7-4+deb10u3

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls-dane0@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls-openssl27@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls28-dev@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls30@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutlsxx28@3.6.7-4

NVD Description

Note: Versions mentioned in the description apply to the upstream gnutls28 package. See Remediation section below for Debian:10 relevant versions.

GnuTLS 3.6.x before 3.6.13 uses incorrect cryptography for DTLS. The earliest affected version is 3.6.3 (2018-07-16) because of an error in a 2017-10-06 commit. The DTLS client always uses 32 '\0' bytes instead of a random value, and thus contributes no randomness to a DTLS negotiation. This breaks the security guarantees of the DTLS protocol.

Remediation

Upgrade Debian:10 gnutls28 to version 3.6.7-4+deb10u3 or higher.

References

high severity

Use of a Broken or Risky Cryptographic Algorithm

  • Vulnerable module: gnutls28/libgnutls-dane0
  • Introduced through: gnutls28/libgnutls-dane0@3.6.7-4, gnutls28/libgnutls-openssl27@3.6.7-4 and others
  • Fixed in: 3.6.7-4+deb10u4

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls-dane0@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls-openssl27@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls28-dev@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutls30@3.6.7-4
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* gnutls28/libgnutlsxx28@3.6.7-4

NVD Description

Note: Versions mentioned in the description apply to the upstream gnutls28 package. See Remediation section below for Debian:10 relevant versions.

GnuTLS 3.6.x before 3.6.14 uses incorrect cryptography for encrypting a session ticket (a loss of confidentiality in TLS 1.2, and an authentication bypass in TLS 1.3). The earliest affected version is 3.6.4 (2018-09-24) because of an error in a 2018-09-18 commit. Until the first key rotation, the TLS server always uses wrong data in place of an encryption key derived from an application.

Remediation

Upgrade Debian:10 gnutls28 to version 3.6.7-4+deb10u4 or higher.

References

high severity

Double Free

  • Vulnerable module: icu/icu-devtools
  • Introduced through: icu/icu-devtools@63.1-6, icu/libicu-dev@63.1-6 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* icu/icu-devtools@63.1-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* icu/libicu-dev@63.1-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* icu/libicu63@63.1-6

NVD Description

Note: Versions mentioned in the description apply to the upstream icu package.

Double free in ICU in Google Chrome prior to 91.0.4472.77 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

Remediation

There is no fixed version for Debian:10 icu.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: icu/icu-devtools
  • Introduced through: icu/icu-devtools@63.1-6, icu/libicu-dev@63.1-6 and others
  • Fixed in: 63.1-6+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* icu/icu-devtools@63.1-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* icu/libicu-dev@63.1-6
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* icu/libicu63@63.1-6

NVD Description

Note: Versions mentioned in the description apply to the upstream icu package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in International Components for Unicode (ICU) for C/C++ through 66.1. An integer overflow, leading to a heap-based buffer overflow, exists in the UnicodeString::doAppend() function in common/unistr.cpp.

Remediation

Upgrade Debian:10 icu to version 63.1-6+deb10u1 or higher.

References

high severity

Divide By Zero

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in versions before 7.0.11 and before 6.9.12, where a division by zero in WaveImage() of MagickCore/visual-effects.c may trigger undefined behavior via a crafted image file submitted to an application using ImageMagick. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Improper Initialization

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

ImageMagick 7.0.8-34 has a "use of uninitialized value" vulnerability in the ReadPANGOImage function in coders/pango.c.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Improper Initialization

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

ImageMagick 7.0.8-34 has a "use of uninitialized value" vulnerability in the WriteJP2Image function in coders/jp2.c.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Improper Initialization

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

ImageMagick 7.0.8-34 has a "use of uninitialized value" vulnerability in the SyncImageSettings function in MagickCore/image.c. This is related to AcquireImage in magick/image.c.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Information Exposure

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in versions before 7.0.11. A potential cipher leak when the calculate signatures in TransformSignature is possible. The highest threat from this vulnerability is to data confidentiality.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in MagickCore/statistic.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of values outside the range of type unsigned long. This would most likely lead to an impact to application availability, but could potentially cause other problems related to undefined behavior. This flaw affects ImageMagick versions prior to 7.0.8-69.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in versions 7.0.11, where an integer overflow in WriteTHUMBNAILImage of coders/thumbnail.c may trigger undefined behavior via a crafted image file that is submitted by an attacker and processed by an application using ImageMagick. The highest threat from this vulnerability is to system availability.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Memory Leak

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

In ImageMagick before 7.0.8-25, some memory leaks exist in DecodeImage in coders/pcd.c.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Memory Leak

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

In ImageMagick before 7.0.8-25, a memory leak exists in ReadSIXELImage in coders/sixel.c.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Memory Leak

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

In ImageMagick before 7.0.8-25 and GraphicsMagick through 1.3.31, several memory leaks exist in WritePDFImage in coders/pdf.c.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Memory Leak

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

In ImageMagick before 7.0.8-25, a memory leak exists in WritePSDChannel in coders/psd.c.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Memory Leak

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

In ImageMagick before 7.0.8-25, a memory leak exists in WriteDIBImage in coders/dib.c.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

In ImageMagick 7.0.8-40 Q16, there is a heap-based buffer over-read in the function WritePNMImage of coders/pnm.c, which allows an attacker to cause a denial of service or possibly information disclosure via a crafted image file. This is related to SetGrayscaleImage in MagickCore/quantize.c.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

In ImageMagick 7.0.8-43 Q16, there is a heap-based buffer over-read in the function WriteTIFFImage of coders/tiff.c, which allows an attacker to cause a denial of service or possibly information disclosure via a crafted image file.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

In ImageMagick 7.0.8-50 Q16, ComplexImages in MagickCore/fourier.c has a heap-based buffer over-read because of incorrect calls to GetCacheViewVirtualPixels.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

ImageMagick 7.0.8-50 Q16 has a heap-based buffer over-read at MagickCore/threshold.c in AdaptiveThresholdImage because a width of zero is mishandled.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

ImageMagick 7.0.8-50 Q16 has a heap-based buffer over-read at MagickCore/threshold.c in AdaptiveThresholdImage because a height of zero is mishandled.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

In ImageMagick 7.0.8-43 Q16, there is a heap-based buffer over-read in the function WritePNGImage of coders/png.c, related to Magick_png_write_raw_profile and LocaleNCompare.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

Stack-based buffer overflow and unconditional jump in ReadXPMImage in coders/xpm.c in ImageMagick 7.0.10-7.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Out-of-bounds Write

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

A flaw was found in ImageMagick in MagickCore/quantum-private.h. An attacker who submits a crafted file that is processed by ImageMagick could trigger a heap buffer overflow. This would most likely lead to an impact to application availability, but could potentially lead to an impact to data integrity as well. This flaw affects ImageMagick versions prior to 7.0.9-0.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Out-of-bounds Write

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

ImageMagick 7.0.8-50 Q16 has a heap-based buffer overflow in MagickCore/fourier.c in ComplexImage.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

ImageMagick 7.0.8-50 Q16 has a stack-based buffer overflow at coders/pnm.c in WritePNMImage because of off-by-one errors.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

ImageMagick 7.0.8-50 Q16 has a heap-based buffer overflow at MagickCore/statistic.c in EvaluateImages because of mishandling columns.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

ImageMagick 7.0.8-50 Q16 has a heap-based buffer overflow at MagickCore/statistic.c in EvaluateImages because of mishandling rows.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

ImageMagick 7.0.8-50 Q16 has a stack-based buffer overflow at coders/pnm.c in WritePNMImage because of a misplaced assignment.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

ImageMagick 7.0.8-50 Q16 has a stack-based buffer overflow at coders/pnm.c in WritePNMImage because of a misplaced strncpy and an off-by-one error.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

In ImageMagick 7.0.8-43 Q16, there is a heap-based buffer overflow in the function WriteSGIImage of coders/sgi.c.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Use After Free

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

coders/mat.c in ImageMagick 7.0.8-43 Q16 allows remote attackers to cause a denial of service (use-after-free and application crash) or possibly have unspecified other impact by crafting a Matlab image file that is mishandled in ReadImage in MagickCore/constitute.c.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

Use of Uninitialized Resource

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others
  • Fixed in: 8:6.9.10.23+dfsg-2.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package. See Remediation section below for Debian:10 relevant versions.

ImageMagick before 7.0.8-50 has a "use of uninitialized value" vulnerability in the function ReadCUTImage in coders/cut.c.

Remediation

Upgrade Debian:10 imagemagick to version 8:6.9.10.23+dfsg-2.1+deb10u1 or higher.

References

high severity

XML Injection

  • Vulnerable module: imagemagick
  • Introduced through: imagemagick@8:6.9.10.23+dfsg-2.1, imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1 and others

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6-common@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/imagemagick-6.q16@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-arch-config@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-6-extra@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickcore-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6-headers@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-6@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-6.q16-dev@8:6.9.10.23+dfsg-2.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* imagemagick/libmagickwand-dev@8:6.9.10.23+dfsg-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream imagemagick package.

ImageMagick before 6.9.11-40 and 7.x before 7.0.10-40 mishandles the -authenticate option, which allows setting a password for password-protected PDF files. The user-controlled password was not properly escaped/sanitized and it was therefore possible to inject additional shell commands via coders/pdf.c.

Remediation

There is no fixed version for Debian:10 imagemagick.

References

high severity

Out-of-bounds Write

  • Vulnerable module: json-c/libjson-c3
  • Introduced through: json-c/libjson-c3@0.12.1+ds-2
  • Fixed in: 0.12.1+ds-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* json-c/libjson-c3@0.12.1+ds-2

NVD Description

Note: Versions mentioned in the description apply to the upstream json-c package. See Remediation section below for Debian:10 relevant versions.

json-c through 0.14 has an integer overflow and out-of-bounds write via a large JSON file, as demonstrated by printbuf_memappend.

Remediation

Upgrade Debian:10 json-c to version 0.12.1+ds-2+deb10u1 or higher.

References

high severity

Uncontrolled Recursion

  • Vulnerable module: krb5/krb5-multidev
  • Introduced through: krb5/krb5-multidev@1.17-3, krb5/libgssapi-krb5-2@1.17-3 and others
  • Fixed in: 1.17-3+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* krb5/krb5-multidev@1.17-3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* krb5/libgssapi-krb5-2@1.17-3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* krb5/libgssrpc4@1.17-3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* krb5/libk5crypto3@1.17-3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* krb5/libkadm5clnt-mit11@1.17-3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* krb5/libkadm5srv-mit11@1.17-3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* krb5/libkdb5-9@1.17-3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* krb5/libkrb5-3@1.17-3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* krb5/libkrb5-dev@1.17-3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* krb5/libkrb5support0@1.17-3

NVD Description

Note: Versions mentioned in the description apply to the upstream krb5 package. See Remediation section below for Debian:10 relevant versions.

MIT Kerberos 5 (aka krb5) before 1.17.2 and 1.18.x before 1.18.3 allows unbounded recursion via an ASN.1-encoded Kerberos message because the lib/krb5/asn.1/asn1_encode.c support for BER indefinite lengths lacks a recursion limit.

Remediation

Upgrade Debian:10 krb5 to version 1.17-3+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libbsd/libbsd0
  • Introduced through: libbsd/libbsd0@0.9.1-2
  • Fixed in: 0.9.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libbsd/libbsd0@0.9.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libbsd package. See Remediation section below for Debian:10 relevant versions.

nlist.c in libbsd before 0.10.0 has an out-of-bounds read during a comparison for a symbol name from the string table (strtab).

Remediation

Upgrade Debian:10 libbsd to version 0.9.1-2+deb10u1 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: libexif/libexif-dev
  • Introduced through: libexif/libexif-dev@0.6.21-5.1 and libexif/libexif12@0.6.21-5.1
  • Fixed in: 0.6.21-5.1+deb10u5

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libexif/libexif-dev@0.6.21-5.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libexif/libexif12@0.6.21-5.1

NVD Description

Note: Versions mentioned in the description apply to the upstream libexif package. See Remediation section below for Debian:10 relevant versions.

In exif_entry_get_value of exif-entry.c, there is a possible out of bounds write due to an integer overflow. This could lead to remote code execution if a third party app used this library to process remote image data with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-8.1 Android-9 Android-10 Android-11 Android-8.0Android ID: A-159625731

Remediation

Upgrade Debian:10 libexif to version 0.6.21-5.1+deb10u5 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: libexif/libexif-dev
  • Introduced through: libexif/libexif-dev@0.6.21-5.1 and libexif/libexif12@0.6.21-5.1
  • Fixed in: 0.6.21-5.1+deb10u4

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libexif/libexif-dev@0.6.21-5.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libexif/libexif12@0.6.21-5.1

NVD Description

Note: Versions mentioned in the description apply to the upstream libexif package. See Remediation section below for Debian:10 relevant versions.

In exif_data_load_data_content of exif-data.c, there is a possible UBSAN abort due to an integer overflow. This could lead to remote denial of service with no additional execution privileges needed. User interaction is needed for exploitation.Product: AndroidVersions: Android-10Android ID: A-146428941

Remediation

Upgrade Debian:10 libexif to version 0.6.21-5.1+deb10u4 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: libexif/libexif-dev
  • Introduced through: libexif/libexif-dev@0.6.21-5.1 and libexif/libexif12@0.6.21-5.1
  • Fixed in: 0.6.21-5.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libexif/libexif-dev@0.6.21-5.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libexif/libexif12@0.6.21-5.1

NVD Description

Note: Versions mentioned in the description apply to the upstream libexif package. See Remediation section below for Debian:10 relevant versions.

In exif_data_load_data_thumbnail of exif-data.c, there is a possible denial of service due to an integer overflow. This could lead to remote denial of service with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-10Android ID: A-145075076

Remediation

Upgrade Debian:10 libexif to version 0.6.21-5.1+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libexif/libexif-dev
  • Introduced through: libexif/libexif-dev@0.6.21-5.1 and libexif/libexif12@0.6.21-5.1
  • Fixed in: 0.6.21-5.1+deb10u3

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libexif/libexif-dev@0.6.21-5.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libexif/libexif12@0.6.21-5.1

NVD Description

Note: Versions mentioned in the description apply to the upstream libexif package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in libexif before 0.6.22. Several buffer over-reads in EXIF MakerNote handling could lead to information disclosure and crashes. This is different from CVE-2020-0093.

Remediation

Upgrade Debian:10 libexif to version 0.6.21-5.1+deb10u3 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: libexif/libexif-dev
  • Introduced through: libexif/libexif-dev@0.6.21-5.1 and libexif/libexif12@0.6.21-5.1
  • Fixed in: 0.6.21-5.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libexif/libexif-dev@0.6.21-5.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libexif/libexif12@0.6.21-5.1

NVD Description

Note: Versions mentioned in the description apply to the upstream libexif package. See Remediation section below for Debian:10 relevant versions.

In libexif, there is a possible out of bounds write due to an integer overflow. This could lead to remote escalation of privilege in the media content provider with no additional execution privileges needed. User interaction is needed for exploitation. Product: AndroidVersions: Android-10Android ID: A-112537774

Remediation

Upgrade Debian:10 libexif to version 0.6.21-5.1+deb10u1 or higher.

References

high severity

Resource Exhaustion

  • Vulnerable module: libexif/libexif-dev
  • Introduced through: libexif/libexif-dev@0.6.21-5.1 and libexif/libexif12@0.6.21-5.1
  • Fixed in: 0.6.21-5.1+deb10u3

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libexif/libexif-dev@0.6.21-5.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libexif/libexif12@0.6.21-5.1

NVD Description

Note: Versions mentioned in the description apply to the upstream libexif package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in libexif before 0.6.22. An unrestricted size in handling Canon EXIF MakerNote data could lead to consumption of large amounts of compute time for decoding EXIF data.

Remediation

Upgrade Debian:10 libexif to version 0.6.21-5.1+deb10u3 or higher.

References

high severity

Use After Free

  • Vulnerable module: libexif/libexif-dev
  • Introduced through: libexif/libexif-dev@0.6.21-5.1 and libexif/libexif12@0.6.21-5.1
  • Fixed in: 0.6.21-5.1+deb10u3

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libexif/libexif-dev@0.6.21-5.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libexif/libexif12@0.6.21-5.1

NVD Description

Note: Versions mentioned in the description apply to the upstream libexif package. See Remediation section below for Debian:10 relevant versions.

An issue was discovered in libexif before 0.6.22. Use of uninitialized memory in EXIF Makernote handling could lead to crashes and potential use-after-free conditions.

Remediation

Upgrade Debian:10 libexif to version 0.6.21-5.1+deb10u3 or higher.

References

high severity

Information Exposure

  • Vulnerable module: libgcrypt20
  • Introduced through: libgcrypt20@1.8.4-5
  • Fixed in: 1.8.4-5+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libgcrypt20@1.8.4-5

NVD Description

Note: Versions mentioned in the description apply to the upstream libgcrypt20 package. See Remediation section below for Debian:10 relevant versions.

Libgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption because it lacks exponent blinding to address a side-channel attack against mpi_powm, and the window size is not chosen appropriately. (There is also an interoperability problem because the selection of the k integer value does not properly consider the differences between basic ElGamal encryption and generalized ElGamal encryption.) This, for example, affects use of ElGamal in OpenPGP.

Remediation

Upgrade Debian:10 libgcrypt20 to version 1.8.4-5+deb10u1 or higher.

References

high severity
new

CVE-2020-19498

  • Vulnerable module: libheif/libheif1
  • Introduced through: libheif/libheif1@1.3.2-2~deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libheif/libheif1@1.3.2-2~deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream libheif package.

Floating point exception in function Fraction in libheif 1.4.0, allows attackers to cause a Denial of Service or possibly other unspecified impacts.

Remediation

There is no fixed version for Debian:10 libheif.

References

high severity
new

Out-of-bounds Read

  • Vulnerable module: libheif/libheif1
  • Introduced through: libheif/libheif1@1.3.2-2~deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libheif/libheif1@1.3.2-2~deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream libheif package.

An issue was discovered in heif::Box_iref::get_references in libheif 1.4.0, allows attackers to cause a Denial of Service or possibly other unspecified impact due to an invalid memory read.

Remediation

There is no fixed version for Debian:10 libheif.

References

high severity

Improper Input Validation

  • Vulnerable module: libidn2/libidn2-0
  • Introduced through: libidn2/libidn2-0@2.0.5-1 and libidn2/libidn2-dev@2.0.5-1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libidn2/libidn2-0@2.0.5-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libidn2/libidn2-dev@2.0.5-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libidn2 package.

GNU libidn2 before 2.2.0 fails to perform the roundtrip checks specified in RFC3490 Section 4.2 when converting A-labels to U-labels. This makes it possible in some circumstances for one domain to impersonate another. By creating a malicious domain that matches a target domain except for the inclusion of certain punycoded Unicode characters (that would be discarded when converted first to a Unicode label and then back to an ASCII label), arbitrary domains can be impersonated.

Remediation

There is no fixed version for Debian:10 libidn2.

References

high severity

Out-of-bounds Write

  • Vulnerable module: libidn2/libidn2-0
  • Introduced through: libidn2/libidn2-0@2.0.5-1 and libidn2/libidn2-dev@2.0.5-1
  • Fixed in: 2.0.5-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libidn2/libidn2-0@2.0.5-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libidn2/libidn2-dev@2.0.5-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libidn2 package. See Remediation section below for Debian:10 relevant versions.

idn2_to_ascii_4i in lib/lookup.c in GNU libidn2 before 2.1.1 has a heap-based buffer overflow via a long domain string.

Remediation

Upgrade Debian:10 libidn2 to version 2.0.5-1+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libjpeg-turbo/libjpeg-dev
  • Introduced through: libjpeg-turbo/libjpeg-dev@1:1.5.2-2, libjpeg-turbo/libjpeg62-turbo@1:1.5.2-2+b1 and others
  • Fixed in: 1:1.5.2-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libjpeg-turbo/libjpeg-dev@1:1.5.2-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libjpeg-turbo/libjpeg62-turbo@1:1.5.2-2+b1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libjpeg-turbo/libjpeg62-turbo-dev@1:1.5.2-2+b1

NVD Description

Note: Versions mentioned in the description apply to the upstream libjpeg-turbo package. See Remediation section below for Debian:10 relevant versions.

libjpeg-turbo 2.0.4, and mozjpeg 4.0.0, has a heap-based buffer over-read in get_rgb_row() in rdppm.c via a malformed PPM input file.

Remediation

Upgrade Debian:10 libjpeg-turbo to version 1:1.5.2-2+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: libjpeg-turbo/libjpeg-dev
  • Introduced through: libjpeg-turbo/libjpeg-dev@1:1.5.2-2, libjpeg-turbo/libjpeg62-turbo@1:1.5.2-2+b1 and others
  • Fixed in: 1:1.5.2-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libjpeg-turbo/libjpeg-dev@1:1.5.2-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libjpeg-turbo/libjpeg62-turbo@1:1.5.2-2+b1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libjpeg-turbo/libjpeg62-turbo-dev@1:1.5.2-2+b1

NVD Description

Note: Versions mentioned in the description apply to the upstream libjpeg-turbo package. See Remediation section below for Debian:10 relevant versions.

In generate_jsimd_ycc_rgb_convert_neon of jsimd_arm64_neon.S, there is a possible out of bounds write due to a missing bounds check. This could lead to remote code execution in an unprivileged process with no additional execution privileges needed. User interaction is needed for exploitation.Product: AndroidVersions: Android-8.0 Android-8.1 Android-9 Android-10Android ID: A-120551338

Remediation

Upgrade Debian:10 libjpeg-turbo to version 1:1.5.2-2+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: libntlm/libntlm0
  • Introduced through: libntlm/libntlm0@1.5-1
  • Fixed in: 1.5-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libntlm/libntlm0@1.5-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libntlm package. See Remediation section below for Debian:10 relevant versions.

Libntlm through 1.5 relies on a fixed buffer size for tSmbNtlmAuthRequest, tSmbNtlmAuthChallenge, and tSmbNtlmAuthResponse read and write operations, as demonstrated by a stack-based buffer over-read in buildSmbNtlmAuthRequest in smbutil.c for a crafted NTLM request.

Remediation

Upgrade Debian:10 libntlm to version 1.5-1+deb10u1 or higher.

References

high severity

Buffer Overflow

  • Vulnerable module: libproxy/libproxy1v5
  • Introduced through: libproxy/libproxy1v5@0.4.15-5
  • Fixed in: 0.4.15-5+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libproxy/libproxy1v5@0.4.15-5

NVD Description

Note: Versions mentioned in the description apply to the upstream libproxy package. See Remediation section below for Debian:10 relevant versions.

url.cpp in libproxy through 0.4.15 is prone to a buffer overflow when PAC is enabled, as demonstrated by a large PAC file that is delivered without a Content-length header.

Remediation

Upgrade Debian:10 libproxy to version 0.4.15-5+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: libproxy/libproxy1v5
  • Introduced through: libproxy/libproxy1v5@0.4.15-5
  • Fixed in: 0.4.15-5+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libproxy/libproxy1v5@0.4.15-5

NVD Description

Note: Versions mentioned in the description apply to the upstream libproxy package. See Remediation section below for Debian:10 relevant versions.

url::recvline in url.cpp in libproxy 0.4.x through 0.4.15 allows a remote HTTP server to trigger uncontrolled recursion via a response composed of an infinite stream that lacks a newline character. This leads to stack exhaustion.

Remediation

Upgrade Debian:10 libproxy to version 0.4.15-5+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libssh2/libssh2-1
  • Introduced through: libssh2/libssh2-1@1.8.0-2.1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libssh2/libssh2-1@1.8.0-2.1

NVD Description

Note: Versions mentioned in the description apply to the upstream libssh2 package.

In libssh2 before 1.9.0, kex_method_diffie_hellman_group_exchange_sha256_key_exchange in kex.c has an integer overflow that could lead to an out-of-bounds read in the way packets are read from the server. A remote attacker who compromises a SSH server may be able to disclose sensitive information or cause a denial of service condition on the client system when a user connects to the server. This is related to an _libssh2_check_length mistake, and is different from the various issues fixed in 1.8.1, such as CVE-2019-3855.

Remediation

There is no fixed version for Debian:10 libssh2.

References

high severity

Improper Input Validation

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. When reading a file libwebp allocates an excessive amount of memory. The highest threat from this vulnerability is to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function ApplyFilter. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function ShiftBytes. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function ChunkVerifyAndAssign. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function WebPMuxCreateInternal. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function WebPMuxCreateInternal. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An out-of-bounds read was found in function ChunkAssignData. The highest threat from this vulnerability is to data confidentiality and to the service availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. A heap-based buffer overflow in function WebPDecodeRGBInto is possible due to an invalid check for buffer size. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. A heap-based buffer overflow was found in PutLE16(). The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Use After Free

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. A use-after-free was found due to a thread being killed too early. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Use of Uninitialized Resource

  • Vulnerable module: libwebp/libwebp-dev
  • Introduced through: libwebp/libwebp-dev@0.6.1-2, libwebp/libwebp6@0.6.1-2 and others
  • Fixed in: 0.6.1-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp-dev@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebp6@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpdemux2@0.6.1-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libwebp/libwebpmux3@0.6.1-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libwebp package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in libwebp in versions before 1.0.1. An unitialized variable is used in function ReadSymbol. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Remediation

Upgrade Debian:10 libwebp to version 0.6.1-2+deb10u1 or higher.

References

high severity

Buffer Overflow

  • Vulnerable module: libx11/libx11-6
  • Introduced through: libx11/libx11-6@2:1.6.7-1, libx11/libx11-data@2:1.6.7-1 and others
  • Fixed in: 2:1.6.7-1+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libx11/libx11-6@2:1.6.7-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libx11/libx11-data@2:1.6.7-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libx11/libx11-dev@2:1.6.7-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libx11/libx11-xcb1@2:1.6.7-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libx11 package. See Remediation section below for Debian:10 relevant versions.

LookupCol.c in X.Org X through X11R7.7 and libX11 before 1.7.1 might allow remote attackers to execute arbitrary code. The libX11 XLookupColor request (intended for server-side color lookup) contains a flaw allowing a client to send color-name requests with a name longer than the maximum size allowed by the protocol (and also longer than the maximum packet size for normal-sized packets). The user-controlled data exceeding the maximum size is then interpreted by the server as additional X protocol requests and executed, e.g., to disable X server authorization completely. For example, if the victim encounters malicious terminal control sequences for color codes, then the attacker may be able to take full control of the running graphical session.

Remediation

Upgrade Debian:10 libx11 to version 2:1.6.7-1+deb10u2 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: libx11/libx11-6
  • Introduced through: libx11/libx11-6@2:1.6.7-1, libx11/libx11-data@2:1.6.7-1 and others
  • Fixed in: 2:1.6.7-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libx11/libx11-6@2:1.6.7-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libx11/libx11-data@2:1.6.7-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libx11/libx11-dev@2:1.6.7-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libx11/libx11-xcb1@2:1.6.7-1

NVD Description

Note: Versions mentioned in the description apply to the upstream libx11 package. See Remediation section below for Debian:10 relevant versions.

An integer overflow vulnerability leading to a double-free was found in libX11. This flaw allows a local privileged attacker to cause an application compiled with libX11 to crash, or in some cases, result in arbitrary code execution. The highest threat from this flaw is to confidentiality, integrity as well as system availability.

Remediation

Upgrade Debian:10 libx11 to version 2:1.6.7-1+deb10u1 or higher.

References

high severity

Improper Resource Shutdown or Release

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

xmlSchemaPreRun in xmlschemas.c in libxml2 2.9.10 allows an xmlSchemaValidateStream memory leak.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u1 or higher.

References

high severity

Loop with Unreachable Exit Condition ('Infinite Loop')

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package.

parser.c in libxml2 before 2.9.5 does not prevent infinite recursion in parameter entities.

Remediation

There is no fixed version for Debian:10 libxml2.

References

high severity

Loop with Unreachable Exit Condition ('Infinite Loop')

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

xmlStringLenDecodeEntities in parser.c in libxml2 2.9.10 has an infinite loop in a certain end-of-file situation.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u1 or higher.

References

high severity

Missing Release of Resource after Effective Lifetime

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

xmlParseBalancedChunkMemoryRecover in parser.c in libxml2 before 2.9.10 has a memory leak related to newDoc->oldNs.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u1 or higher.

References

high severity

NULL Pointer Dereference

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

A NULL pointer dereference vulnerability exists in the xpath.c:xmlXPathCompOpEval() function of libxml2 through 2.9.8 when parsing an invalid XPath expression in the XPATH_OP_AND or XPATH_OP_OR case. Applications processing untrusted XSL format inputs with the use of the libxml2 library may be vulnerable to a denial of service attack due to a crash of the application.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u1 or higher.

References

high severity

Out-of-Bounds

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

There is a flaw in the xml entity encoding functionality of libxml2 in versions before 2.9.11. An attacker who is able to supply a crafted file to be processed by an application linked with the affected functionality of libxml2 could trigger an out-of-bounds read. The most likely impact of this flaw is to application availability, with some potential impact to confidentiality and integrity if an attacker is able to use memory information to further exploit the application.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u2 or higher.

References

high severity

Use After Free

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

There's a flaw in libxml2's xmllint in versions before 2.9.11. An attacker who is able to submit a crafted file to be processed by xmllint could trigger a use-after-free. The greatest impact of this flaw is to confidentiality, integrity, and availability.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u2 or higher.

References

high severity

Use After Free

  • Vulnerable module: libxml2/libxml2
  • Introduced through: libxml2/libxml2@2.9.4+dfsg1-7+b3 and libxml2/libxml2-dev@2.9.4+dfsg1-7+b3
  • Fixed in: 2.9.4+dfsg1-7+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxml2/libxml2@2.9.4+dfsg1-7+b3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxml2/libxml2-dev@2.9.4+dfsg1-7+b3

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:10 relevant versions.

There's a flaw in libxml2 in versions before 2.9.11. An attacker who is able to submit a crafted file to be processed by an application linked with libxml2 could trigger a use-after-free. The greatest impact from this flaw is to confidentiality, integrity, and availability.

Remediation

Upgrade Debian:10 libxml2 to version 2.9.4+dfsg1-7+deb10u2 or higher.

References

high severity

Access of Resource Using Incompatible Type ('Type Confusion')

  • Vulnerable module: libxslt/libxslt1-dev
  • Introduced through: libxslt/libxslt1-dev@1.1.32-2 and libxslt/libxslt1.1@1.1.32-2
  • Fixed in: 1.1.32-2.1~deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxslt/libxslt1-dev@1.1.32-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxslt/libxslt1.1@1.1.32-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libxslt package. See Remediation section below for Debian:10 relevant versions.

In numbers.c in libxslt 1.1.33, a type holding grouping characters of an xsl:number instruction was too narrow and an invalid character/length combination could be passed to xsltNumberFormatDecimal, leading to a read of uninitialized stack data.

Remediation

Upgrade Debian:10 libxslt to version 1.1.32-2.1~deb10u1 or higher.

References

high severity

Improper Access Control

  • Vulnerable module: libxslt/libxslt1-dev
  • Introduced through: libxslt/libxslt1-dev@1.1.32-2 and libxslt/libxslt1.1@1.1.32-2
  • Fixed in: 1.1.32-2.1~deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxslt/libxslt1-dev@1.1.32-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxslt/libxslt1.1@1.1.32-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libxslt package. See Remediation section below for Debian:10 relevant versions.

libxslt through 1.1.33 allows bypass of a protection mechanism because callers of xsltCheckRead and xsltCheckWrite permit access even upon receiving a -1 error code. xsltCheckRead can return -1 for a crafted URL that is not actually invalid and is subsequently loaded.

Remediation

Upgrade Debian:10 libxslt to version 1.1.32-2.1~deb10u1 or higher.

References

high severity

Use After Free

  • Vulnerable module: libxslt/libxslt1-dev
  • Introduced through: libxslt/libxslt1-dev@1.1.32-2 and libxslt/libxslt1.1@1.1.32-2
  • Fixed in: 1.1.32-2.2~deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxslt/libxslt1-dev@1.1.32-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxslt/libxslt1.1@1.1.32-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libxslt package. See Remediation section below for Debian:10 relevant versions.

In xsltCopyText in transform.c in libxslt 1.1.33, a pointer variable isn't reset under certain circumstances. If the relevant memory area happened to be freed and reused in a certain way, a bounds check could fail and memory outside a buffer could be written to, or uninitialized data could be disclosed.

Remediation

Upgrade Debian:10 libxslt to version 1.1.32-2.2~deb10u1 or higher.

References

high severity

Use of Uninitialized Resource

  • Vulnerable module: libxslt/libxslt1-dev
  • Introduced through: libxslt/libxslt1-dev@1.1.32-2 and libxslt/libxslt1.1@1.1.32-2
  • Fixed in: 1.1.32-2.1~deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxslt/libxslt1-dev@1.1.32-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* libxslt/libxslt1.1@1.1.32-2

NVD Description

Note: Versions mentioned in the description apply to the upstream libxslt package. See Remediation section below for Debian:10 relevant versions.

In numbers.c in libxslt 1.1.33, an xsl:number with certain format strings could lead to a uninitialized read in xsltNumberFormatInsertNumbers. This could allow an attacker to discern whether a byte on the stack contains the characters A, a, I, i, or 0, or any other character.

Remediation

Upgrade Debian:10 libxslt to version 1.1.32-2.1~deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: lz4/liblz4-1
  • Introduced through: lz4/liblz4-1@1.8.3-1
  • Fixed in: 1.8.3-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* lz4/liblz4-1@1.8.3-1

NVD Description

Note: Versions mentioned in the description apply to the upstream lz4 package. See Remediation section below for Debian:10 relevant versions.

There's a flaw in lz4. An attacker who submits a crafted file to an application linked with lz4 may be able to trigger an integer overflow, leading to calling of memmove() on a negative size argument, causing an out-of-bounds write and/or a crash. The greatest impact of this flaw is to availability, with some potential impact to confidentiality and integrity as well.

Remediation

Upgrade Debian:10 lz4 to version 1.8.3-1+deb10u1 or higher.

References

high severity

Improper Privilege Management

  • Vulnerable module: mailutils
  • Introduced through: mailutils@1:3.5-3, mailutils/libmailutils5@1:3.5-3 and others
  • Fixed in: 1:3.5-4

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* mailutils@1:3.5-3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* mailutils/libmailutils5@1:3.5-3
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* mailutils/mailutils-common@1:3.5-3

NVD Description

Note: Versions mentioned in the description apply to the upstream mailutils package. See Remediation section below for Debian:10 relevant versions.

maidag in GNU Mailutils before 3.8 is installed setuid and allows local privilege escalation in the url mode.

Remediation

Upgrade Debian:10 mailutils to version 1:3.5-4 or higher.

References

high severity

CVE-2020-13249

  • Vulnerable module: mariadb-10.3/libmariadb-dev
  • Introduced through: mariadb-10.3/libmariadb-dev@1:10.3.15-1, mariadb-10.3/libmariadb-dev-compat@1:10.3.15-1 and others
  • Fixed in: 1:10.3.23-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev@1:10.3.15-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev-compat@1:10.3.15-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* mariadb-10.3/libmariadb3@1:10.3.15-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* mariadb-10.3/mariadb-common@1:10.3.15-1

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.3 package. See Remediation section below for Debian:10 relevant versions.

libmariadb/mariadb_lib.c in MariaDB Connector/C before 3.1.8 does not properly validate the content of an OK packet received from a server. NOTE: although mariadb_lib.c was originally based on code shipped for MySQL, this issue does not affect any MySQL components supported by Oracle.

Remediation

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.23-0+deb10u1 or higher.

References

high severity

Improper Input Validation

  • Vulnerable module: mariadb-10.3/libmariadb-dev
  • Introduced through: mariadb-10.3/libmariadb-dev@1:10.3.15-1, mariadb-10.3/libmariadb-dev-compat@1:10.3.15-1 and others
  • Fixed in: 1:10.3.25-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev@1:10.3.15-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev-compat@1:10.3.15-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* mariadb-10.3/libmariadb3@1:10.3.15-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* mariadb-10.3/mariadb-common@1:10.3.15-1

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.3 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in the mysql-wsrep component of mariadb. Lack of input sanitization in wsrep_sst_method allows for command injection that can be exploited by a remote attacker to execute arbitrary commands on galera cluster nodes. This threatens the system's confidentiality, integrity, and availability. This flaw affects mariadb versions before 10.1.47, before 10.2.34, before 10.3.25, before 10.4.15 and before 10.5.6.

Remediation

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.25-0+deb10u1 or higher.

References

high severity

OS Command Injection

  • Vulnerable module: mariadb-10.3/libmariadb-dev
  • Introduced through: mariadb-10.3/libmariadb-dev@1:10.3.15-1, mariadb-10.3/libmariadb-dev-compat@1:10.3.15-1 and others
  • Fixed in: 1:10.3.29-0+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev@1:10.3.15-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* mariadb-10.3/libmariadb-dev-compat@1:10.3.15-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* mariadb-10.3/libmariadb3@1:10.3.15-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* mariadb-10.3/mariadb-common@1:10.3.15-1

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.3 package. See Remediation section below for Debian:10 relevant versions.

A remote code execution issue was discovered in MariaDB 10.2 before 10.2.37, 10.3 before 10.3.28, 10.4 before 10.4.18, and 10.5 before 10.5.9; Percona Server through 2021-03-03; and the wsrep patch through 2021-03-03 for MySQL. An untrusted search path leads to eval injection, in which a database SUPER user can execute OS commands after modifying wsrep_provider and wsrep_notify_cmd. NOTE: this does not affect an Oracle product.

Remediation

Upgrade Debian:10 mariadb-10.3 to version 1:10.3.29-0+deb10u1 or higher.

References

high severity

Use of a Broken or Risky Cryptographic Algorithm

  • Vulnerable module: nettle/libhogweed4
  • Introduced through: nettle/libhogweed4@3.4.1-1, nettle/libnettle6@3.4.1-1 and others
  • Fixed in: 3.4.1-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* nettle/libhogweed4@3.4.1-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* nettle/libnettle6@3.4.1-1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* nettle/nettle-dev@3.4.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream nettle package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in Nettle in versions before 3.7.2, where several Nettle signature verification functions (GOST DSA, EDDSA & ECDSA) result in the Elliptic Curve Cryptography point (ECC) multiply function being called with out-of-range scalers, possibly resulting in incorrect results. This flaw allows an attacker to force an invalid signature, causing an assertion failure or possible validation. The highest threat to this vulnerability is to confidentiality, integrity, as well as system availability.

Remediation

Upgrade Debian:10 nettle to version 3.4.1-1+deb10u1 or higher.

References

high severity

Allocation of Resources Without Limits or Throttling

  • Vulnerable module: nghttp2/libnghttp2-14
  • Introduced through: nghttp2/libnghttp2-14@1.36.0-2
  • Fixed in: 1.36.0-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* nghttp2/libnghttp2-14@1.36.0-2

NVD Description

Note: Versions mentioned in the description apply to the upstream nghttp2 package. See Remediation section below for Debian:10 relevant versions.

Some HTTP/2 implementations are vulnerable to window size manipulation and stream prioritization manipulation, potentially leading to a denial of service. The attacker requests a large amount of data from a specified resource over multiple streams. They manipulate window size and stream priority to force the server to queue the data in 1-byte chunks. Depending on how efficiently this data is queued, this can consume excess CPU, memory, or both.

Remediation

Upgrade Debian:10 nghttp2 to version 1.36.0-2+deb10u1 or higher.

References

high severity

Resource Exhaustion

  • Vulnerable module: nghttp2/libnghttp2-14
  • Introduced through: nghttp2/libnghttp2-14@1.36.0-2
  • Fixed in: 1.36.0-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* nghttp2/libnghttp2-14@1.36.0-2

NVD Description

Note: Versions mentioned in the description apply to the upstream nghttp2 package. See Remediation section below for Debian:10 relevant versions.

Some HTTP/2 implementations are vulnerable to resource loops, potentially leading to a denial of service. The attacker creates multiple request streams and continually shuffles the priority of the streams in a way that causes substantial churn to the priority tree. This can consume excess CPU.

Remediation

Upgrade Debian:10 nghttp2 to version 1.36.0-2+deb10u1 or higher.

References

high severity

Arbitrary File Overwrite

  • Vulnerable module: node
  • Introduced through: node@12.8.1
  • Fixed in: 12.14.0

Detailed paths

  • Introduced through: docker-image|circleci/node@12.8-buster-browsers-legacy node@12.8.1

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Arbitrary File Overwrite. It fails to prevent existing globally-installed binaries to be overwritten by other package installations. For example, if a package was installed globally and created a serve binary, any subsequent installs of packages that also create a serve binary would overwrite the first binary. This only affects files in /usr/local/bin.

For npm, this behaviour is still allowed in local installations and also through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.

Details

A Directory Traversal attack (also known as path traversal) aims to access files and directories that are stored outside the intended folder. By manipulating files with "dot-dot-slash (../)" sequences and its variations, or by using absolute file paths, it may be possible to access arbitrary files and directories stored on file system, including application source code, configuration, and other critical system files.

Directory Traversal vulnerabilities can be generally divided into two types:

  • Information Disclosure: Allows the attacker to gain information about the folder structure or read the contents of sensitive files on the system.

st is a module for serving static files on web pages, and contains a vulnerability of this type. In our example, we will serve files from the public route.

If an attacker requests the following URL from our server, it will in turn leak the sensitive private key of the root user.

curl http://localhost:8080/public/%2e%2e/%2e%2e/%2e%2e/%2e%2e/%2e%2e/root/.ssh/id_rsa

Note %2e is the URL encoded version of . (dot).

  • Writing arbitrary files: Allows the attacker to create or replace existing files. This type of vulnerability is also known as Zip-Slip.

One way to achieve this is by using a malicious zip archive that holds path traversal filenames. When each filename in the zip archive gets concatenated to the target extraction folder, without validation, the final path ends up outside of the target folder. If an executable or a configuration file is overwritten with a file containing malicious code, the problem can turn into an arbitrary code execution issue quite easily.

The following is an example of a zip archive with one benign file and one malicious file. Extracting the malicious file will result in traversing out of the target folder, ending up in /root/.ssh/ overwriting the authorized_keys file:

2018-04-15 22:04:29 .....           19           19  good.txt
2018-04-15 22:04:42 .....           20           20  ../../../../../../root/.ssh/authorized_keys

Remediation

Upgrade node to version 12.14.0, 10.18.0, 8.17.0, 13.4.0 or higher.

References

high severity

Arbitrary File Write

  • Vulnerable module: node
  • Introduced through: node@12.8.1
  • Fixed in: 12.14.0

Detailed paths

  • Introduced through: docker-image|circleci/node@12.8-buster-browsers-legacy node@12.8.1

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Arbitrary File Write. It fails to prevent access to folders outside of the intended node_modules folder through the bin field.

For npm, a properly constructed entry in the package.json bin field would allow a package publisher to modify and/or gain access to arbitrary files on a user’s system when the package is installed. This behaviour is possible through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.

Details

A Directory Traversal attack (also known as path traversal) aims to access files and directories that are stored outside the intended folder. By manipulating files with "dot-dot-slash (../)" sequences and its variations, or by using absolute file paths, it may be possible to access arbitrary files and directories stored on file system, including application source code, configuration, and other critical system files.

Directory Traversal vulnerabilities can be generally divided into two types:

  • Information Disclosure: Allows the attacker to gain information about the folder structure or read the contents of sensitive files on the system.

st is a module for serving static files on web pages, and contains a vulnerability of this type. In our example, we will serve files from the public route.

If an attacker requests the following URL from our server, it will in turn leak the sensitive private key of the root user.

curl http://localhost:8080/public/%2e%2e/%2e%2e/%2e%2e/%2e%2e/%2e%2e/root/.ssh/id_rsa

Note %2e is the URL encoded version of . (dot).

  • Writing arbitrary files: Allows the attacker to create or replace existing files. This type of vulnerability is also known as Zip-Slip.

One way to achieve this is by using a malicious zip archive that holds path traversal filenames. When each filename in the zip archive gets concatenated to the target extraction folder, without validation, the final path ends up outside of the target folder. If an executable or a configuration file is overwritten with a file containing malicious code, the problem can turn into an arbitrary code execution issue quite easily.

The following is an example of a zip archive with one benign file and one malicious file. Extracting the malicious file will result in traversing out of the target folder, ending up in /root/.ssh/ overwriting the authorized_keys file:

2018-04-15 22:04:29 .....           19           19  good.txt
2018-04-15 22:04:42 .....           20           20  ../../../../../../root/.ssh/authorized_keys

Remediation

Upgrade node to version 12.14.0, 10.18.0, 8.17.0, 13.4.0 or higher.

References

high severity

Denial of Service (DoS)

  • Vulnerable module: node
  • Introduced through: node@12.8.1
  • Fixed in: 12.21.0

Detailed paths

  • Introduced through: docker-image|circleci/node@12.8-buster-browsers-legacy node@12.8.1

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Denial of Service (DoS). When too many connection attempts with an HTTP2 unknownProtocol are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening. If no file descriptor limit is configured, then this leads to an excessive memory usage and causes the system to run out of memory.

Details

Denial of Service (DoS) describes a family of attacks, all aimed at making a system inaccessible to its intended and legitimate users.

Unlike other vulnerabilities, DoS attacks usually do not aim at breaching security. Rather, they are focused on making websites and services unavailable to genuine users resulting in downtime.

One popular Denial of Service vulnerability is DDoS (a Distributed Denial of Service), an attack that attempts to clog network pipes to the system by generating a large volume of traffic from many machines.

When it comes to open source libraries, DoS vulnerabilities allow attackers to trigger such a crash or crippling of the service by using a flaw either in the application code or from the use of open source libraries.

Two common types of DoS vulnerabilities:

  • High CPU/Memory Consumption- An attacker sending crafted requests that could cause the system to take a disproportionate amount of time to process. For example, commons-fileupload:commons-fileupload.

  • Crash - An attacker sending crafted requests that could cause the system to crash. For Example, npm ws package

Remediation

Upgrade node to version 15.10.0, 14.16.0, 12.21.0, 10.24.0 or higher.

References

high severity

HTTP Request Smuggling

  • Vulnerable module: node
  • Introduced through: node@12.8.1
  • Fixed in: 12.20.1

Detailed paths

  • Introduced through: docker-image|circleci/node@12.8-buster-browsers-legacy node@12.8.1

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to HTTP Request Smuggling. Two copies of a header field are allowed in a HTTP request, which causes Node.js to identifiy the first header and ignore the second.

Remediation

Upgrade node to version 10.23.1, 12.20.1, 14.15.4, 15.5.1 or higher.

References

high severity

HTTP Request Smuggling

  • Vulnerable module: node
  • Introduced through: node@12.8.1
  • Fixed in: 12.15.0

Detailed paths

  • Introduced through: docker-image|circleci/node@12.8-buster-browsers-legacy node@12.8.1

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to HTTP Request Smuggling. HTTP request smuggling is possible using malformed Transfer-Encoding header.

Remediation

Upgrade node to version 12.15.0, 13.8.0, 10.19.0 or higher.

References

high severity

Improper Certificate Validation

  • Vulnerable module: node
  • Introduced through: node@12.8.1
  • Fixed in: 12.22.1

Detailed paths

  • Introduced through: docker-image|circleci/node@12.8-buster-browsers-legacy node@12.8.1

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Improper Certificate Validation. There is insufficient verification of a certificate chain when using the X509_V_FLAG_X509_STRICT flag.

Remediation

Upgrade node to version 15.14.0, 14.16.1, 12.22.1, 10.24.1 or higher.

References

high severity

Improper Certificate Validation

  • Vulnerable module: node
  • Introduced through: node@12.8.1
  • Fixed in: 12.15.0

Detailed paths

  • Introduced through: docker-image|circleci/node@12.8-buster-browsers-legacy node@12.8.1

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Improper Certificate Validation. It is possible to trigger an assertion on a TLS server with a malformed certificate string. X509V3_EXT_print can return value different from 1 if the X509 extension does not support printing to a buffer. Instead of failing with an unrecoverable assertion. This vulnerability can be exploited by a user that can remotely connect to a TLS server and supply an invalid certificate, causing the server to crash. As such, this vulnerability could result in a denial-of-service vulnerability.

Remediation

Upgrade node to version 12.15.0, 13.8.0, 10.19.0 or higher.

References

high severity

Insufficient Hostname Verification

  • Vulnerable module: node
  • Introduced through: node@12.8.1
  • Fixed in: 12.18.0

Detailed paths

  • Introduced through: docker-image|circleci/node@12.8-buster-browsers-legacy node@12.8.1

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Insufficient Hostname Verification. TLS session reuse can lead to host certificate verification bypass.

session event is emitted after secure event on TLSSocket, but before secureConnect event. This is problematic for https.Agent because it must cache session only after verifying the remote peer's certificate.

Connecting to a server that presents an invalid certificate resulted in the session being cached after the handshake with the server and evicted right after a certifiate validation error and socket's destruction. A request initiated during this narrow window would pick the faulty session, send it to the malicious server and skip the verification of the server's certificate.

Remediation

Upgrade node to version 12.18.0, 14.4.0, 10.21.0 or higher.

References

high severity

Memory Corruption

  • Vulnerable module: node
  • Introduced through: node@12.8.1
  • Fixed in: 12.18.0

Detailed paths

  • Introduced through: docker-image|circleci/node@12.8-buster-browsers-legacy node@12.8.1

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Memory Corruption. napi_get_value_string_*() allows various kinds of memory corruption vulnerabilities. No further technical details are currently available.

Remediation

Upgrade node to version 12.18.0, 14.4.0, 10.21.0 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: node
  • Introduced through: node@12.8.1

Detailed paths

  • Introduced through: docker-image|circleci/node@12.8-buster-browsers-legacy node@12.8.1

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Out-of-bounds Read in libuv's uv__idna_toascii() function which is used to convert strings to ASCII. This is called by Node's dns module's lookup() function and can lead to information disclosures or crashes.

Remediation

Upgrade node to version 16.4.1, 14.17.2, 12.22.2 or higher.

References

high severity

Privilege Escalation

  • Vulnerable module: node
  • Introduced through: node@12.8.1

Detailed paths

  • Introduced through: docker-image|circleci/node@12.8-buster-browsers-legacy node@12.8.1

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Privilege Escalation under certain conditions on Windows platforms. More specifically, improper configuration of permissions in the installation directory allows an attacker to perform two different escalation attacks: PATH variable hijacking and DLL hijacking.

Remediation

Upgrade node to version 16.4.1, 14.17.2, 12.22.2 or higher.

References

high severity
new

Use After Free

  • Vulnerable module: node
  • Introduced through: node@12.8.1
  • Fixed in: 12.22.4

Detailed paths

  • Introduced through: docker-image|circleci/node@12.8-buster-browsers-legacy node@12.8.1

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Use After Free on close http2 on stream canceling. An attacker might be able to exploit the memory corruption to change process behaviour.

Remediation

Upgrade node to version 16.6.0, 14.17.4, 12.22.4 or higher.

References

high severity

Allocation of Resources Without Limits or Throttling

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* nss/libnss3@2:3.42.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package.

A flaw was found in the way NSS handled CCS (ChangeCipherSpec) messages in TLS 1.3. This flaw allows a remote attacker to send multiple CCS messages, causing a denial of service for servers compiled with the NSS library. The highest threat from this vulnerability is to system availability. This flaw affects NSS versions before 3.58.

Remediation

There is no fixed version for Debian:10 nss.

References

high severity

Improper Certificate Validation

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1
  • Fixed in: 2:3.42.1-1+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* nss/libnss3@2:3.42.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package. See Remediation section below for Debian:10 relevant versions.

In Network Security Services before 3.44, a malformed Netscape Certificate Sequence can cause NSS to crash, resulting in a denial of service.

Remediation

Upgrade Debian:10 nss to version 2:3.42.1-1+deb10u2 or higher.

References

high severity

Insufficient Verification of Data Authenticity

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1
  • Fixed in: 2:3.42.1-1+deb10u3

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* nss/libnss3@2:3.42.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package. See Remediation section below for Debian:10 relevant versions.

In Network Security Services (NSS) before 3.46, several cryptographic primitives had missing length checks. In cases where the application calling the library did not perform a sanity check on the inputs it could result in a crash due to a buffer overflow.

Remediation

Upgrade Debian:10 nss to version 2:3.42.1-1+deb10u3 or higher.

References

high severity

Out-of-Bounds

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1
  • Fixed in: 2:3.42.1-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* nss/libnss3@2:3.42.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package. See Remediation section below for Debian:10 relevant versions.

Empty or malformed p256-ECDH public keys may trigger a segmentation fault due values being improperly sanitized before being copied into memory and used. This vulnerability affects Firefox ESR < 60.8, Firefox < 68, and Thunderbird < 60.8.

Remediation

Upgrade Debian:10 nss to version 2:3.42.1-1+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1
  • Fixed in: 2:3.42.1-1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* nss/libnss3@2:3.42.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package. See Remediation section below for Debian:10 relevant versions.

When importing a curve25519 private key in PKCS#8format with leading 0x00 bytes, it is possible to trigger an out-of-bounds read in the Network Security Services (NSS) library. This could lead to information disclosure. This vulnerability affects Firefox ESR < 60.8, Firefox < 68, and Thunderbird < 60.8.

Remediation

Upgrade Debian:10 nss to version 2:3.42.1-1+deb10u1 or higher.

References

high severity

Out-of-bounds Read

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* nss/libnss3@2:3.42.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package.

A flaw was found in the way CHACHA20-POLY1305 was implemented in NSS in versions before 3.55. When using multi-part Chacha20, it could cause out-of-bounds reads. This issue was fixed by explicitly disabling multi-part ChaCha20 (which was not functioning correctly) and strictly enforcing tag length. The highest threat from this vulnerability is to confidentiality and system availability.

Remediation

There is no fixed version for Debian:10 nss.

References

high severity

Out-of-bounds Write

  • Vulnerable module: nss/libnss3
  • Introduced through: nss/libnss3@2:3.42.1-1
  • Fixed in: 2:3.42.1-1+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* nss/libnss3@2:3.42.1-1

NVD Description

Note: Versions mentioned in the description apply to the upstream nss package. See Remediation section below for Debian:10 relevant versions.

When encrypting with a block cipher, if a call to NSC_EncryptUpdate was made with data smaller than the block size, a small out of bounds write could occur. This could have caused heap corruption and a potentially exploitable crash. This vulnerability affects Thunderbird < 68.3, Firefox ESR < 68.3, and Firefox < 71.

Remediation

Upgrade Debian:10 nss to version 2:3.42.1-1+deb10u2 or higher.

References

high severity

Numeric Errors

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1 and openexr/libopenexr23@2.2.1-4.1
  • Fixed in: 2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openexr/libopenexr-dev@2.2.1-4.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openexr/libopenexr23@2.2.1-4.1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package. See Remediation section below for Debian:10 relevant versions.

In OpenEXR 2.2.0, an invalid write of size 1 in the bufferedReadPixels function in ImfInputFile.cpp could cause the application to crash or execute arbitrary code.

Remediation

Upgrade Debian:10 openexr to version 2.2.1-4.1+deb10u1 or higher.

References

high severity

Numeric Errors

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1 and openexr/libopenexr23@2.2.1-4.1
  • Fixed in: 2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openexr/libopenexr-dev@2.2.1-4.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openexr/libopenexr23@2.2.1-4.1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package. See Remediation section below for Debian:10 relevant versions.

In OpenEXR 2.2.0, an invalid write of size 8 in the storeSSE function in ImfOptimizedPixelReading.h could cause the application to crash or execute arbitrary code.

Remediation

Upgrade Debian:10 openexr to version 2.2.1-4.1+deb10u1 or higher.

References

high severity

Numeric Errors

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1 and openexr/libopenexr23@2.2.1-4.1
  • Fixed in: 2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openexr/libopenexr-dev@2.2.1-4.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openexr/libopenexr23@2.2.1-4.1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package. See Remediation section below for Debian:10 relevant versions.

In OpenEXR 2.2.0, an invalid write of size 2 in the = operator function in half.h could cause the application to crash or execute arbitrary code.

Remediation

Upgrade Debian:10 openexr to version 2.2.1-4.1+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: openexr/libopenexr-dev
  • Introduced through: openexr/libopenexr-dev@2.2.1-4.1 and openexr/libopenexr23@2.2.1-4.1
  • Fixed in: 2.2.1-4.1+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openexr/libopenexr-dev@2.2.1-4.1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openexr/libopenexr23@2.2.1-4.1

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package. See Remediation section below for Debian:10 relevant versions.

makeMultiView.cpp in exrmultiview in OpenEXR 2.3.0 has an out-of-bounds write, leading to an assertion failure or possibly unspecified other impact.

Remediation

Upgrade Debian:10 openexr to version 2.2.1-4.1+deb10u1 or higher.

References

high severity

CVE-2020-14583

  • Vulnerable module: openjdk-11/openjdk-11-jdk
  • Introduced through: openjdk-11/openjdk-11-jdk@11.0.4+11-1~deb10u1, openjdk-11/openjdk-11-jdk-headless@11.0.4+11-1~deb10u1 and others
  • Fixed in: 11.0.8+10-1~deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jdk@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jdk-headless@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jre@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jre-headless@11.0.4+11-1~deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openjdk-11 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: Libraries). Supported versions that are affected are Java SE: 7u261, 8u251, 11.0.7 and 14.0.1; Java SE Embedded: 8u251. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks require human interaction from a person other than the attacker and while the vulnerability is in Java SE, Java SE Embedded, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in takeover of Java SE, Java SE Embedded. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.1 Base Score 8.3 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H).

Remediation

Upgrade Debian:10 openjdk-11 to version 11.0.8+10-1~deb10u1 or higher.

References

high severity

CVE-2020-14593

  • Vulnerable module: openjdk-11/openjdk-11-jdk
  • Introduced through: openjdk-11/openjdk-11-jdk@11.0.4+11-1~deb10u1, openjdk-11/openjdk-11-jdk-headless@11.0.4+11-1~deb10u1 and others
  • Fixed in: 11.0.8+10-1~deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jdk@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jdk-headless@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jre@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jre-headless@11.0.4+11-1~deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openjdk-11 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: 2D). Supported versions that are affected are Java SE: 7u261, 8u251, 11.0.7 and 14.0.1; Java SE Embedded: 8u251. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks require human interaction from a person other than the attacker and while the vulnerability is in Java SE, Java SE Embedded, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all Java SE, Java SE Embedded accessible data. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.1 Base Score 7.4 (Integrity impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N).

Remediation

Upgrade Debian:10 openjdk-11 to version 11.0.8+10-1~deb10u1 or higher.

References

high severity

CVE-2020-2604

  • Vulnerable module: openjdk-11/openjdk-11-jdk
  • Introduced through: openjdk-11/openjdk-11-jdk@11.0.4+11-1~deb10u1, openjdk-11/openjdk-11-jdk-headless@11.0.4+11-1~deb10u1 and others
  • Fixed in: 11.0.6+10-1~deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jdk@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jdk-headless@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jre@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jre-headless@11.0.4+11-1~deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openjdk-11 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: Serialization). Supported versions that are affected are Java SE: 7u241, 8u231, 11.0.5 and 13.0.1; Java SE Embedded: 8u231. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks of this vulnerability can result in takeover of Java SE, Java SE Embedded. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets (in Java SE 8), that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability can also be exploited by using APIs in the specified Component, e.g., through a web service which supplies data to the APIs. CVSS v3.0 Base Score 8.1 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H).

Remediation

Upgrade Debian:10 openjdk-11 to version 11.0.6+10-1~deb10u1 or higher.

References

high severity

CVE-2020-2803

  • Vulnerable module: openjdk-11/openjdk-11-jdk
  • Introduced through: openjdk-11/openjdk-11-jdk@11.0.4+11-1~deb10u1, openjdk-11/openjdk-11-jdk-headless@11.0.4+11-1~deb10u1 and others
  • Fixed in: 11.0.7+10-3~deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jdk@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jdk-headless@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jre@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jre-headless@11.0.4+11-1~deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openjdk-11 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: Libraries). Supported versions that are affected are Java SE: 7u251, 8u241, 11.0.6 and 14; Java SE Embedded: 8u241. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks require human interaction from a person other than the attacker and while the vulnerability is in Java SE, Java SE Embedded, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in takeover of Java SE, Java SE Embedded. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.0 Base Score 8.3 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H).

Remediation

Upgrade Debian:10 openjdk-11 to version 11.0.7+10-3~deb10u1 or higher.

References

high severity

CVE-2020-2805

  • Vulnerable module: openjdk-11/openjdk-11-jdk
  • Introduced through: openjdk-11/openjdk-11-jdk@11.0.4+11-1~deb10u1, openjdk-11/openjdk-11-jdk-headless@11.0.4+11-1~deb10u1 and others
  • Fixed in: 11.0.7+10-3~deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jdk@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jdk-headless@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jre@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jre-headless@11.0.4+11-1~deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openjdk-11 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the Java SE, Java SE Embedded product of Oracle Java SE (component: Libraries). Supported versions that are affected are Java SE: 7u251, 8u241, 11.0.6 and 14; Java SE Embedded: 8u241. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks require human interaction from a person other than the attacker and while the vulnerability is in Java SE, Java SE Embedded, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in takeover of Java SE, Java SE Embedded. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.0 Base Score 8.3 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H).

Remediation

Upgrade Debian:10 openjdk-11 to version 11.0.7+10-3~deb10u1 or higher.

References

high severity

CVE-2020-2816

  • Vulnerable module: openjdk-11/openjdk-11-jdk
  • Introduced through: openjdk-11/openjdk-11-jdk@11.0.4+11-1~deb10u1, openjdk-11/openjdk-11-jdk-headless@11.0.4+11-1~deb10u1 and others
  • Fixed in: 11.0.7+10-3~deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jdk@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jdk-headless@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jre@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jre-headless@11.0.4+11-1~deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openjdk-11 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the Java SE product of Oracle Java SE (component: JSSE). Supported versions that are affected are Java SE: 11.0.6 and 14. Easily exploitable vulnerability allows unauthenticated attacker with network access via HTTPS to compromise Java SE. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all Java SE accessible data. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.0 Base Score 7.5 (Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N).

Remediation

Upgrade Debian:10 openjdk-11 to version 11.0.7+10-3~deb10u1 or higher.

References

high severity
new

CVE-2021-2388

  • Vulnerable module: openjdk-11/openjdk-11-jdk
  • Introduced through: openjdk-11/openjdk-11-jdk@11.0.4+11-1~deb10u1, openjdk-11/openjdk-11-jdk-headless@11.0.4+11-1~deb10u1 and others
  • Fixed in: 11.0.12+7-2~deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jdk@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jdk-headless@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jre@11.0.4+11-1~deb10u1
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjdk-11/openjdk-11-jre-headless@11.0.4+11-1~deb10u1

NVD Description

Note: Versions mentioned in the description apply to the upstream openjdk-11 package. See Remediation section below for Debian:10 relevant versions.

Vulnerability in the Java SE, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Hotspot). Supported versions that are affected are Java SE: 8u291, 11.0.11, 16.0.1; Oracle GraalVM Enterprise Edition: 20.3.2 and 21.1.0. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Oracle GraalVM Enterprise Edition. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in takeover of Java SE, Oracle GraalVM Enterprise Edition. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.1 Base Score 7.5 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H).

Remediation

Upgrade Debian:10 openjdk-11 to version 11.0.12+7-2~deb10u1 or higher.

References

high severity

Heap-based Buffer Overflow

  • Vulnerable module: openjpeg2/libopenjp2-7
  • Introduced through: openjpeg2/libopenjp2-7@2.3.0-2 and openjpeg2/libopenjp2-7-dev@2.3.0-2
  • Fixed in: 2.3.0-2+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjpeg2/libopenjp2-7@2.3.0-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjpeg2/libopenjp2-7-dev@2.3.0-2

NVD Description

Note: Versions mentioned in the description apply to the upstream openjpeg2 package. See Remediation section below for Debian:10 relevant versions.

A heap-buffer overflow was found in the way openjpeg2 handled certain PNG format files. An attacker could use this flaw to cause an application crash or in some cases execute arbitrary code with the permission of the user running such an application.

Remediation

Upgrade Debian:10 openjpeg2 to version 2.3.0-2+deb10u2 or higher.

References

high severity

Integer Overflow or Wraparound

  • Vulnerable module: openjpeg2/libopenjp2-7
  • Introduced through: openjpeg2/libopenjp2-7@2.3.0-2 and openjpeg2/libopenjp2-7-dev@2.3.0-2
  • Fixed in: 2.3.0-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjpeg2/libopenjp2-7@2.3.0-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjpeg2/libopenjp2-7-dev@2.3.0-2

NVD Description

Note: Versions mentioned in the description apply to the upstream openjpeg2 package. See Remediation section below for Debian:10 relevant versions.

An improper computation of p_tx0, p_tx1, p_ty0 and p_ty1 in the function opj_get_encoding_parameters in openjp2/pi.c in OpenJPEG through 2.3.0 can lead to an integer overflow.

Remediation

Upgrade Debian:10 openjpeg2 to version 2.3.0-2+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: openjpeg2/libopenjp2-7
  • Introduced through: openjpeg2/libopenjp2-7@2.3.0-2 and openjpeg2/libopenjp2-7-dev@2.3.0-2
  • Fixed in: 2.3.0-2+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjpeg2/libopenjp2-7@2.3.0-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjpeg2/libopenjp2-7-dev@2.3.0-2

NVD Description

Note: Versions mentioned in the description apply to the upstream openjpeg2 package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in OpenJPEG’s encoder. This flaw allows an attacker to pass specially crafted x,y offset input to OpenJPEG to use during encoding. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.

Remediation

Upgrade Debian:10 openjpeg2 to version 2.3.0-2+deb10u2 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: openjpeg2/libopenjp2-7
  • Introduced through: openjpeg2/libopenjp2-7@2.3.0-2 and openjpeg2/libopenjp2-7-dev@2.3.0-2
  • Fixed in: 2.3.0-2+deb10u1

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjpeg2/libopenjp2-7@2.3.0-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjpeg2/libopenjp2-7-dev@2.3.0-2

NVD Description

Note: Versions mentioned in the description apply to the upstream openjpeg2 package. See Remediation section below for Debian:10 relevant versions.

OpenJPEG before 2.3.1 has a heap buffer overflow in color_apply_icc_profile in bin/common/color.c.

Remediation

Upgrade Debian:10 openjpeg2 to version 2.3.0-2+deb10u1 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: openjpeg2/libopenjp2-7
  • Introduced through: openjpeg2/libopenjp2-7@2.3.0-2 and openjpeg2/libopenjp2-7-dev@2.3.0-2
  • Fixed in: 2.3.0-2+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjpeg2/libopenjp2-7@2.3.0-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjpeg2/libopenjp2-7-dev@2.3.0-2

NVD Description

Note: Versions mentioned in the description apply to the upstream openjpeg2 package. See Remediation section below for Debian:10 relevant versions.

OpenJPEG through 2.3.1 has a heap-based buffer overflow in opj_t1_clbl_decode_processor in openjp2/t1.c because of lack of opj_j2k_update_image_dimensions validation.

Remediation

Upgrade Debian:10 openjpeg2 to version 2.3.0-2+deb10u2 or higher.

References

high severity

Out-of-bounds Write

  • Vulnerable module: openjpeg2/libopenjp2-7
  • Introduced through: openjpeg2/libopenjp2-7@2.3.0-2 and openjpeg2/libopenjp2-7-dev@2.3.0-2
  • Fixed in: 2.3.0-2+deb10u2

Detailed paths

  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjpeg2/libopenjp2-7@2.3.0-2
  • Introduced through: circleci/node:12.8-buster-browsers-legacy@* openjpeg2/libopenjp2-7-dev@2.3.0-2

NVD Description

Note: Versions mentioned in the description apply to the upstream openjpeg2 package. See Remediation section below for Debian:10 relevant versions.

opj_t1_clbl_decode_processor in openjp2/t1.c in OpenJPEG 2.3.1 through 2020-01-28 has a heap-based buffer overflow in the qmfbid==1 case, a different issue than CVE-2020-6851.

Remediation

Upgrade Debian:10 openjpeg2 to version 2.3.0-2+deb10u2 or higher.

References

high severity