mf-google-trends-api

v1.0.5

an API layer on top of google trends

MIT
Latest version published 1 year ago
    npm install mf-google-trends-api
  

Package Health Score

52 / 100
Make sure the packages you're using are safe to use
Secure my Project

Popularity

Limited
Download trend

Weekly Downloads (2)

Dependents
10
GitHub Stars
685
Forks
141
Contributors
9

The npm package mf-google-trends-api receives a total of 2 downloads a week. As such, we scored mf-google-trends-api popularity level to be Limited.

Based on project statistics from the GitHub repository for the npm package mf-google-trends-api, we found that it has been starred 685 times, and that 10 other projects in the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

No known security issues
Powered by Snyk

Security and license risk for significant versions

All Versions

Direct Vulnerabilities

1.0.5
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

1.0.5
  • 0
    H
  • 0
    M
  • 0
    L

License Risks

1.0.5
  • 0
    H
  • 0
    M
  • 0
    L
All security vulnerabilities belong to production dependencies of direct and indirect packages.

License
MIT

Security Policy
No

We found a way for you to contribute to the project! Looks like mf-google-trends-api is missing a security policy.


You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

    # Install the Snyk CLI and test your project
npm i snyk -g && snyk test mf-google-trends-api
Keep your project free of vulnerabilities with Snyk

Maintenance

Inactive

Commit Frequency

Open Issues
37
Open PR
4
Last Release
1 year ago
Last Commit
5 months ago

Further analysis of the maintenance status of mf-google-trends-api based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Inactive.

An important project maintenance signal to consider for mf-google-trends-api is that it hasn't seen any new versions released to npm in the past 12 months, and could be considered as a discontinued project, or that which receives low attention from its maintainers.

In the past month we didn't find any pull request activity or change in issues status has been detected for the GitHub repository.

Community

Limited
Readme.md
Yes
Contributing.md
No
Code of Conduct
No
Contributors
9
Funding
No

This project has seen only 10 or less contributors.

We found a way for you to contribute to the project! Looks like mf-google-trends-api is missing a Code of Conduct.


Embed Package Health Score Badge

package health: 52/100 package health 52/100

Package

Node.js Compatibility
not defined

Age
2 years
Dependencies
0 Direct
Versions
7
Install Size
113 kB
Dist-tags
1
# of Files
16
Maintainers
1
TS Typings
No

mf-google-trends-api has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.