klassi-js

v3.2.1

A debuggable Javascript BDD testing framework. It's simple and easy to use, its built on webdriverio and nodejs

Apache-2.0
Latest version published 3 months ago
    npm install klassi-js
  
We couldn't find any similar packages Browse all packages

Package Health Score

48 / 100
  • Popularity
    Limited
  • Maintenance
    Inactive
  • Security
    Security review needed
  • Community
    Sustainable
Make sure the open source you're using is safe to use Secure my Project

Popularity

Limited
Weekly Downloads (1)
Dependents
0
GitHub Stars
30
Forks
22
Contributors
4

The npm package klassi-js receives a total of 1 downloads a week. As such, we scored klassi-js popularity level to be Limited.

Based on project statistics from the GitHub repository for the npm package klassi-js, we found that it has been starred 30 times, and that 0 other projects on the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

Security review needed

Security and license risk for significant versions

All Versions

Direct Vulnerabilities

2.3.5
2.5.0
3.1.0
3.2.1
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

2.3.5
2.5.0
3.1.0
3.2.1

License Risks

2.3.5
2.5.0
3.1.0
3.2.1
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
All security vulnerabilities belong to production dependencies of direct and indirect packages.

Security Policy
No

Snyk detected that the latest version of klassi-js has a security vulnerability.

We highly advise you to review these security issues.

You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

We found a way for you to contribute to the project! Looks like klassi-js is missing a security policy.

    # Install the Snyk CLI and test your project
npm i snyk && snyk test klassi-js
Fix it in your project with Snyk!

Maintenance

Inactive
Commit Frequency
Open Issues
0
Merged PR
38
Open PR
0
Last Commit
2 months ago

Further analysis of the maintenance status of klassi-js based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Inactive.

We found that klassi-js demonstrates a positive version release cadence with at least one new version released in the past 12 months.

As a healthy sign for on-going project maintenance, we found that the GitHub repository had at least 1 pull request or issue interacted with by the community.

Community

Sustainable
Readme.md
Yes
Contributing.md
No
Code of Conduct
No
Contributors
4
Funding
No
License
Apache-2.0

This project has seen only 10 or less contributors.

We found a way for you to contribute to the project! Looks like klassi-js is missing a Code of Conduct.


Embed Package Health Score Badge

package health: 48/100 package health 48/100

Package

Node.js Compatibility
not defined

Age
2 years
Dependencies
20 Direct / 335 Total
Versions
4
Install Size
773 kB
Dist-tags
1
# of Files
44
Maintainers
1
TS Typings
No

We detected a total of 335 direct & transitive dependencies for klassi-js. See the full dependency tree of klassi-js

klassi-js has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.